(Untitled)

[プロバイダ] タブ

[プロバイダ] タブを使用して、アクセスするデータの種類に対して適切な OLE DB プロバイダを選択します。いくつかのアプリケーションでは、プロバイダを指定したり、現在の選択を変更することはできません。このタブは、アプリケーションで OLE DB プロバイダの設定を変更できる場合にのみ表示されます。データ リンクは、アプリケーションと一緒に、または別個のファイルとして保存できます。データ リンク作成の詳細については、「MDAC SDK」にある「Creating a Data Link」を参照してください。

オプション | 説明
[OLE DB プロバイダ] | コンピュータに登録されているすべての OLE DB プロバイダの一覧が表示されます。プロバイダの詳細については、「MDAC SDK」にある「Microsoft OLE DB Providers Overview」を参照してください。
[次へ] | 選択した OLE DB プロバイダの [接続] タブが開きます。

注意 目的のプロバイダをダブルクリックすると、[接続] タブへ直接移動できます。データ リンクの詳細については、「Data Link API リファレンス」を参照してください。


[詳細設定] タブ

[詳細設定] タブを使用して、データのその他の初期化プロパティを表示および設定します。

データ リンク プロパティのダイアログ ボックスの [詳細設定] タブはプロバイダ固有のもので、選択した OLE DB プロバイダに必要な初期化プロパティのみが表示されます。初期化プロパティの詳細設定については、選択した OLE DB プロバイダのマニュアルを参照してください。

次の表は、初期化オプションの説明です。

オプション | 説明
[偽装レベル] サーバーがクライアントを偽装するときに使用できる偽装のレベルです。このプロパティは、リモート プロシージャ コール (RPC) 以外のネットワーク接続でのみ使用できます。ここで設定する偽装レベルは RPC で使用するレベルに類似しています。このプロパティの値は、認証された RPC 接続に対して指定できる偽装レベルに直接対応していますが、認証された RPC 以外の接続に適用することも可能です。次のレベルから選択します。
  • [Anonymous] - クライアントはサーバーに対して匿名になります。サーバーにおける処理でクライアントに関する識別情報を取得すること、およびクライアントの権限を借用することはできません。

  • [Delegate] - クライアントとして機能している間は、サーバーでの処理でクライアントのセキュリティ コンテキストを借用することができます。また、サーバーでの処理では、クライアントとして機能している間に、ほかのサーバーへの外部呼び出しを実行することもできます。

  • [Identify] - サーバーはクライアントの ID を取得できます。サーバーはアクセス制御リスト (ACL) チェックに対してクライアントの権限を借用できますが、クライアントとしてシステム オブジェクトにアクセスすることはできません。

  • [Impersonate] - クライアントとして機能している間は、サーバーでの処理でクライアントのセキュリティ コンテキストを借用することができます。この情報は、個々の呼び出しに応じてではなく、接続が確立されたときに取得されます。
[保護レベル] クライアントとサーバー間で送信されるデータ保護のレベルです。このプロパティは、RPC 以外のネットワーク接続でのみ使用できます。ここで設定する保護レベルは RPC で使用するレベルに類似しています。このプロパティの値は、認証された RPC 接続に対して指定できる保護レベルに直接対応していますが、認証された RPC 以外の接続に適用することも可能です。次のレベルから選択します。
  • [Call] - クライアントからサーバーに要求が送信されるとき、最初にデータ ソースの認証が行われます。

  • [Connect] - クライアントがサーバーとの接続を確立した場合にのみ認証が行われます。

  • [None] - サーバーに送信されるデータの認証は行われません。

  • [Pkt] - 受信したすべてのデータがクライアントから発信されたことを認証します。

  • [Pkt Integrity] - 受信したすべてのデータがクライアントから発信されたこと、およびデータが送信中に変更されていないことを認証します。

  • [Pkt Privacy] - 受信したすべてのデータがクライアントから発信されたこと、およびデータが送信中に変更されていないことを認証し、暗号化によってデータの機密性を保護します。
[接続タイムアウト] | OLE DB プロバイダが初期化の完了を待つ時間を秒単位で指定します。初期化がタイム アウトになるとエラーが返され、接続は作成されません。
[アクセス許可] 次の中から 1 つまたは複数の権限を選択します。
  • [Read] - 読み取り専用。

  • [ReadWrite] - 読み取りアクセス権および書き込みアクセス権。

  • [Share Deny None] - ほかのユーザーに対して、読み込みアクセス権および書き込みアクセス権を拒否することができません。

  • [Share Deny Read] - ほかのユーザーは読み取りモードで開くことができません。

  • [Share Deny Write] - ほかのユーザーは書き込みモードで開くことができません。

  • [Share Exclusive] - ほかのユーザーは読み込み/書き込みモードで開くことができません。

  • [Write] - 書き込み専用。

注意 データ リンク初期化の詳細については、「Data Link API リファレンス」を参照してください。


[すべて] タブ

[すべて] タブを使用して、選択した OLE DB プロバイダで使用可能なすべての OLE DB 初期化プロパティを表示および編集します。プロパティは、使用する OLE DB プロバイダによって異なります。初期化プロパティの詳細については、選択した OLE DB プロバイダのマニュアルを参照してください。

オプション | 説明
[初期化プロパティの一覧] | すべてのプロパティとそれらの現在値が表示されます。
[値の編集] | 選択したプロパティのための [プロパティの値を編集] ダイアログ ボックスが開きます。

注意 目的のプロパティをダブルクリックすると、[プロパティの値を編集] ダイアログ ボックスを開くことができます。データ リンク初期化の詳細については、「Data Link API リファレンス」を参照してください。


[接続] タブ

[接続] タブを使用して、OLE DB プロバイダを使ってデータに接続する方法を指定します。

データ リンク プロパティのダイアログ ボックスの [接続] タブはプロバイダ固有のもので、選択した OLE DB プロバイダに必要な接続プロパティのみが表示されます。接続プロパティでは、データの場所およびデータに接続する方法を指定します。詳細については、選択した OLE DB プロバイダのマニュアルを参照してください。

次の表は、接続オプションの説明です。

オプション | 説明
[データ ソース] | アクセスするデータ ソースの名前を入力します。通常、サーバー名です。
[場所] | アクセスするデータ ソースの場所を入力します。通常、データベース名です。
[Windows NT の統合セキュリティを使用する] | ユーザーを識別するために認証サービスを使用する場合は、このオプションを選択します。 この機能を使用するには、選択した OLE DB プロバイダが認証サービスをサポートしている必要があります。OLE DB Provider for SQL Server は、認証サービスをサポートしています。認証サービスを使用するには、データ ソース内の許可も必要です。
[特定のユーザー名とパスワードを使用する] | 与えられたユーザー名とパスワードを使用してデータ ソースへのログオン情報を認証する場合は、このオプションを選択します。
[ユーザー名] | データ ソースへのログオン認証に使用するユーザー ID を入力します。
[パスワード] | データ ソースへのログオン認証に使用するパスワードを入力します。
[パスワードを空にする] | 指定されたプロバイダは、接続文字列の中に空白のパスワードを含めて返すことができます。
[パスワードを保存する] | パスワードを接続文字列に含めて保存することができます。パスワードが接続文字列に含まれるかどうかは、呼び出しを行うアプリケーションの機能によって異なります。 注意 パスワードを保存した場合は、パスワードはマスクおよび暗号化されずに保存されて使用されます。
[使用する初期カタログを入力します] | 接続時にアクセスするカタログを入力します。
[接続のテスト] | 指定したデータ ソースへの接続をテストする場合にクリックします。接続が失敗した場合は、設定が正しいことを確認してください。たとえば、スペルが誤っていたり大文字と小文字の区別を間違えると、接続が失敗することがあります。

注意 データ リンク接続の詳細については、「Data Link API リファレンス」を参照してください。


Jet の [接続] タブ

[接続] タブを使用して、Microsoft Access データに接続する方法を指定します。

この [接続] タブはプロバイダ固有のもので、OLE DB Provider for Microsoft Jet に必要な接続プロパティのみが表示されます。

オプション | 説明
[データベース名を選択または入力します] | アクセスする Microsoft Access データベース ファイル (.mdb) の名前を入力します。ファイルを参照するには、[参照] をクリックします。
[ユーザー名] | データ ソースへのログオン認証に使用するユーザー ID を入力します。
[パスワード] | データ ソースへのログオン認証に使用するパスワードを入力します。
[パスワードを空にする] | 指定されたプロバイダは、接続文字列の中に空白のパスワードを含めて返すことができます。
[パスワードを保存する] | パスワードを接続文字列に含めて保存することができます。パスワードが接続文字列に含まれるかどうかは、呼び出しを行うアプリケーションの機能によって異なります。 注意 パスワードを保存した場合は、パスワードはマスクおよび暗号化されずに保存されて使用されます。
[接続のテスト] | 指定したデータ ソースへの接続をテストする場合にクリックします。接続が失敗した場合は、設定が正しいことを確認してください。たとえば、スペルが誤っていたり大文字と小文字の区別を間違えると、接続が失敗することがあります。

注意 データ リンク接続の詳細については、「Data Link API リファレンス」を参照してください。


ODBC の [接続] タブ

[接続] タブを使用して、ODBC データに接続する方法を指定します。

この [接続] タブはプロバイダ固有のもので、Microsoft OLE DB Provider for ODBC に必要な接続プロパティのみが表示されます。

オプション | 説明
[データ ソース名を使用する] | アクセスする ODBC データ ソース名 (DSN) を一覧から選択するか、または入力します。ODBC データ ソース アドミニストレータを使って、ソースを追加することができます。[更新] をクリックすると、一覧の内容が更新されます。
[接続文字列を使用する] | 既存の DSN を使用する代わりに、ODBC 接続文字列を入力または作成できます。
[ビルド] [データ ソースの選択] ダイアログ ボックスが開きます。データ ソースを選択すると、そのデータ ソースに含まれている接続文字列がデータ リンク プロパティのダイアログ ボックスの [接続] タブに表示されます。

ファイル データ ソースを選択した場合、DSN は ODBC 接続文字列に反映されていません。ODBC 接続文字列はデータ リンク ファイル (.UDL) で保持され、選択したファイル データ ソースには依存しません。

コンピュータ データ ソースを選択した場合、DSN は ODBC 接続文字列に反映されています。ODBC 接続文字列は、選択したコンピュータ データ ソースを参照します。別のシステムのユーザーがデータ リンク ファイル (.UDL) にアクセスするには、そのユーザーのコンピュータにコンピュータ データ ソースがインストールされている必要があります。
[ユーザー名] | データ ソースへのログオン認証に使用するユーザー ID を入力します。
[パスワード] | データ ソースへのログオン認証に使用するパスワードを入力します。
[パスワードを空にする] | 指定されたプロバイダは、接続文字列の中に空白のパスワードを含めて返すことができます。
[パスワードを保存する] パスワードを接続文字列に含めて保存することができます。パスワードが接続文字列に含まれるかどうかは、呼び出しを行うアプリケーションの機能によって異なります。

注意 パスワードを保存した場合は、パスワードはマスクおよび暗号化されずに保存されて使用されます。
[使用する初期カタログを入力します] | カタログまたはデータベースの名前を入力するか、ドロップダウン リストから選択します。
[接続のテスト] | 指定したデータ ソースへの接続をテストする場合にクリックします。接続が失敗した場合は、設定が正しいことを確認してください。たとえば、スペルが誤っていたり大文字と小文字の区別を間違えると、接続が失敗することがあります。

注意 データ リンク接続の詳細については、「Data Link API リファレンス」を参照してください。


Oracle の [接続] タブ

[接続] タブを使用して、Oracle データに接続する方法を指定します。

この [接続] タブはプロバイダ固有のもので、Microsoft OLE DB Provider for Oracle に必要な接続プロパティのみが表示されます。

オプション | 説明
[サーバー名を入力します] | アクセスするデータベースが存在するサーバーを入力します。
[ユーザー名] | データ ソースへのログオン認証に使用するユーザー ID を入力します。
[パスワード] | データ ソースへのログオン認証に使用するパスワードを入力します。
[パスワードを空にする] | 指定されたプロバイダは、接続文字列の中に空白のパスワードを含めて返すことができます。
[パスワードを保存する] | パスワードを接続文字列に含めて保存することができます。パスワードが接続文字列に含まれるかどうかは、呼び出しを行うアプリケーションの機能によって異なります。 注意 パスワードを保存した場合は、パスワードはマスクおよび暗号化されずに保存されて使用されます。
[接続のテスト] | 指定したデータ ソースへの接続をテストする場合にクリックします。接続が失敗した場合は、設定が正しいことを確認してください。たとえば、スペルが誤っていたり大文字と小文字の区別を間違えると、接続が失敗することがあります。

注意 データ リンク接続の詳細については、「Data Link API リファレンス」を参照してください。


SQL Server の [接続] タブ

[接続] タブを使用して、Microsoft SQL Server データに接続する方法を指定します。

この [接続] タブはプロバイダ固有のもので、OLE DB Provider for Microsoft SQL Server に必要な接続プロパティのみが表示されます。

オプション | 説明
[サーバー名を選択または入力します] | ドロップダウン リストからサーバー名を選択するか、アクセスするデータベースが存在するサーバーの場所を入力します。サーバー上のデータベースの選択は、別の操作になります。[更新] をクリックすると、一覧の内容が更新されます。
[Windows NT の統合セキュリティを使用する] | このオプションを選択すると、プロバイダは Microsoft Windows NT 上で実行中の SQL Server への安全で信頼性の高い接続を要求します。また、SQL Server は統合ログイン セキュリティを適用し、サーバーで設定されているセキュリティのレベルにかかわらず、このデータ ソースを使用して接続を確立します。与えられたログイン ID とパスワードはすべて無視されます。SQL Server のシステム管理者は、Microsoft Windows ネットワーク ID と SQL Server のログイン ID を関連付けておく必要があります。
[特定のユーザー名とパスワードを使用する] | 与えられたユーザー名とパスワードを使用してデータ ソースへのログオン情報を認証する場合は、このオプションを選択します。
[ユーザー名] | データ ソースへのログオン認証に使用するユーザー ID を入力します。
[パスワード] | データ ソースへのログオン認証に使用するパスワードを入力します。
[パスワードを空にする] | 指定されたプロバイダは、接続文字列の中に空白のパスワードを含めて返すことができます。
[パスワードを保存する] パスワードを接続文字列に含めて保存することができます。パスワードが接続文字列に含まれるかどうかは、呼び出しを行うアプリケーションの機能によって異なります。

注意 パスワードを保存した場合は、パスワードはマスクおよび暗号化されずに保存されて使用されます。
[データベースの選択] 以下の方法のいずれかを使用します。
  • アクセスするデータベース名を入力します。

  • SQL Server 7.0 の場合、データベース名として SQL データベース ファイルを添付します。添付した SQL データベース ファイルに使用するデータベース名を入力します。

  • SQL Server 6.5 およびそれ以前のバージョンの場合、添付するデータベース ファイル名を入力します。単一ファイル データベース ファイルの名前を入力します。ファイルを参照するには、[参照] をクリックします。
[接続のテスト] | 指定したデータ ソースへの接続をテストする場合にクリックします。接続が失敗した場合は、設定が正しいことを確認してください。たとえば、スペルが誤っていたり大文字と小文字の区別を間違えると、接続が失敗することがあります。

注意 データ リンク接続の詳細については、「Data Link API リファレンス」を参照してください。


Data Link API リファレンス

データ リンク API の詳細については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「ODBC Programmer's Reference」の「Part 4 API Reference」を参照してください。


[プロパティの値を編集] ダイアログ ボックス

[プロパティの値を編集] ダイアログ ボックスを使用して、[すべて] タブで現在選択されている OLE DB 初期化プロパティを編集します。プロパティは、OLE DB プロバイダによって異なります。

注意 プロバイダ固有のプロパティの詳細については、選択した OLE DB プロバイダのマニュアルを参照してください。

オプション | 説明
[プロパティの説明] | 選択したプロパティの説明が表示されます。
[プロパティの値] | 有効な値を選択します。
[値のリセット] | 選択したプロパティの値を OLE DB プロバイダの既定値に設定します。