トラップ可能な Microsoft Jet のエラー

トラップ可能なエラーは、開発環境で、またはスタンドアロンの実行可能ファイルとしてアプリケーションが実行されているときに発生する可能性があります。Error オブジェクトを使用して、トラップ可能なエラーをテストしたりそれに応答したりできます。

コード メッセージ

2420 数値の構文エラーです。

2421 日付の構文エラーです。

2422 文字列の構文エラーです。

2423 '.'、'!'、または '()' の使い方が正しくありません。

2424 未定義の名前です。

2425 未定義の関数名です。

2426 この関数は式では使用できません。

2427 オブジェクトに値がありません。

2428 定義域関数の引数が正しくありません。

2429 In 演算子に '()' がありません。

2430 Between 演算子に対応する And がありません。

2431 構文エラー : 演算子がありません。

2432 構文エラー : カンマがありません。

2433 構文エラー

2434 構文エラー : 演算子がありません。

2435 不要な ')' があります。

2436 ')'、']'、または Item がありません。

2437 垂直バーの使い方が正しくありません。

2438 構文エラー

2439 関数で使用されている引数の数が正しくありません。

2440 IIF 関数に対応する '()' がありません。

2442 かっこの使い方が正しくありません。

2443 Is 演算子の使い方が正しくありません。

2445 式が複雑すぎます。

2446 メモリ不足のため、演算を実行できません。

2447 '.'、'!'、または '()' の使い方が正しくありません。

2448 値を設定できません。

3000 システムで予約されているエラー <アイテム> です。このエラーに対するメッセージはありません。

3001 引数が無効です。

3002 セッションを開始できませんでした。

3003 ネストされているトランザクションが多すぎるので、トランザクションを開始できませんでした。

3005 データベース名 <データベース名> は正しくありません。

3006 データベース <データベース名> は排他ロックされています。

3007 ライブラリ データベース <データベース名> を開くことができません。

3008 テーブル <テーブル名> はほかのユーザーが排他的に開いているか、既にユーザー インターフェイスを介して開いているので、プログラムによって操作することはできません。

3009 テーブル <テーブル名> は現在使用されているので、開くときにロックを試みてもロックできません。後で、再度実行してください。

3010 テーブル <テーブル名> は既に存在しています。

3011 オブジェクト <オブジェクト名> が見つかりませんでした。オブジェクトが存在していること、名前やパス名が正しいことを確認してください。

3012 オブジェクト <オブジェクト名> は既に存在しています。

3013 インストール可能な ISAM ドライバのファイル名を変更できませんでした。

3014 これ以上テーブルを開くことはできません。

3015 インデックスが見つかりませんでした。

3016 フィールドがレコードに適合しません。

3017 フィールド サイズが長すぎます。

3018 フィールドが見つかりませんでした。

3019 カレント インデックスを指定してください。

3020 Update または CancelUpdate メソッドには、対応する AddNew または Edit メソッドが必要です。

3021 カレント レコードがありません。

3022 インデックス、主キー、またはリレーションシップで値が重複しているので、テーブルを変更できませんでした。

3023 AddNew メソッドまたは Edit メソッドは、既に適用されています。

3024 ファイル <ファイル名> が見つかりませんでした。

3025 これ以上ファイルを開くことはできません。

3026 ディスクの空き容量が不足しています。

3027 データベースまたはオブジェクトは読み取り専用なので、更新できません。

3028 アプリケーションを起動できません。システム データベースが存在しないか、またはほかのユーザーが排他的にシステム データベースを開いています。

3029 アカウント名またはパスワードが正しくありません。

3030 アカウント名 <アカウント名> は正しくありません。

3031 パスワードが正しくありません。

3032 この操作は実行できません。

3033 オブジェクト <オブジェクト名> を使用する権限がありません。システム管理者またはこのオブジェクトの作成者から権限を取得してください。

3034 コミットまたはロールバックを実行するには、BeginTrans メソッドを使用してください。

3036 データベース サイズが上限に達しました。

3037 これ以上テーブルまたはクエリを開くことはできません。

3039 定義されているインデックスが多すぎるので、インデックスを作成できませんでした。

3040 読み取り中にディスク I/O エラーが発生しました。

3041 前のバージョンのアプリケーションで作成されたデータベースを開くことはできません。

3042 MS-DOS のファイル ハンドルが不足しています。

3043 ディスクまたはネットワークのエラーです。

3044 パス '<パス名>' は正しくありません。パス名に間違いがないことと、ファイルが置かれたサーバーに接続していることを確認してください。

3045 <ファイル名> は既に使用されているので、使用できませんでした。

3046 ほかのユーザーによってロックされているため、保存できませんでした。

3047 レコードが大きすぎます。

3048 これ以上データベースを開くことはできません。

3049 データベース <データベース名> を開くことができません。アプリケーションで認識できないデータベースであるか、またはファイルが破損しています。

3050 ファイルをロックできませんでした。

3051 ファイル <ファイル名> を開くことができませんでした。ほかのユーザーが排他的に開いているか、データを読み取る権限がありません。

3052 ファイルの共有ロック数が制限を超えています。

3053 クライアント タスクが多すぎます。

3054 メモ型、OLE オブジェクト型、またはハイパーリンク オブジェクト型のフィールドが多すぎます。

3055 ファイル名が正しくありません。

3056 このデータベースを修復できませんでした。

3057 この操作は、リンク テーブルには実行できません。

3058 インデックスまたは主キーには、Null 値を使用できません。

3059 ユーザーによって処理が中止されました。

3060 パラメータ <パラメータ名> のデータ型が正しくありません。

3061 パラメータが少なすぎます。<数> を指定してください。

3062 出力の別名 '<別名>' が重複しています。

3063 出力先 <デスティネーション名> が重複しています。

3064 アクション クエリ '<クエリ名>' を開くことができません。

3065 選択クエリを実行できません。

3066 クエリには、出力フィールドが 1 つ以上必要です。

3067 クエリの入力には、1 つ以上のテーブルまたはクエリが必要です。

3068 別名が正しくありません。

3069 アクション クエリ '<クエリ名>' をデータ ソースとして使用することはできません。

3070 <名前> を有効なフィールド名、または式として認識できません。

3071 式が正しく入力されていないか、複雑すぎるために評価できません。たとえば、数式に複雑な要素が多すぎます。変数に式の一部を割り当て、式を簡単にしてください。

3072 テーブルの入力規則や列に対する CHECK 制約を作成するときに、データ型が一致しませんでした。

3073 更新可能なクエリであることが必要です。

3074 FROM 句でテーブル名 <テーブル名> を繰り返すことはできません。

3075 クエリ式 '<式>' の <メッセージ>

3076 抽出条件式の <名前>。

3077 式の <メッセージ>。

3078 入力テーブルまたはクエリ '<クエリ名>' が見つかりませんでした。そのテーブルやクエリが存在していること、または名前が正しいことを確認してください。

3079 指定されたフィールド <フィールド名> が SQL ステートメントの FROM 句にある複数のテーブルを参照しました。

3080 結合テーブル <テーブル名> が FROM 句に指定されていません。

3081 同じ名前 (<テーブル名>) で複数のテーブルを結合することはできません。

3082 JOIN 操作 '<操作>' は結合テーブルにないフィールドを参照しています。

3083 内部レポート クエリは使用できません。

3084 アクション クエリを使用してデータを挿入することはできません。

3085 式に未定義関数 <関数名> があります。

3086 指定されたテーブルから削除できませんでした。

3087 GROUP BY 句の式が多すぎます。

3088 ORDER BY 句の式が多すぎます。

3089 DISTINCT 出力の式が多すぎます。

3090 作成されるテーブルは、複数のオートナンバー フィールドを含むことはできません。

3091 グループまたは集合のない HAVING 句 (<名前>) です。

3092 TRANSFORM ステートメントで HAVING 句は使用できません。

3093 ORDER BY 句 (<句>) が DISTINCT 句と矛盾しています。

3094 ORDER BY 句 (<句>) が GROUP BY 句と矛盾しています。

3095 式 (<式>) で集計関数を使用することはできません。

3096 WHERE 句 (<句>) で集計関数を使用することはできません。

3097 ORDER BY 句 (<句>) で集計関数を使用することはできません。

3098 GROUP BY 句 (<句>) で集計関数を使用することはできません。

3099 JOIN 操作 (<操作>) で集計関数を使用することはできません。

3100 結合キーに含まれるフィールド '<フィールド名>' は Null に設定できません。

3101 フィールド '<フィールド名>' とキーが一致しているレコードをテーブル '<テーブル名>' で探すことができません。

3102 '<クエリ参照>' から循環参照が発生しています。

3103 クエリ定義の SELECT で指定されている別名 '<別名>' が循環参照を発生させています。

3104 クロス集計クエリには、複数の固定列見出し '<値>' を指定できません。

3105 SELECT INTO ステートメント (<ステートメント>) に出力するフィールド名が見つかりません。

3106 UPDATE ステートメント (<ステートメント>) に出力するフィールド名が見つかりません。

3107 '<名前>' の挿入権限がないので、レコードを追加できません。

3108 '<名前>' の更新権限がないので、レコードを編集できません。

3109 '<名前>' の削除権限がないので、レコードを削除できません。

3110 テーブルまたはクエリ '<クエリ名>' の定義を読み取る権限がないので、定義を読み取ることができませんでした。

3111 テーブルまたはクエリ '<クエリ名>' のデザインを変更する権限がないので、作成できませんでした。

3112 '<参照名>' の読み取り権限がないので、レコードを読み取ることができません。

3113 フィールド '<フィールド名>' は更新できません。フィールドが更新可能ではありません。

3114 固有の値 (<ステートメント>) を選択した場合は、メモ型または OLE オブジェクト型のフィールドを含むことはできません。

3115 集計関数の引数 (<ステートメント>) にメモ型または OLE オブジェクト型のフィールドを指定することはできません。

3116 集計関数の抽出条件 (<条件>) にメモ型または OLE オブジェクト型のフィールドを指定することはできません。

3117 メモ型または OLE オブジェクト型のフィールド (<句>) で並べ替えを行うことはできません。

3118 メモ型または OLE オブジェクト型 (<名前>) のフィールドを結合することはできません。

3119 メモ型または OLE オブジェクト型 (<句>) のフィールドはグループ化できません。

3120 '*' (<テーブル名>) で選択したフィールドはグループ化できません。

3121 '*' で選択したフィールドはグループ化できません。

3122 集計関数の一部として指定された式 '<名前>' を含んでいないクエリを実行しようとしました。

3123 クロス集計クエリに '*' を使用することはできません。

3124 内部のレポート クエリ (<クエリ名>) から入力することはできません。

3125 '<名前>' が見つかりません。パラメータや別名が正しいこと、無効な文字や区切り記号が含まれていないこと、または名前が長すぎないことを確認してください。

3126 '<名前>' のかっこの使い方が正しくありません。

3127 INSERT INTO ステートメントに、認識できないフィールド '<フィールド名>' があります。名前が正しいことを確認して、再度実行してください。

3128 削除するレコードを含んだテーブルを指定してください。

3129 SQL ステートメントが正しくありません。'DELETE'、'INSERT'、'PROCEDURE'、'SELECT'、または 'UPDATE' を使用してください。

3130 DELETE ステートメントの構文エラーです。

3131 FROM 句の構文エラーです。

3132 GROUP BY 句の構文エラーです。

3133 HAVING 句の構文エラーです。

3134 INSERT INTO ステートメントの構文エラーです。

3135 JOIN 操作の構文エラーです。

3136 LEVEL 句が間違っている予約語や引数を含んでいるか、区切り記号が正しくありません。

3137 SQL ステートメントの最後には、セミコロン (;) が必要です。

3138 ORDER BY 句の構文エラーです。

3139 PARAMETER 句の構文エラーです。

3140 PROCEDURE 句の構文エラーです。

3141 SELECT ステートメントが間違っている予約語や引数を含んでいるか、区切り記号が正しくありません。

3142 SQL ステートメントの後に文字が見つかりました。

3143 TRANSFORM ステートメントの構文エラーです。

3144 UPDATE ステートメントの構文エラーです。

3145 WHERE 句の構文エラーです。

3146 ODBC--呼び出しが失敗しました。

3151 ODBC--'<名前>' への接続が失敗しました。

3154 ODBC--DLL '<DLL ファイル名>' が見つかりませんでした。

3155 ODBC--リンク テーブル '<テーブル名>' への挿入に失敗しました。

3156 ODBC--リンク テーブル '<テーブル名>' での削除に失敗しました。

3157 ODBC--リンク テーブル '<テーブル名>' での更新に失敗しました。

3158 ほかのユーザーによってロックされているので、レコードを保存できませんでした。

3159 ブックマークが正しくありません。

3160 このテーブルは開いていません。

3161 ファイルを解読できませんでした。

3162 バリアント型でない変数に Null 値を代入しようとしました。

3163 指定されたデータ量がフィールド サイズを超えています。データ量を減らし、挿入または貼り付けを行ってください。

3164 フィールドを更新できません。

3165 .INF ファイル を開くことができませんでした。

3166 指定された Xbase メモ ファイルを見つけることができません。

3167 レコードは削除されています。

3168 無効な .INF ファイルです。

3169 SQL ステートメントに無効なデータ型が使用されているので、実行できませんでした。

3170 インストール可能な ISAM ドライバが見つかりませんでした。

3171 ネットワーク パスまたはユーザー名が見つかりませんでした。

3172 PARADOX.NET を開くことができませんでした。

3173 ワークグループ情報ファイルの 'MSysAccounts' テーブルを開くことができませんでした。

3174 ワークグループ情報ファイルの 'MSysGroups' テーブルを開くことができませんでした。

3175 日付が範囲外であるか、書式が正しくありません。

3176 ファイル '<ファイル名>' を開くことができませんでした。

3177 テーブル名が正しくありません。

3179 EOF エラーです。

3180 ファイル '<ファイル名>' に書き込むことができませんでした。

3181 範囲が正しくありません。

3182 ファイル形式が正しくありません。

3183 テンポラリ ファイル用の空き容量が不足しています。

3184 リンクするテーブルが見つからないので、クエリを実行できませんでした。

3185 リモート データベース上で SELECT INTO ステートメントを使用して作成しようとしたフィールドが多すぎます。

3186 マシン '<マシン名>' のユーザー '<ユーザー名>' によってロックされているので、保存できませんでした。

3187 マシン '<マシン名>' のユーザー '<ユーザー名>' によってロックされているので、読み取れませんでした。

3188 このマシンのほかのセッションによってロックされているので、更新できませんでした。

3189 テーブル '<テーブル名>' は、マシン '<マシン名>' のユーザー '<ユーザー名>' によって排他ロックされています。

3190 定義されているフィールドが多すぎます。

3191 複数回フィールドを定義することはできません。

3192 出力テーブル '<テーブル名>' が見つかりませんでした。

3196 データベース '<データベース名>' はほかのユーザーまたはプロセスによって既に使用されています。データベースが使用可能になった時点で、再度実行してください。

3197 ほかのユーザーが同じデータに対して同時に変更を試みているので、プロセスが停止しました。

3198 アクティブなセッションが多すぎるので、セッションを開始できませんでした。

3199 参照が見つかりませんでした。

3200 リレーションシップが設定されたレコードがテーブル '<テーブル名>' にあるので、レコードの削除や変更を行うことはできません。

3201 テーブル '<テーブル名>' にリレーションシップが設定されたレコードが必要なので、レコードの追加や変更を行うことはできません。

3202 ほかのユーザーによってロックされているので、保存できませんでした。

3203 式 (<式>) にサブクエリは指定できません。

3204 データベースは既に存在しています。

3205 クロス集計する列のヘッダー (<値>) が多すぎます。

3206 同じフィールドの間でリレーションシップは作成できません。

3207 この操作は、主キーのない Paradox テーブルでは実行できません。

3208 レジストリの Xbase キーの Deleted 設定値が正しくありません。

3210 接続文字列が長すぎます。

3211 テーブル '<テーブル名>' は現在ほかのユーザーまたはプロセスで使用されているので、ロックできませんでした。

3212 テーブル '<テーブル名>' は、マシン '<マシン名>' のユーザー '<ユーザー名>' によって使用されているので、ロックできませんでした。

3213 レジストリの Xbase キーの Date 設定値が正しくありません。

3214 レジストリの Xbase キーの Mark 設定値が正しくありません。

3216 パラメータ '<名前>' にはテーブル名を指定してください。

3217 パラメータ '<名前>' にはデータベース名を指定してください。

3218 現在ロックされているので、更新できませんでした。

3219 無効な処理です。

3220 照合順序が正しくありません。

3222 クエリにはデータベースのパラメータを含めることはできません。

3223 パラメータ名 '<パラメータ名>' は正しくありません。名前が長すぎるか、無効な文字を含んでいます。

3227 レジストリの Xbase キーの Century 設定値が正しくありません。

3228 選択された CollatingSequence は OS でサポートされていません。

3230 古い Paradox のロック ファイルです。

3231 ODBC--フィールドが長すぎるので、データが切り捨てられました。

3232 ODBC--テーブルを作成できませんでした。

3234 ODBC--サーバーの応答がありません。

3235 ODBC--サーバーでサポートされていないデータ型です。

3238 ODBC--範囲外のデータです。

3239 アクティブ ユーザーが多すぎます。

3242 SELECT ステートメントの参照が正しくありません。

3243 インポートするフィールド名と一致するフィールドが追加先テーブルにありません。

3244 パスワードで保護されているワークシートはインポートできません。

3245 インポートしたテーブルの先頭行からフィールド名を解析できませんでした。

3246 この操作は、トランザクションには実行できません。

3247 ODBC--リンク テーブルの定義が変更されています。

3248 レジストリの NetworkAccess 設定値が正しくありません。

3249 レジストリの PageTimeout 設定値が正しくありません。

3250 キーを設定できませんでした。

3251 この操作は、このタイプのオブジェクトには実行できません。

3252 フォームを開くことができません。元になるクエリで、このフォームの RecordsetClone プロパティの設定または取得を行うユーザー定義関数が見つかりました。

3254 ODBC--すべてのレコードをロックできません。

3256 インデックス ファイルが見つかりません。

3257 WITH OWNERACCESS OPTION 宣言の構文エラーです。

3258 あいまいな外部結合が含まれているので、SQL ステートメントを実行できません。いずれかの結合を最初に実行するために、第一次結合を実行する分割クエリを作成し、SQL ステートメントにそのクエリを含めてください。

3259 フィールドのデータ型が正しくありません。

3260 マシン '<マシン名>' のユーザー '<ユーザー名>' によってロックされているので、更新できませんでした。

3261 テーブル '<テーブル名>' はマシン '<マシン名>' のユーザー '<ユーザー名>' によって排他的にロックされています。

3262 テーブルをロックできませんでした。

3263 データベース オブジェクトが正しくありません。

3264 フィールドが定義されていないので、テーブル定義またはインデックスを追加できません。

3265 このコレクションには項目がありません。

3266 既に Fields コレクションに属しているフィールドは追加できません。

3267 プロパティは、フィールドが Recordset オブジェクトの Fields コレクションに属していないと設定できません。

3268 オブジェクトがコレクションに属しているので、このプロパティを設定できません。

3269 既に Indexes コレクションに属しているインデックスは追加できません。

3270 プロパティが見つかりませんでした。

3271 プロパティの値が正しくありません。

3272 オブジェクトはコレクションではありません。

3273 このオブジェクトには使用できないメソッドです。

3274 外部テーブルのフォーマットが正しくありません。

3275 外部データベース ドライバ (<エラー番号>) で予期しないエラーが発生しました。

3276 データベース のオブジェクト参照が正しくありません。

3277 1 つのインデックスで使用できるフィールド数は 10 以下です。

3278 Microsoft Jet データベース エンジンが初期化されていません。

3279 Microsoft Jet データベース エンジンは既に初期化されています。

3280 インデックスとして使用されているフィールド、またはシステムに必要なフィールドは削除できません。

3281 このフィールドまたはテーブルは削除できません。カレント インデックスとして使用されているか、リレーションシップで使用されています。

3282 この操作は、データを含んでいるテーブルには実行できません。

3283 主キーは既に存在しています。

3284 インデックスは既に存在しています。

3285 インデックスの定義が正しくありません。

3286 メモ ファイルのフォーマットが、指定されている外部データベースのファイル フォーマットに対応していません。

3287 指定されたフィールドにはインデックスを作成できません。

3288 Paradox のインデックスが主インデックスではありません。

3289 CONSTRAINT 句の構文エラーです。

3290 CREATE TABLE ステートメントの構文エラーです。

3291 CREATE INDEX ステートメントの構文エラーです。

3292 フィールド定義の構文エラーです。

3293 ALTER TABLE ステートメントの構文エラーです。

3294 DROP INDEX ステートメントの構文エラーです。

3295 DROP TABLE または DROP INDEX ステートメントの構文エラーです。

3296 結合式がサポートされていません。

3297 テーブルまたはクエリをインポートできませんでした。レコードが何も見つからないか、すべてのレコードにエラーがあります。

3298 同じ名前のテーブルが複数見つかりました。'所有者.テーブル名' の形式で所有者を指定してください。

3299 ODBC の仕様適合エラー (<メッセージ>) です。アプリケーションの作成者に通知してください。

3300 リレーションシップを作成できません。

3301 この処理を実行できません。このバージョンの機能には、古いバージョンのデータベースでは使用できないものがあります。

3302 このテーブルに対する規則は現在使用されているので、変更できません。

3303 このフィールドは削除できません。1 つ以上のリレーションシップで使用されています。

3304 4 桁 (バイト) 以上、20 桁 (バイト) 未満の PID (パーソナル ID) を入力してください。

3305 パススルー クエリで使用されている接続文字列が正しくありません。

3306 メイン クエリの FROM 句の予約語 EXISTS を使用しないフィールドを複数返すサブクエリを作成しました。サブクエリの SELECT ステートメントを変更し、1 つのフィールドだけを指定してください。

3307 ユニオン クエリで選択した 2 つのテーブルまたはクエリの列数が一致しません。

3308 選択クエリの TOP 引数が正しくありません。

3309 プロパティは 2KB 以下で設定してください。

3310 このプロパティは、外部データ ソースまたは前のバージョンの Microsoft Jet データベース エンジンで作成されたデータベースではサポートされていません。

3311 指定されたプロパティは既に存在しています。

3312 システム テーブルとリンク テーブルには、入力規則と既定値を設定できません。

3313 指定された入力規則は、このフィールドには設定できません。

3314 フィールドに必要なプロパティが True に設定されているため、このフィールド '<フィールド名>' には Null 値は挿入できません。値を入力してください。

3315 フィールド '<フィールド名>' には、長さ 0 の文字列を格納できません。

3316 <テーブル レベルの入力規則のメッセージ>。

3317 '<フィールド名>' に設定されている入力規則 '<規則>' に違反する値が 1 つ以上あります。このフィールドの式で使用できる値を入力してください。

3318 削除クエリやレポートでは、TOP 句に指定された値は使用できません。

3319 ユニオン クエリの構文エラーです。

3320 テーブル レベル入力規則の <エラー>。

3321 接続文字列または IN 句にデータベースが指定されていません。

3322 クロス集計クエリに、無効な固定列見出しが 1 つ以上見つかりました。

3323 このクエリは、データ ソースとして使用することはできません。

3324 このクエリは DDL クエリなので、データ ソースとして使用することはできません。

3325 ReturnsRecords プロパティが True に設定されているパススルー クエリから、レコードが返されませんでした。

3326 このレコードセットは更新できません。

3327 フィールド '<フィールド名>' は式に基づいているので、編集できません。

3328 テーブル '<テーブル名>' は読み取り専用です。

3329 テーブル '<テーブル名>' のレコードは、ほかのユーザーによって削除されています。

3330 テーブル '<テーブル名>' のレコードは、ほかのユーザーによってロックされています。

3331 このフィールドを変更する前に、まずレコードを保存してください。

3332 外部結合の '一' 側の空白フィールドには値を入力できません。

3333 テーブル '<テーブル名>' のレコードに、'一' 側と対応するレコードがなくなります。

3334 使用できるのは、Version 1.0 形式だけです。

3337 DataCodePage オプションの設定値が正しくありません。

3340 クエリ '<クエリ名>' は破損しています。

3341 カレント フィールドは、一対多リレーションシップの '一' 側のテーブルにある結合キー '<キー名>' と一致する必要があります。

3342 サブクエリ '<サブクエリ名>' のメモ型または OLE オブジェクト型のデータが正しくありません。

3343 データベースの形式 <ファイル名> を認識できません。

3344 Microsoft Jet データベース エンジンで、入力検査の式にあるフィールド '<フィールド名>' またはテーブル '<テーブル名>' の既定値が認識されません。

3345 フィールドの参照 '<参照名>' が認識できません。または無効な参照です。

3346 クエリの値と出力するフィールドの数が一致しません。

3347 レコードを追加できません。テーブル '<テーブル名>' の主キーがレコードセットにありません。

3348 レコードを追加できません。テーブル '<テーブル名>' の結合キーがレコードセットにありません。

3349 数値フィールドがオーバーフローしました。

3350 オブジェクトが正しくありません。

3351 ORDER BY 式 (<式>) にクエリに選択されていないフィールドが含まれています。ORDER BY 式 (<式>) に含めることができるのは、最初のクエリで要求されたフィールドだけです。

3352 INSERT INTO ステートメント (<ステートメント>) に出力するフィールド名が指定されていません。

3354 このサブクエリでは 1 つのレコードしか返せません。

3355 既定値の構文エラーです。

3356 このデータベースは、マシン '<マシン名>' のユーザー '<ユーザー名>' が排他的に開いています。データベースが使用可能になった時点で、再度実行してください。

3357 このクエリは、正しく指定されたデータ定義クエリではありません。

3358 Microsoft Jet データベース エンジンのワークグループ情報ファイルを開くことができません。

3359 パススルー クエリには、1 文字以上指定してください。

3360 クエリが複雑すぎます。

3361 サブクエリでは UNION 句を使用できません。

3362 1 行の更新/削除により、1 行以上のリンク テーブルに影響がありました。固有インデックスに重複する値が含まれています。

3363 レコードを追加できません。'一' 側に対応するレコードがありません。

3364 ユニオン クエリの SELECT 句では、メモ型または OLE オブジェクト型のフィールド '<フィールド名>' を使用できません。

3365 REMOTE オブジェクトのプロパティの値が正しくありません。

3366 フィールドが定義されていないので、リレーションシップを追加できません。

3367 指定された名前と同じ名前のオブジェクトが既にコレクションにあるので、追加できません。

3368 リレーションシップは、同じデータ型で同じ数のフィールドに設定する必要があります。

3370 テーブル '<テーブル名>' のデザインは変更できません。データベースが読み取り専用になっています。

3371 テーブルまたは規則を見つけることができません。

3372 テーブル '<テーブル名>' に インデックス '<インデックス名>' が見つかりませんでした。

3373 リレーションシップを作成できません。参照先のテーブル '<テーブル名>' に主キーがありません。

3374 指定されたフィールドは、テーブル '<テーブル名>' の固有インデックスではありません。

3375 テーブル '<テーブル名>' には既に '<インデックス名>' という名前のインデックスがあります。

3376 テーブル '<テーブル名>' は存在しません。

3377 テーブル '<テーブル名>' にリレーションシップ '<リレーションシップ名>' はありません。

3378 カレント データベースには既に '<リレーションシップ名>' という名前のリレーションシップが存在します。

3379 参照整合性を設定したリレーションシップを作成できません。テーブル '<テーブル名>' にある既存のデータが、テーブル '<テーブル名>' の参照整合性に違反しています。

3380 フィールド '<フィールド名>' は、テーブル '<テーブル名>' に既に存在しています。

3381 テーブル '<テーブル名>' に '<フィールド名>' という名前のフィールドが見つかりません。

3382 フィールド '<フィールド名>' のサイズが長すぎます。

3383 フィールド '<フィールド名>' は削除できません。1 つ以上のリレーションシップで使用されています。

3384 組み込みプロパティは削除できません。

3385 ユーザー定義プロパティでは Null 値をサポートできません。

3386 このメソッドを使用するには、プロパティ '<プロパティ名>' を設定する必要があります。

3388 '<名前>' に設定されている入力規則または既定値の関数 '<関数名>' が見つかりません。

3389 クエリがサポートされていません。

3390 既に存在するアカウント名です。

3393 結合、グループ化、並べ替え、インデックスを実行できません。検索または並べ替えの対象である値が大きすぎます。

3394 プロパティを保存できません。このプロパティはスキーマ プロパティです。

3396 連鎖処理を実行できません。関連レコードがテーブル '<テーブル名>' に存在しているので、参照整合性の規則に違反することになります。

3397 連鎖処理を実行できません。テーブル '<テーブル名>' に関連レコードが存在する必要があります。

3398 連鎖処理を実行できません。実行すると、テーブル '<テーブル名>' のキーが Null 値になります。

3399 連鎖処理を実行できません。実行すると、テーブル '<テーブル名>' のキーが重複します。

3400 連鎖処理を実行できません。実行すると、テーブル '<テーブル名>' のフィールド '<フィールド名>' が 2 回更新されます。

3401 連鎖処理を実行できません。実行すると、フィールド '<フィールド名>' が Null 値になります。

3402 連鎖処理を実行できません。実行すると、フィールド '<フィールド名>' が長さ 0 の文字列になります。

3403 連鎖処理 '<入力規則テキスト>' を実行できません。

3404 連鎖処理を実行できません。入力された値は、'<名前>' に設定されている入力規則 '<規則>' で禁止されています。

3405 入力規則のエラー '<エラー テキスト>'。

3406 <エラー テキスト> のために、DefaultValue プロパティに使用している式は無効です。有効な式を使用して、このプロパティを設定してください。

3407 サーバーの MSysConf テーブルが見つかりました。ただし、正しい形式ではないので、システム管理者に確認してください。

3408 実行している高速検索のセッション数が多すぎます。

3409 インデックスまたはリレーションシップの定義で使用されているフィールド定義 '<フィールド名>' が正しくありません。

3411 無効なエントリです。フィールド '<フィールド名>' に入力された値が大きすぎ、テーブル '<テーブル名>' で連鎖処理を実行できません。

3412 このテーブルは現在ほかのユーザーによって使用されているので、連鎖更新を実行できません。

3413 テーブル '<テーブル名>' はマシン '<マシン名>' のユーザー '<ユーザー名>' によって使用されているので、連鎖更新を実行できません。

3414 テーブル '<テーブル名>' は現在使用されているので、連鎖更新を実行できません。

3415 長さ 0 の文字列を使用できるのは、テキスト型またはメモ型のフィールドだけです。

3416 <予約されているエラー警告>。

3417 アクション クエリをデータ ソースとして使用することはできません。

3418 <テーブル名> を開くことができません。ほかのユーザーが別のネットワーク コントロール ファイルまたは別のロック形式を使用してテーブルを開いています。

3419 レジストリで ParadoxNetStyle セクションが 3.x に設定されているので、Paradox 4.x または 5.x のテーブルを開くことはできません。

3420 オブジェクトが正しくないか、現在設定されていません。

3421 データ型の変換エラーが発生しました。

3422 テーブルの構造を変更できません。ほかのユーザーがテーブルを開いています。

3423 ODBC を使用して、外部 Microsoft Jet データベース エンジンのテーブルや組み込み可能な ISAM データベースのテーブルのインポート、エクスポート、またはリンクを行うことはできません。

3424 データベースを作成できません。データベースの並び順の設定が正しくありません。

3428 データベースでエラーが発生しました。データベースを修復し、最適化してください。

3429 組み込み可能な ISAM ドライバのバージョンに互換性がありません。

3430 Excel ISAM ドライバの読み込み中に、OLE を初期化できませんでした。

3431 Excel 5.0 形式のファイルではありません。

3432 Excel 5.0 形式のファイルを開くことができません。

3433 レジストリの Engines セクションの Excel キーに設定されている値が正しくありません。

3434 指定範囲を広げることはできません。

3435 ワークシートのセルを削除できません。

3436 ファイルを作成できませんでした。

3437 これ以上ワークシートに書き込むことはできません。

3438 エクスポートしているデータが SCHEMA.INI ファイルで設定されている形式と矛盾しています。

3439 Word の差し込み文書をリンクまたはインポートすることはできません。

3440 テキスト ファイルをインポートまたはリンクするには、ファイルにデータが含まれている必要があります。

3441 テキスト ファイル形式のフィールド区切り記号に、桁やテキストの区切り記号と同じ記号は使用できません。

3442 テキスト ファイルの指定 '<名前>' で、<オプション名> オプションの設定値が正しくありません。

3443 固定長の指定 '<名前>' で、列幅が指定されていません。

3444 固定長 '<名前>' の指定で、<列名> 列の列幅が指定されていません。

3445 正しくないバージョンの DLL ファイル '<ファイル名>' が見つかりました。

3446 Jet VBA ファイル (16 ビット VBAJET.DLL、32 ビット VBAJET32.DLL) が見つかりません。エラーが発生したアプリケーションを再度セットアップしてください。

3447 Jet VBA ファイル (16 ビット VBAJET.DLL、32 ビット VBAJET32.DLL) の初期化に失敗しました。エラーが発生したアプリケーションを再度セットアップしてください。

3448 OLE システム関数の呼び出しでエラーが発生しました。エラーが発生したアプリケーションを再度セットアップしてください。

3449 リンク テーブルへの接続文字列で、国番号が指定されていません。

3450 クエリの構文エラーです。クエリの句が不完全です。

3451 クエリの参照が不正です。

3452 このレプリカでは、データベースのデザインは変更できません。

3453 レプリケートされているテーブルとローカル テーブルの間にリレーションシップを設定したり、設定を変更することはできません。

3455 データベースをレプリケート可能にできません。

3456 コンテナ <コンテナ名> 内のオブジェクト <オブジェクト名> をレプリケート可能にできません。

3457 既にレプリケートされているオブジェクトの KeepLocal プロパティを設定することはできません。

3458 データベースの KeepLocal プロパティを設定することはできません。このプロパティは、データベース内のオブジェクトに対してだけ設定できます。

3459 データベースをレプリケートした後で、レプリケート不可能に設定し直すことはできません。

3460 実行を試みた操作は、レプリカ セットのメンバを含む既存の操作と矛盾します。

3461 設定または削除を試みたレプリケーション プロパティは読み取り専用であり、変更できません。

3462 DLL を読み込むことができません。

3463 DLL '<ファイル名>' が見つかりません。

3464 抽出条件でデータ型が一致しません。

3465 指定のディスク ドライブを読み取ることができません。

3468 ドロップボックス フォルダ '<フォルダ名>' へのアクセス中に、アクセスが拒否されました。

3469 ドロップボックス フォルダ '<フォルダ名>' のディスクがいっぱいです。

3470 ドロップボックス フォルダ '<フォルダ名>' へのアクセス中に、ディスク エラーが発生しました。

3471 シンクロナイザ ログ ファイルに書き込むことができません。

3472 パス '<パス名>' のディスクがいっぱいです。

3473 ログ ファイル '<ファイル名>' にアクセス中にディスク エラーが発生しました。

3474 ログ ファイル '<ファイル名>' を書き込み用に開くことができません。

3475 排他書き込みモードでログ ファイル '<ファイル名>' を開こうとしたときに、共有違反が発生しました。

3476 ドロップボックス '<ドロップボックス名>' のパスが正しくありません。

3477 ドロップボックスのアドレス '<アドレス名>' の構文が正しくありません。

3478 このレプリカは部分レプリカではありません。

3479 部分レプリカをレプリカ セットのデザイン マスターにすることはできません。

3480 部分フィルタの式に含まれるリレーションシップ '<リレーションシップ名>' が正しくありません。

3481 部分フィルタの式に含まれるテーブル名 '<テーブル名>' が正しくありません。

3482 部分レプリカのフィルタ式が正しくありません。

3483 ドロップボックス フォルダ '<フォルダ名>' のパスワードが正しくありません。

3484 シンクロナイザがドロップボックス フォルダに書き込むためのパスワードが正しくありません。

3485 データベースがレプリケートされていないので、このオブジェクトをレプリケートすることはできません。

3486 2 番目の Replication ID オートナンバー フィールドをテーブルに追加することはできません。

3487 レプリケートを試みているデータベースを変換できません。

3488 指定された値は、レプリカ セットのメンバに対する ReplicaID ではありません。

3489 必要なリソースがないため、指定したオブジェクトをレプリケートできません。

3490 コンテナ '<コンテナ名>' のオブジェクト '<オブジェクト名>' をレプリケートできないため、新しいレプリカを作成できません。

3491 データベースをレプリケートにするには、まず排他モードで開く必要があります。

3492 レプリカのデザインは変更できないので、同期できませんでした。

3493 指定されたシンクロナイザのレジストリ パラメータを設定できません。

3494 指定されたシンクロナイザのレジストリ パラメータの値を取得できません。

3495 2 つのシンクロナイザ間に同期スケジュールはありません。

3496 レプリケーション マネージャが、MSysExchangeLog テーブルで ExchangeID を見つけることができません。

3497 シンクロナイザのスケジュールを設定できません。

3499 レプリカ セットのメンバの絶対パス情報を取得できません。

3500 同じレプリカを管理するために、2 つの異なるシンクロナイザを指定することはできません。

3502 デザイン マスターまたはレプリカがシンクロナイザによって管理されていません。

3503 シンクロナイザのレジストリに必要なキー値が設定されていません。

3504 シンクロナイザ ID が、MSysTranspAddress テーブル内の既存の ID と一致しません。

3505 MSysFilters テーブルに存在しない部分フィルタに関する情報を削除または取得しようとしました。

3506 シンクロナイザがシンクロナイザ ログを開くことができません。

3507 シンクロナイザ ログに書き込むことができません。

3508 シンクロナイザに対するアクティブなトランスポートがありません。

3509 このシンクロナイザに対する有効なトランスポートが見つかりませんでした。

3510 同期を試みたレプリカ セットのメンバは、現在ほかの同期で使用されています。

3512 ドロップボックス フォルダを読み取ることができませんでした。

3513 ドロップボックス フォルダに書き込むことができませんでした。

3514 シンクロナイザは、スケジュールされた同期またはオンデマンドの同期を見つけることができませんでした。

3515 Microsoft Jet データベース エンジンはコンピュータのシステム クロックを見つけることができませんでした。

3516 デスティネーション シンクロナイザは間接同期をサポートするように設定されていません。また、デスティネーション レプリカは直接同期に使用できません。

3517 シンクロナイザは処理対象のメッセージを見つけることができませんでした。

3518 MSysTranspAddress テーブルでシンクロナイザを見つけることができませんでした。

3519 メッセージを送信できませんでした。

3520 レプリカの名前または ID が、現在管理されているレプリカ セットのメンバと一致しません。

3521 同期を開始する共通点がないため、この 2 つのレプリカを同期できません。

3522 シンクロナイザは、MSysExchangeLog テーブル内に特定の同期のレコードを見つけることができません。

3523 シンクロナイザは、MSysSchChange テーブル内に特定のバージョン番号を見つけることができません。

3524 レプリカのデザイン変更の履歴が、デザイン マスターの履歴と一致しません。

3525 シンクロナイザはメッセージ データベースにアクセスできませんでした。

3526 システム オブジェクト用に指定した名前は既に使用されています。

3527 シンクロナイザまたはレプリケーション マネージャはシステム オブジェクトを見つけることができませんでした。

3528 シンクロナイザまたはレプリケーション マネージャ用の共有メモリには、新しいデータはありません。

3529 シンクロナイザまたはレプリケーション マネージャは、共有メモリ上に未読のデータを見つけました。既存のデータは上書きされます。

3530 シンクロナイザは既にクライアントを起動しています。

3531 イベントの待ち時間は終了しました。

3532 シンクロナイザを初期化できませんでした。

3533 プロセスが終了した後も、このプロセスが使用したシステム オブジェクトが存在します。

3534 シンクロナイザはシステム イベントを検索しましたが、クライアントに報告するようなシステム イベントを見つけることができませんでした。

3535 クライアントはシンクロナイザに処理を終了するよう要求しました。

3536 シンクロナイザは、管理するレプリカ セットのメンバに対する無効なメッセージを受信しました。

3537 シンクロナイザのクライアントは現在存在していないので、認識されません。

3538 多くのアプリケーションが実行されているので、シンクロナイザを初期化できません。

3539 システム エラーが発生したか、スワップ ファイルの上限に達しました。

3540 スワップ ファイルの上限に達したか、ファイルが壊れています。

3541 シンクロナイザを正しくシャット ダウンできなかったので、アクティブのままです。

3542 シンクロナイザ クライアントを終了しようとしたときに処理が中断しました。

3543 シンクロナイザがセットアップされていません。

3544 シンクロナイザは既に実行されています。

3545 同期を試みた 2 つのレプリカは、異なるレプリカ セットのものです。

3546 実行しようとした同期の種類が正しくありません。

3547 同期を完了するために、シンクロナイザは正しいセットでレプリカを見つけることができませんでした。

3548 GUID が一致しないか、指定した GUID が見つかりません。

3549 指定したファイル名が長すぎます。

3550 GUID 列にはインデックスがありません。

3551 指定したシンクロナイザのレジストリ パラメータを削除できません。

3552 レジストリ パラメータのサイズが、上限値を超えています。

3553 GUID を作成できませんでした。

3555 レプリカ用の有効な名前はすべて使用されています。

3556 デスティネーション ドロップボックス フォルダのパスが正しくありません。

3557 デスティネーション ドロップボックス フォルダのアドレスが正しくありません。

3558 デスティネーション ドロップボックス フォルダでディスク I/O エラーが発生しました。

3559 出力するディスクがいっぱいなので、書き込むことができません。

3560 同期を試みたレプリカ セットの 2 つのメンバの ReplicaID が同じです。

3561 同期を試みた 2 つのレプリカ セットのメンバは両方ともデザイン マスターです。

3562 デスティネーション ドロップボックス フォルダでアクセスが拒否されました。

3563 ローカル ドロップボックス フォルダへのアクセス中に致命的エラーが発生しました。

3564 シンクロナイザはメッセージのソース ファイルを見つけることができません。

3565 ほかのアプリケーションがメッセージ データベースを開いているため、ソース ドロップボックス フォルダで共有違反が発生しました。

3566 ネットワーク I/O エラー。

3567 ドロップボックス フォルダ内のメッセージは不正なシンクロナイザのものです。

3568 シンクロナイザはファイルを削除できませんでした。

3569 このレプリカはレプリカ セットから論理的に削除されているため、使用できません。

3570 部分レプリカを定義するフィルタが変更されています。部分レプリカを再設定する必要があります。

3571 部分レプリカに適用される規則に違反するため、部分レプリカでは列を設定できません。

3572 環境変数 TEMP で指定されているフォルダの読み込みまたは書き込み中に、ディスク I/O エラーが発生しました。

3573 レプリカの一覧用のフォルダは管理されていません。

3574 このレプリカの ReplicaID は、移動またはコピーの処理中に再度割り当てられました。

3575 書き込みを試みたディスク ドライブはいっぱいです。

3576 開こうとしたデータベースは、既にほかのアプリケーションが使用しています。

3577 レプリケーションのシステム列を更新できません。

3578 データベースが排他モードで開いていることを確認できないため、データベースをレプリケートできません。

3579 データベースをレプリケート可能にするために必要なレプリケーション システム テーブルを作成できませんでした。

3580 データベースをレプリケート可能にするために必要な列を追加できませんでした。

3581 レプリケーション システム テーブル '<テーブル名>' は既に使用されているため、開くことができません。

3582 コンテナ <コンテナ名> 内のオブジェクト <オブジェクト名> をレプリケート可能にできないため、新しいレプリカを作成できません。

3583 コンテナ <コンテナ名> 内のオブジェクト <オブジェクト名> をレプリケート可能にできません。

3584 メモリ不足のため、操作を完了できません。

3585 列数が上限値を超えているため、テーブルをレプリケートできません。

3586 テーブル <テーブル名> の部分フィルタ式の構文エラーです。

3587 ReplicaFilter プロパティの式が正しくありません。

3588 部分フィルタの式を評価するときにエラーが発生しました。

3589 部分フィルタの式に未定義の関数が含まれています。

3590 部分レプリカに適用される規則に違反します。

3591 ログ ファイルのパス '<パス名>' が正しくありません。

3592 パスワードで保護されているデータベースをレプリケートすることはできません。また、レプリケートされたデータベースにパスワードを設定することはできません。

3593 レプリカ セットのデータのマスター属性を変更することはできません。

3594 レプリカ セットのデータのマスター属性を変更することはできません。データはデザイン マスターだけで変更できます。

3595 レプリカのシステム テーブルの信頼性がありません。このため、このレプリカを使用することはできません。

3600 集計関数の式では GUID を使用することはできません。

3605 レプリケートされていないデータベースと同期することはできません。データベース '<データベース名>' はデザイン マスターまたはレプリカではありません。

3607 削除を試みたレプリケーション プロパティは読み取り専用のため、削除できません。

3608 インデックス化された Paradox テーブルのレコードが長すぎます。

3609 主テーブルで参照されているフィールド用の固有インデックスが見つかりません。

3610 テーブル作成クエリで同じテーブル ('<テーブル名>') が、作成元になるテーブルおよび作成されるテーブルの両方として指定されています。

3611 リンクされているデータ ソースに対してデータ定義ステートメントを実行することはできません。

3612 サブクエリでは、マルチレベル GROUP BY 句は使用できません。

3613 リンク ODBC テーブル間にリレーションシップを設定することはできません。

3614 Find 系メソッドの抽出条件では、GUID は使用できません。

3615 式で型が一致しません。

3616 この ISAM では、リンク テーブル内のデータを更新することはできません。

3617 この ISAM では、リンク テーブル内のデータを削除することはできません。

3618 インポート/エクスポートで、例外テーブルを作成できませんでした。

3619 例外テーブルにレコードを追加できませんでした。

3620 リンクされている Excel のワークシートを表示するための接続が切断されました。

3621 共有モードで開いているテーブルのパスワードを変更することはできません。

3622 IDENTITY 列を持つ SQLServer テーブルにアクセスする場合は、OpenDatabase メソッドで dbSeeChanges オプションを使用する必要があります。

3623 DBF ファイル <ファイル名> に結合されている FoxPro 3.0 にアクセスできません。

3624 このレコードは現在ほかのユーザーによってロックされているので、読み取ることができませんでした。

3625 テキスト ファイルの指定 <名前> が存在しません。この指定を使用してインポート、エクスポート、またはリンクすることはできません。

3626 テーブル <テーブル名> にインデックスが多すぎるため、この操作を実行できませんでした。インデックスをいくつか削除して、再度実行してください。この操作を実行できませんでした。

3627 シンクロナイザの実行可能ファイル (MSTRAN40.EXE) が見つかりません。

3628 パートナー レプリカはシンクロナイザによって管理されていません。

3629 シンクロナイザ '<シンクロナイザ名>' も同じ File System ドロップボックス '<ドロップボックス名>' を使用しています。

3630 シンクロナイザ '<シンクロナイザ名>' も同じ File System ドロップボックス '<ドロップボックス名>' を使用しています。

3631 フィルタのテーブル名が正しくありません。

3632 インターネット トランスポートはリモート シンクロナイザ上では効果的ではありません。

3633 DLL '<DLL 名>' を読み込むことができません。

3634 部分レプリカを使用してレプリカを作成することはできません。

3635 システム データベースの部分レプリカを作成することはできません。

3636 レプリカに競合またはデータ エラーがあるため、レプリカにレコードを読み込んだりレプリカのフィルタを変更することはできません。

3637 サブクエリに非固定列のクロス集計を使用することはできません。

3638 ソース コントロール データベースはレプリケート可能にすることはできません。

3639 システム データベースのレプリカを作成することはできません。

3640 要求したデータの量に対してフェッチ バッファが小さすぎます。

3641 レコードセットには、要求されたレコードより少ないレコードしかありません。

3642 この操作はキャンセルされました。

3643 レコードセットのレコードの 1 つがほかのプロセスによって削除されました。

3645 バインド パラメータの 1 つが正しくありません。

3646 列の長さの合計より短い長さが指定されました。

3647 要求された列はレコード セットに返されていません。

3648 部分レプリカとほかの部分レプリカを同期することはできません。

3649 言語固有のコード ページが指定されていないか、見つかりません。

3650 インターネットが遅すぎるか、インターネット サーバーのレプリケーション マネージャの設定に問題があります。

3651 インターネットのアドレスが正しくありません。

3652 インターネットのログインに失敗しました。

3653 インターネットがセットアップされていません。

3656 部分式の評価でエラーが発生しました。

3657 テーブル '<テーブル名>' のブール型フィルタの式の評価でエラーが発生しました。

3658 バイナリ列 '<列名>' はブール型フィルタでは使用できません。

3659 リレーションシップ '<リレーションシップ名>' は実行できません。部分フィルタ式のリレーションシップは実行する必要があります。

3660 <description> のために要求された交換は失敗しました。

3661 <説明> のために要求された交換は失敗しました。

3663 この操作には別のカーソル ライブラリが必要です。

3664 非同期の OpenConnection 呼び出しはまだ完了していません。呼び出しが完了するまで返された Connection オブジェクトを参照することはできません。

3665 レプリケーション システム オブジェクト '<オブジェクト名>' を変更することはできません。

3666 レプリケーション システム オブジェクト '<オブジェクト名>' を変更することはできません。

3667 ほかの操作により、この操作は実行できなくなっています。

3668 アクティブな接続が存在しないので、この操作を実行することはできません。

3672 RDOCURS.DLL の読み込みに失敗しました。

3673 このテーブルには、このスプレッドシートで定義されている範囲外のセルが含まれています。

3674 インターネット DLL (WININET.DLL) が見つからないか、ロードできませんでした。

3675 インターネット ハンドルからの読み込みに失敗しました。再度実行してください。

3676 インターネット ハンドルへの書き込みに失敗しました。再度実行してください。

3677 HTTP 要求の実行に失敗し、インターネット サーバー上にあるインターネット シンクロナイザを起動できませんでした。Replication Manager を使用して、インターネット サーバー上のインターネット シンクロナイザを設定してください。

3678 インターネット サーバー上の FTP サービスへの接続に失敗しました。FTP サービスがサーバー上で正しく実行され、匿名での接続をサポートしていることを確認してください。

3679 FTP サービスを使用してファイルを開くことができませんでした。FTP ドロップボックスに読み取り権限があることを確認してください。

3680 FTP を使用してサーバーからファイルを取得できませんでした。FTP ドロップボックスに読み取り権限があることを確認してください。

3681 FTP を使用してサーバーにファイルを置くことができませんでした。FTP ドロップボックスに書き込み権限があることを確認してください。

3682 FTP を使用してサーバーのファイルを削除できませんでした。FTP ドロップボックスに読み取り/書き込み権限があることを確認してください。

3683 インターネット シンクロナイザがサーバー上で異常終了しました。インターネット サーバーにあるパートナー レプリカのデータ交換履歴を確認して、問題の原因を特定してください。

3684 データを交換する適切なレプリカがありません。

3685 HTTP アドレスが正しくありません。

3686 レプリカのパス、または名前が正しくありません。

3689 SQL 構文が正しくありません。正しいトークンは Privileges です。

3700 この精度は、decimal データ型には適用できません。

3701 この桁数は、decimal データ型には適用できません。

3702 UNICODE テキスト列の幅は、偶数バイト数であることが必要です。

3703 この操作は、現バージョンに変換されていないレプリケート可能なデータベースには実行できません。

3704 このデータベースは、マシン '<マシン名>' のユーザー '<ユーザー名>' が開いています。データベースが使用可能になった時点で、再度実行してください。

3705 列の数が多いので、<テーブル名> テーブルをレプリケートできません。

3706 インデックスの数が多いので、<テーブル名> テーブルをレプリケートできません。

3707 新しい参照に対する連鎖オプションが既存の参照 '<参照名>' と矛盾しています。

3708 Transaction ステートメントの構文エラーです。TRANSACTION または WORK を使用するか、何も入力しないでください。

3709 レコードに検索キーが見つかりませんでした。

3710 MAPI フォルダまたはアドレス帳が見つかりません。

3711 復旧されたレプリケート可能なデータです。この行は、破損したレプリケート可能なデータベースから復旧しました。レコードの内容が正しいことを確認し、レコードを再度挿入するか、この競合するレコードを削除してください。

3713 更新/更新の競合。ほかのレプリカもこのレコードを更新しました。このレコードには、競合がなくなりました。更新データを再発行するか、この競合データを削除してください。

3714 ロックされたテーブル。テーブルがほかのユーザーにロックされていたので、 このレコードは同期中には適用されませんでした。この競合レコードを再発行してください。

3715 一意なキーの規則に違反しています。

3716 TLV 違反です。

3717 削除/RI 競合です。

3718 更新/RI 競合です。

3719 外部キー違反です。

3720 フィールド '<フィールド名>' を変更できません。このフィールドは、1 つ以上のリレーションシップの一部です。

3721 SQL 構文が正しくありません。制約名が必要です。

3722 SQL 構文が正しくありません。正しいトークンは DEFAULT です。

3723 SQL 構文が正しくありません。WITH とその後に COMPRESSION が必要です。

3724 SQL 構文が正しくありません。正しいトークンは UPDATE または DELETE です。

3725 SQL 構文が正しくありません。正しいトークンは 'CASCADE'、'SET NULL'、または 'NO ACTION' です。

3726 SQL 構文が正しくありません。正しいトークンは NULL です。

3727 SQL 構文が正しくありません。使用できるのは、1 つの更新規則または 1 つの削除規則です。

3728 SQL 構文が正しくありません。正しいトークンは AS です。

3729 SQL 構文が正しくありません。正しいトークンは SELECT です。

3730 VIEW にはパラメータを使用できません。

3731 指定する別名の数は、出力列の数と同じにします。

3732 'EXECUTE' の後にクエリ名が必要です。

3733 認識できないユーザーがデータベースを開けない状態、またはロックできない状態にしています。

3734 マシン '<マシン名>' のユーザー '<ユーザー名>' がデータベースを開けない状態、またはロックできない状態にしています。

3736 更新/削除の競合。この更新されたレコードは、ほかのレプリカによって削除されました。この競合レコードを再度挿入するか、削除してください。

3737 指定されたソース レプリカからこのタイプのレプリカは作成できません。

3738 ローカルまたは匿名のレプリカは、レプリケーション元だけと同期する必要があります。

3740 競合テーブル '<テーブル名>' に新しい列を追加できません。古い列を削除して、データベースを最適化してください。

3741 無効なパートナー シンクロナイザです。ローカルまたは匿名のレプリカは、レプリケーション元だけと同期する必要があります。

3742 インターネット機能がタイムアウトしました。

3743 レプリカ セットの保有期間内に、レプリカが同期しませんでした。

3745 インターネット サーバー名、HTTP 共有名、および FTP 別名を合わせた文字数は、252 文字以下にします。

3746 パラメータ句の構文エラーです。パラメータが存在し、入力した値が正しいことを確認してください。

3747 パラメータにはデフォルト値はありません。

3748 パラメータ <パラメータ名> にはデフォルト値はありません。

3749 オブジェクトはストアド プロシージャではありません。

3750 オブジェクト <オブジェクト名> はストアド プロシージャではありません。

3751 データベースがページ ロック モードにあり、要求された行がロックされています。

3752 データベースが行ロック モードにあり、要求されたページがロックされています。

3753 Jet SQL レプリカのレプリカは作成できません。

3754 Prevent Deletes Replica からは削除できません。

3755 チェック制約 '<制約名>' は存在しません。

3756 チェック制約 '<制約名>' は既に存在します。

3757 Jet ソート DLL を正しくロードできませんでした。

3758 小数を丸めたために、データが切り捨てられました。

3759 小数を丸めたために、データが切り捨てられました。

3760 小数を丸めたために、データがオーバーフローしました。

3761 指定された数値は、小数フィールドの精度と合致しません。

3762 SQL 構文が正しくありません。正しいトークンは ACTION です。

3763 同時スキーマを変更したので、レプリカの作成に失敗しました。再度実行してください。

3765 チェック制約句の構文エラーです。

3766 VIEWS には、単純な SELECT クエリしか使用できません。

3767 テーブル '<テーブル名>' を排他的に開くことができなかったので、レプリケート可能にできませんでした。

3768 FastFind では、列ではない参照は検索できません。

3769 競合テーブルは、名前を変更できません。

3770 カウンタの定義が有効な範囲ではありません。

3771 ローカルまたは匿名のレプリカは、デザイン マスターにはできません。

3772 管理者の許可を得ていない場合は、レプリカの優先度は 0 - 1 の範囲にします。

3773 1 つ以上のオブジェクト <オブジェクト名> を削除できません。

3775 Jet SQL Server Reconciler (MSRPJT40.DLL) をロードできません。

3777 Jet SQL Server レプリカで不正な操作を行いました。

3778 Jet データベースがこの SQL/Jet レプリカ セットに対して正しくないか、見つかりません。

3779 既にレプリケート可能になっているオブジェクトでは、Column Level Tracking プロパティを変更できません。

3780 SQL 構文が正しくありません。ビュー名が必要です。

3781 SQL 構文が正しくありません。プロシージャ名が必要です。

3784 データベースは既にレプリケート可能になっています。

3785 SQL 構文が正しくありません。正しいトークンは Database です。

3786 SQL 構文が正しくありません。CREATEDB または CONNECT などのデータベース権限が必要です。

3787 この操作は、サブクエリでは実行できません。

3788 この MAPI フォルダ/アドレス帳には、インデックスを作成できません。

3789 列レベルの制約が正しくありません。

3798 チェック制約は、レプリケート可能なデータベースには使用できません。

3799 フィールド '<フィールド名>' が見つかりませんでした。

3800 '<インデックス名>' は、このテーブルのインデックスではありません。

3801 オブジェクト (<オブジェクト名>) は、CHECK CONSTRAINT 句には使用できません。

3802 <制約名> CHECK 制約の評価でエラーが発生しました。<付加情報>

3803 このテーブルで DDL を完了できません。この DDL は、テーブル <テーブル名> の制約 <制約名> で参照されています。

3804 このマシンには MAPI クライアントがインストールされていません。Outlook などの MAPI クライアントをインストールしてください。

3805 テーブル <テーブル名> のチェック制約はこのテーブルに転送されません。チェック制約を作成する場合は、SQL DDL ステートメントを使用する必要があります。

3806 NULL 属性および NOT NULL 属性は複数作成することはできません。

3807 クエリ <クエリ名> にあいまいな列名があり、関連名 (別名) と重複しています。

3808 この操作を実行するには、システム データベースの Version 4.x 以上が必要です。


式が複雑すぎます。(Error 2445)

この式は Microsoft Jet データベース エンジンには複雑すぎます。式を簡単にしてください。


レジストリで ParadoxNetStyle セクションが 3.x に設定されているので、Paradox 4.x または 5.x のテーブルを開くことはできません。(Error 3419)

テーブルのバージョンと、Microsoft® Windows® レジストリの ParadoxNetStyle の設定との間に矛盾があるため、Microsoft Jet データベース エンジンは Paradox の外部テーブルを開くことができませんでした。

次のように対処してください。

  1. アプリケーションを終了します。

  2. レジストリ エディタを起動し、\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox キーを検索して、ParadoxNetStyle の値を選択します。

  3. [編集] メニューの [変更] をクリックします。

  4. [値のデータ] ボックスで、値 4.x を指定します。

  5. ParadoxNetStyle の設定は、データベースを共有するすべてのユーザーで同じ設定にする必要があります。

  6. アプリケーションを再起動します。

  7. もう一度テーブルを開きます。


このデータベースを修復できませんでした。(Error 3056)

データベースが破損しているか、または Microsoft Jet データベースではありません。Microsoft® Jet データベースの場合は、バックアップ コピーからデータベースをロールバックしてください。または、新しいデータベースを作成し直してください。


この操作はキャンセルされました。(Error 3642)

クエリの実行がデータ ソースにより中断されているため、一致している行のいくつかが返されていません。もう一度クエリを実行してください。


オブジェクト <オブジェクト名> を使用する権限がありません。システム管理者またはこのオブジェクトの作成者から権限を取得してください。(Error 3033)

指定したオブジェクトに対する権限を持っていません。システム管理者、またはオブジェクトの作成者に依頼して、権限の割り当てを変更してください。


既に存在するアカウント名です。(Error 3390)

セキュリティ上の問題です。既に存在する名前を使用してユーザー アカウントを作成しようとしました。Users コレクションにあるユーザー名を確認し、別のユーザー名を使用してもう一度実行してください。


要求された列はレコード セットに返されていません。(Error 3647)

要求された列の 1 つが使用できません。


データベースをレプリケート可能にするために必要な列を追加できませんでした。(Error 3580)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


式 (<式>) で集計関数を使用することはできません。(Error 3095)

この式で、集計関数を使用することはできません。


GROUP BY 句 (<句>) で集計関数を使用することはできません。(Error 3098)

SQL ステートメントの GROUP BY 句で集計関数を使用することはできません。


JOIN 操作 (<操作>) で集計関数を使用することはできません。(Error 3099)

SQL ステートメントの JOIN 操作で集計関数を使用することはできません。


ORDER BY 句 (<句>) で集計関数を使用することはできません。(Error 3097)

SQL ステートメントの ORDER BY 句で集計関数を使用することはできません。


WHERE 句 (<句>) で集計関数を使用することはできません。(Error 3096)

SQL ステートメントの WHERE 句で集計関数を使用することはできません。


式 (<式>) にサブクエリは指定できません。(Error 3203)

指定した式には、サブクエリ、またはサブクエリと同じ機能を持つ式が含まれています。

原因：

  • SELECT ステートメントに、別の集計関数を評価する集計関数が含まれています。たとえば、次のステートメントを実行すると、このエラーが発生します。

    TRANSFORM Sum([OrderAmount]) AS Sum1

    SELECT Sum([Sum1]) AS Sum2, OrderID, Sum([Sum2]) AS Expr1

    FROM Orders

    GROUP BY OrderID

    PIVOT ShipName;

    SELECT ステートメントの式 Sum([Sum2]) は同じ SELECT ステートメントで使用されている別名を参照し、Sum([Sum1]) に対してサブクエリとして機能します。このためエラーになり、警告メッセージの <式> パラメータは式 Sum([Sum2]) になります。


集計関数の式では GUID を使用することはできません。(Error 3600)

SQL ステートメントでは、MAX、MIN、SUM などの集計関数で GUID 型 (GUID) を持つ列は使用できません。


レプリカ用の有効な名前はすべて使用されています。(Error 3555)

レプリカ セットのレプリカの数が作成可能な最大数 (32,768) に達しました。新しいレプリカ セットを作成してください。


Microsoft Jet データベース エンジンは既に初期化されています。(Error 3279)

Microsoft Jet データベース エンジンを初期化しようとしましたが、既に初期化されています。


AddNew メソッドまたは Edit メソッドは、既に適用されています。(Error 3023)

現在の変更を保存またはロールバックしないまま、別のレコードの追加や変更をしようとしました。Rollback または Update メソッドを使用してから、AddNew または Edit メソッドを使用してください。


テキスト ファイル形式のフィールド区切り記号に、桁やテキストの区切り記号と同じ記号は使用できません。(Error 3441)

テキスト ISAM で使用されている次の区切り記号設定のうちの複数が同じ記号です。

TxtDelimiter

NumberDecimalSymbol

CurrencyDecimalSymbol

Format


構文エラー (Error 2438)

入力した式には、無効な構文が含まれています。必要なオペランドや演算子が入力されていない、文字やカンマ (,) が正しくない、またはテキストがダブル クォーテーション ("") で囲まれていないなどの可能性があります。入力した式が正しいかどうかを確認してください。


日付の構文エラーです。(Error 2421)

Date の構文が正しくありません。このエラーは、無効な日付を指定した場合に発生します。たとえば、9 月は 30 日しかないので、94/9/31 は無効です。


'.'、'!'、または '()' の使い方が正しくありません。(Error 2423)

ドット (.)、! 演算子、またはかっこの使い方が正しくありません。DAO オブジェクトのプロパティを参照するには、.propertyname の構文の使用をお勧めします。


IIF 関数に対応する '()' がありません。(Error 2440)

IIf 関数では、次の構文のように引数をかっこで囲む必要があります。

IIf (expr, truepart, falsepart)


In 演算子に '()' がありません。(Error 2429)

SQL ステートメントで In 演算子を使用する場合は、調べるアイテムのリストをかっこで囲む必要があります。たとえば、ある値が値の集合に含まれているかどうかを調べるには、SQL クエリの WHERE 句で次のように使用します。

WHERE Region In ('TX', 'CA', 'WA')

このコードでは、テキサス州、カリフォルニア州、ワシントン州を表す区切り記号が Region フィールドに含まれているかどうかを調べます。


Is 演算子の使い方が正しくありません。(Error 2443)

Is 演算子は式が Null かどうかを調べるために使用します。Is 演算子は、NULL または NOT NULL を伴う式でのみ使用できます。


サーバーの MSysConf テーブルが見つかりました。ただし、正しい形式ではないので、システム管理者に確認してください。(Error 3407)

サーバー上に作成される MSysConf テーブルは、Microsoft Jet データベース エンジンとそれにリンクされている ODBC データ ソースとの通信を制御するために使用される、非常に特殊な形式のテーブルです。


数値の構文エラーです。(Error 2420)

入力した値は無効です。このエラーは、式の一部として数値以外の値を入力した場合に発生することがあります。


範囲が正しくありません。(Error 3181)

インポートしようとしたワークシートのセルの範囲が無効です。


文字列の構文エラーです。(Error 2422)

入力した式には、無効な文字列が含まれています。入力した式が正しいかどうかを確認してください。


垂直バーの使い方が正しくありません。(Error 2437)

入力した式で、垂直バーの使い方が正しくありません。入力した式が正しいかどうかを確認してください。


テーブル名が正しくありません。(Error 3177)

入力したテーブル名が名前付け規則に従っていません。正しいテーブル名を入力してから、もう一度実行してください。


バイナリ列 '<列名>' はブール型フィルタでは使用できません。(Error 3658)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ファイル形式が正しくありません。(Error 3182)

原因と対策：

  • 読み取りまたはリンクをしようとしたファイルが破損しています。バックアップ コピーを使用してファイルをディスクにロールアップしてから、もう一度実行してください。

  • ファイル形式を認識できません。ファイルが Btrieve、dBASE、または Paradox のファイルの場合は、セットアップ プログラムを実行して、組み込み可能な ISAM をセットアップしてから、もう一度ファイルをリンクしてください。


テーブル '<テーブル名>' のブール型フィルタの式の評価でエラーが発生しました。(Error 3657)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


部分レプリカとほかの部分レプリカを同期することはできません。(Error 3648)

同期を取ろうとしているデータベースは部分レプリカです。部分レプリカのフィルタに対応するすべてのレコードを、別の部分レプリカは含んでいないため、レプリカと別の部分レプリカ間では同期を取ることはできません。


Between 演算子に対応する And がありません。(Error 2430)

Between 演算子を使用して、式の値が指定の値の範囲内にあるかを調べる場合は、予約語 And の前後に範囲の上限と下限を入力します。たとえば、"A" から "C" までを範囲として調べるには、次のように使用します。

WHERE fldName Between "A" And "C"


シンクロナイザはメッセージ データベースにアクセスできませんでした。(Error 3525)

シンクロナイザがメッセージ データベースを使用できません。別のプログラムまたはユーザーがデータベース ファイルを使用している可能性があります。ユーザーはシンクロナイザのメッセージ データベースを開かないでください。データベースを使用している可能性のあるアプリケーションを閉じてください。


指定されたレプリケーション元からこのタイプは作成できません。(Error 3737)

指定されたソース レプリカからこのタイプのレプリカは作成できません。(Error 3737)

グローバル レプリカを除いて、可視性が異なるレプリカは作成できません。たとえば、ローカル レプリカが作成できるのはローカル レプリカだけ、匿名レプリカが作成できるのは匿名レプリカだけです。グローバル レプリカは、グローバル、ローカル、匿名のいずれのレプリカも作成できます。


システム データベースの部分レプリカを作成することはできません。(Error 3635)

ワークグループの情報ファイルをソースとして、部分レプリカを作成しようとしています。ワークグループの情報ファイルはレプリケートすることができません。


部分レプリカを使用してレプリカを作成することはできません。(Error 3634)

部分レプリカをソースとして、レプリカを作成しようとしています。部分レプリカはレプリケートすることができません。


DLL '<ファイル名>' が見つかりません。(Error 3463)

指定した DLL (ダイナミック リンク ライブラリ) がパスの中に存在するかどうかを確認してください。存在しない場合は、Microsoft レプリケーション マネージャ、またはアプリケーションをもう一度セットアップしてください。


シンクロナイザは、MSysExchangeLog テーブル内に特定の同期のレコードを見つけることができません。(Error 3522)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


シンクロナイザの実行可能ファイル (MSTRAN40.EXE) が見つかりません。(Error 3627)

シンクロナイザを起動しようとしましたが、実行可能ファイル Mstran40.exe が指定したパスが見つかりませんでした。


シンクロナイザまたはレプリケーション マネージャはシステム オブジェクトを見つけることができませんでした。(Error 3527)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


シンクロナイザは、MSysSchChange テーブル内に特定のバージョン番号を見つけることができません。(Error 3523)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


コンテナ <コンテナ名> 内のオブジェクト <オブジェクト名> をレプリケート可能にできません。(Error 3583)

指定したコンテナのオブジェクト (テーブル、フォーム、レポート、モジュール、マクロ) はレプリケート可能にすることができません。

レプリケート可能にすることができないオブジェクトの例としては、253 以上のフィールドを持つテーブルがあります。レプリケーションを行うには、最低 3 文字を追加する必要があるため、この例の場合では 255 のフィールドの制限を超えてしまいます。


レプリケーション システム オブジェクト '<オブジェクト名>' を変更することはできません。(Error 3665)

システム テーブルの削除、システム テーブル名の変更、レプリケーション システム列の削除など、内部レプリケーション システム オブジェクトに対して無効な操作を実行しようとしています。


レプリケーション システム オブジェクト '<オブジェクト名>' を変更することはできません。(Error 3666)

システム テーブルの削除、テーブル名の変更、レプリケーション列の削除など、内部レプリケーション システム オブジェクトに対して無効な操作を実行しようとしています。


アプリケーションを起動できません。システム データベースが存在しないか、またはほかのユーザーが排他的にシステム データベースを開いています。(Error 3028)

Microsoft Jet データベース エンジンが作成したデータベースの参照整合性を保つには、アプリケーションの中で Microsoft® Jet データベースの System.mdw ファイルを参照する必要があります。Windows レジストリの \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet キーの SystemDB で指定した場所に、このファイルがあるかどうかを確認してください。


インストール可能な ISAM ドライバのファイル名を変更できませんでした。(Error 3013)

Btrieve、dBASE、または Paradox のテーブル名を変更しようとしましたが、そのテーブルのあるファイル名を変更することができませんでした。

原因：

  • ファイルがオペレーティング システムまたはネットワークで、読み取り専用として定義されています。

  • ネットワーク環境で、そのファイルに書き込む権限がありません。


PARADOX.NET を開くことができませんでした。(Error 3172)

原因と対策：

  • \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox レジストリ キーの ParadoxNetPath の値が無効です。たとえば、Paradox の外部データベースを使用していて、ParadoxNetPath の値が指すディレクトリが存在しない場合に、このエラーが発生します。アプリケーションを終了し、無効なエントリを修正してから、もう一度実行してください。

  • ParadoxNetPath の値がネットワーク ドライブを指していますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。


2 番目の Replication ID オートナンバー フィールドをテーブルに追加することはできません。(Error 3486)

変更しようとしているテーブルには、レプリケーション ID オートナンバー型 (AutoNumber) フィールド (または GUID 型 (GUID)) を使用しているフィールドが既にあります。外部キーとして機能する 2 つ目のレプリケーション ID フィールドを作成しようとしている場合は、データ型としてオートナンバー型 (AutoNumber) ではなく Numeric 型 (Numeric) を使用してください。


データベース サイズが上限に達しました。(Error 3036)

このデータベースにデータを追加するには、データを削除してデータベースのサイズを小さくする必要があります。Microsoft® Jet データベース Version 3.x およびそれ以前のバージョンでは、データベースの最大サイズは 1.07GB です。Microsoft Jet Version 4.0 データベースでの最大サイズは、2.14GB です。


レプリカのデザインは変更できないので、同期できませんでした。(Error 3492)

Microsoft Jet データベース エンジンは、レプリカ セットのいずれかのレプリカのデータベースのデザインを更新できませんでした。デザインを更新できなかった原因として、次のどちらかが考えられます。

  • 更新しようとしているオブジェクトを既にレプリカの中で開いています。

  • 強制リレーションシップをレプリカに追加しましたが、存在しない主キーを参照している外部キーがレプリカに含まれています。

同期の失敗に関する詳細については、デザイン マスターで、または同期の対象となったレプリカで、MSysSchemaProb テーブルを調べてください。


セッションを開始できませんでした。(Error 3002)

新しいセッションを必要とする処理を開始しようとしましたが、同時に使用できるセッションの最大数に達しています。ほかの処理が終了するまで待つか、またはほかの処理を終了してから、もう一度実行してください。


キーを設定できませんでした。(Error 3250)

主インデックスを作成しようとしましたが、Microsoft Jet データベース エンジンは主キーを作成できませんでした。主キー フィールドの名前が正しいかどうか、また、そのキーを元にした重複するレコードがないかどうかを確認してください。

たとえば、Recordset オブジェクトに対して Seek メソッドを使用する場合、Recordset オブジェクトのカレント インデックスとして、元になるテーブルの "氏名" フィールドが使用されている場合、次のように記述するとエラーになります。

rstEmployees.Seek "=", "東京都", "課長"

Microsoft® Jet データベース エンジンは 2 つのフィールドから主キーを作成しようとしますが、フィールドの 1 つにはインデックスが設定されているため、主キーの作成は失敗し、エラーになります。


共有モードで開いているテーブルのパスワードを変更することはできません。(Error 3621)

パスワードを変更するには、データベースを排他モードで開く必要があります。


このレプリカでは、データベースのデザインは変更できません。(Error 3452)

レプリケートされたデータベースのデザインは、デザイン マスターでのみ変更できます。変更しようとしているレプリカは、レプリカ セット用のデザイン マスターではありません。デザイン マスターで変更してください。


レプリケートを試みているデータベースを変換できません。(Error 3487)

レプリケート可能にできるデータベースは、Microsoft Jet データベース エンジンの 3.0 以降のバージョンを使用して作成したデータベースのみです。組み込み可能な ISAM を使用してこのデータベースを開くことはできますが、レプリケートされた形式に変換することはできません。データベースが前のバージョンの Microsoft® Jet データベース エンジンで作成されたものである場合は、Microsoft Access の [ツール] メニューの [データベース ユーティリティ] の [データベースの変換] をクリックし、データベースの形式を新しいバージョンの形式に変換してください。データベースが Jet 以外の形式である場合には、新しい Microsoft Jet データベース エンジンにデータをエクスポートしてから、もう一度実行してください。


GUID を作成できませんでした。(Error 3553)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


システム データベースのレプリカを作成することはできません。(Error 3639)

ワークグループの情報ファイルはレプリケートできません。


指定したシンクロナイザのレジストリ パラメータを削除できません。(Error 3551)

使用しているコンピュータのシンクロナイザの再設定を行う必要があります。

シンクロナイザの設定を行うには、次の操作を行ってください。

  1. Microsoft レプリケーション マネージャを起動します。

  2. [ツール] メニューの [レプリケーション マネージャの構成] をクリックします。

  3. ウィザードの指示に従ってください。


データベースが排他モードで開いていることを確認できないため、データベースをレプリケートできません。(Error 3578)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


レプリケートされているテーブルとローカル テーブルの間にリレーションシップを設定したり、設定を変更することはできません。(Error 3453)

レプリケートされたテーブルとレプリケートされていないテーブルとの間に強制リレーションシップを確立または保持しようとしています。レプリケーションでは、次の強制リレーションシップは確立できません。

  • レプリケートされたテーブルとローカル テーブルとの間のリレーションシップ

  • レプリケート可能にしようとしている 2 つのローカル テーブルの間のリレーションシップ

  • KeepLocal プロパティの設定が異なる 2 つのテーブルの間のリレーションシップ

2 つのテーブル間のリレーションシップを削除してから、作業を進めてください。


<制約名> CHECK 制約の評価でエラーが発生しました。<付加情報> (Error 3802)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


レプリケーション マネージャが、MSysExchangeLog テーブルで ExchangeID を見つけることができません。(Error 3496)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


シンクロナイザはメッセージのソース ファイルを見つけることができません。(Error 3564)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


デスティネーション シンクロナイザは間接同期をサポートするように設定されていません。また、デスティネーション レプリカは直接同期に使用できません。(Error 3516)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


MSysTranspAddress テーブルでシンクロナイザを見つけることができませんでした。(Error 3518)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


このシンクロナイザに対する有効なトランスポートが見つかりませんでした。(Error 3509)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


DLL '<DLL 名>' を読み込むことができません。(Error 3633)

指定した DLL は登録されていないか、またはパスにありません。


テーブル <テーブル名> は現在使用されているので、開くときにロックを試みてもロックできません。後で、再度実行してください。(Error 3009)

共有モードでアクセスを試みたテーブルは、別のユーザーによって排他ロックされています。または、排他的に開こうとしたテーブルは、別のユーザーによって共有ロックされています。返されたユーザー名は、現在ロックしているユーザーを示します。


.INF ファイル を開くことができませんでした。(Error 3165)

dBASE のテーブルにリンクしようとしましたが、そのテーブルのインデックス情報が保存されている .inf ファイルを開くまたは作成することができませんでした。

原因：

  • .inf ファイルの作成に必要なディスクの空き容量が不足しています。

  • ネットワーク環境で、ネットワーク ドライブに対する書き込み権限がありません。


データベースをレプリケート可能にできません。(Error 3455)

リソース不足のため、Microsoft Jet データベース エンジンはデータベースをレプリケート可能にする処理に失敗しました。レプリケーション完了後のテーブルの全フィールド数が 255 個以下になること、および、レコードの全バイト数が 2,048 バイト以下になることを確認してください。


部分レプリカをレプリカ セットのデザイン マスターにすることはできません。(Error 3479)

別のレプリカをデザイン マスターとして選択してください。


データベースをレプリケートした後で、レプリケート不可能に設定し直すことはできません。(Error 3459)

既にレプリケート可能にされているデータベースは、Replicable プロパティに "T" を設定したり、あるいは Microsoft® Windows® のブリーフケースや Microsoft Access、Microsoft レプリケーション マネージャなどを使用して変換しても、レプリケーションの機能を取り去ることはできません。また、DAO を使用してデータベースの Replicable プロパティに "F" やその他の値を設定しても、レプリケートされたデータベースには効果がありません。レプリケーションに関連するプロパティ、フィールド、テーブルなどの属性を持たないデータベースのコピーを使用する場合は、データベースを初めて変換する前に作成したバックアップ コピーを開いてください。


ファイル '<ファイル名>' を開くことができませんでした。(Error 3176)

指定したテキスト ファイルまたはワークシート ファイルを開くことができませんでした。ファイルの指定が無効であるか、別のユーザーがファイルにアクセスしているか、あるいはファイルの読み取り権限を持っていない可能性があります。ほかのユーザーがファイルの使用を完了してからもう一度実行してください。または、システム管理者やネットワーク管理者に権限の変更を依頼してください。


ログ ファイル '<ファイル名>' を書き込み用に開くことができません。(Error 3474)

ログ ファイルに書き込む権限があるかどうかを確認してください。


Word の差し込み文書をリンクまたはインポートすることはできません。(Error 3439)

Microsoft® Word の差し込み文書ファイルをリンクまたはインポートしようとしました。ファイルのエクスポートは可能ですが、リンクやインポートはできません。


パスワードで保護されているデータベースをレプリケートすることはできません。また、レプリケートされたデータベースにパスワードを設定することはできません。(Error 3592)

既にデータベースにパスワードを設定している場合は、パスワードの設定を解除してください。


レプリカに競合またはデータ エラーがあるため、レプリカにレコードを読み込んだりレプリカのフィルタを変更することはできません。(Error 3636)

部分レプリカのフィルタを変更しようとしているか、部分レプリカを配置しようとしているため、レプリカで競合が生じたか、データのエラーが発生しています。作業を続ける前に、発生した競合やエラーを解消する必要があります。競合やエラーを解消することで、競合の情報で生じる無駄な時間のロスを防ぐことができ、またエラーが正しく修正されたことを確認することができます。


レプリカ セットのメンバの絶対パス情報を取得できません。(Error 3499)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


指定されたシンクロナイザのレジストリ パラメータの値を取得できません。(Error 3494)

使用しているコンピュータのシンクロナイザの再設定を行う必要があります。

シンクロナイザの設定を行うには、次の操作を行ってください。

  1. Microsoft レプリケーション マネージャを起動します。

  2. [ツール] メニューの [レプリケーションマネージャの構成] をクリックします。

  3. ウィザードの指示に従ってください。


値を設定できません。(Error 2448)

読み取り専用または値のないオブジェクトに値を割り当てようとしました。


既にレプリケートされているオブジェクトの KeepLocal プロパティを設定することはできません。(Error 3457)

レプリケート オブジェクトには KeepLocal プロパティを設定できません。データベースをレプリケートした後にローカル オブジェクトに KeepLocal プロパティを設定しても効果はありません。オブジェクトがレプリカ セットのほかのレプリカにレプリケートされないようにする場合は、そのオブジェクトの Replicable プロパティに "F" を設定してください。


レプリカ セットのデータのマスター属性を変更することはできません。データはデザイン マスターだけで変更できます。(Error 3594)

データベースを初めてデザイン マスターに変換する場合、レプリカ セットのすべてのレプリカでデータ変更を許可するのか (複数データ マスター)、またはデザイン マスターでのみデータ変更を許可するのか (単一データ マスター) が決まります。データベースの変換後に単一データ マスターまたは複数データ マスターの属性を変更することはできません。


レプリカ セットのデータのマスター属性を変更することはできません。(Error 3593)

データベースを初めてデザイン マスターに変換する場合、レプリカ セットのすべてのレプリカでデータ変更を許可するのか (複数データ マスター)、またはデザイン マスターでのみデータ変更を許可するのか (単一データ マスター) が決まります。データベースの変換後に単一データ マスターまたは複数データ マスターの属性を変更することはできません。


指定されたシンクロナイザのレジストリ パラメータを設定できません。(Error 3493)

使用しているコンピュータのシンクロナイザの再設定を行う必要があります。

シンクロナイザの設定を行うには、次の操作を行ってください。

  1. Microsoft レプリケーション マネージャを起動します。

  2. [ツール] メニューの [レプリケーション マネージャの構成] をクリックします。

  3. ウィザードの指示に従ってください。


レプリケーションのシステム列を更新できません。(Error 3577)

更新しようとしている列はシステム列であり、読み取り専用です。


この操作は、主キーのない Paradox テーブルでは実行できません。(Error 3207)

テーブルを作成したアプリケーションを実行して主キーを追加してから、もう一度実行してください。


シンクロナイザ ログ ファイルに書き込むことができません。(Error 3471)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ファイル '<ファイル名>' に書き込むことができませんでした。(Error 3180)

指定したテキスト ファイルまたはワークシート ファイルにデータをエクスポートしようとしましたが、そのファイルを変更できませんでした。

原因：

  • 現在、ほかのユーザーがそのファイルにアクセスしています。そのユーザーが使用を完了してから、もう一度実行してください。

  • ファイルはオペレーティング システムまたはネットワークによって読み取り専用として設定されています。読み取り専用の属性を解除してから、もう一度実行してください。

  • ネットワーク環境で、ファイルに書き込む権限がありません。

以上の点については、システム管理者またはネットワーク管理者に問い合わせてください。


このテーブルには、このスプレッドシートで定義されている範囲外のセルが含まれています。(Error 3673)

読み込んでいるワークシート ファイルは、正しい形式に従っていません。このファイルに含まれるデータが、ファイルのヘッダー情報で指定された範囲の外にあります。ファイルが正しい形式に従っていない場合は、ワークシート ドライバにデータが正しく読み込まれません。

このファイルはワークシート ファイルでないか、ファイルが破損している可能性があります。ワークシートを作成したアプリケーションでファイルを読み込み、別のファイルとして保存し直してみてください。ワークシート製品を利用することで、エラーを回避できる可能性があります。


フィールド '<フィールド名>' を変更できません。このフィールドは、1 つ以上のリレーションシップの一部です。(Error 3720)

このエラーは、ほかの外部キーが参照する主キーの名前または定義を変更しようとした場合に発生します。主キーに関係する列の定義または名前を変更するには、最初に主キーに対するすべての外部キー参照を削除する必要があります。通常、このエラーは ALTER TABLE ALTER COLUMN ステートメントを使用する場合に発生します。


チェック制約 '<制約名>' は存在しません。(Error 3755)

このエラーは、ALTER TABLE ALTER COLUMN 構文を使用して、存在しない CHECK 制約を削除しようとした場合に発生します。また、Microsoft® OLE DB Provider for Jet を使用して、存在しない CHECK 制約に関する情報を取得しようとした場合にも発生することがあります。


チェック制約句の構文エラーです。(Error 3765)

このエラーは、SQL DLL を使用して CHECK 制約を定義する場合に発生します。また、CHECK 句で検索条件 (SELECT ステートメント) が無効なテーブル名や列名を参照している場合に発生します。


チェック制約 '<制約名>' は既に存在します。(Error 3756)

このエラーは、ALTER TABLE ALTER COLUMN 構文を使用して、テーブルで既に使用されている CHECK 制約の制約名を使用しようとした場合に発生します。また、Microsoft® OLE DB Provider for Jet を使用して、同じテーブル内のほかの CHECK 制約と同じ名前の CHECK 制約を追加しようとした場合にも発生することがあります。


クライアントはシンクロナイザに処理を終了するよう要求しました。(Error 3535)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


作成されるテーブルは、複数のオートナンバー フィールドを含むことはできません。(Error 3090)

このクエリを実行すると、複数のオートナンバー型 (AutoNumber) の複数のフィールドを含むテーブルが作成されます。オートナンバー型 (AutoNumber) フィールドが 1 つのみになるようにクエリを修正してください。


指定されたフィールドにはインデックスを作成できません。(Error 3287)

メモ型 (Memo) または OLE オブジェクト型 (OLE Object) フィールドにインデックスを作成しようとしました。別のデータ型のフィールドを指定してから、もう一度実行してください。

また、Btrieve テーブルの 1 バイト フィールドにインデックスを作成しようとした場合にも、このエラーが発生します。


ユニオン クエリで選択した 2 つのテーブルまたはクエリの列数が一致しません。(Error 3307)

UNION 操作によって結合する 2 つのテーブルまたはクエリは、同じ列数である必要があります。列数の多い SELECT ステートメントから列を削除するか、または列数の少ない SELECT ステートメントに列を追加してください。

メモ 列数の少ない SELECT ステートメントでは、列の代わりに定数を使用することができます。たとえば、次の ユニオン クエリの例では、最初の SELECT ステートメントからは 3 つの列が出力されますが、2 番目の SELECT ステートメントからは 1 つのフィールドと 2 つの定数が出力されます。このクエリは、[社員] テーブルと [地区] テーブルにあるすべての都道府県を返します。また、[社員] テーブルからは、社員の氏名とフリガナも返します。しかし、都道府県の値が [地区] テーブルからのものである場合は、"氏名"と "フリガナ" の各列に Null 値を返します。

SELECT Country, FirstName, LastName FROM Employees

UNION SELECT Country, NULL, NULL FROM Regions;


フィールドがレコードに適合しません。(Error 3016)

インポートまたは貼り付けをしようとしたフィールドが大きすぎます。フィールドを分割してからデータをインポートするか、貼り付けてください。または、フィールドのデータ型を変更してください。

レコードのサイズは、メモ型 (Memo) と OLE オブジェクト型 (OLE Object) のフィールドを除いてすべて 2KB 以下に制限されています。


複数回フィールドを定義することはできません。(Error 3191)

複数のフィールドが同じ名前で定義されているテーブルを作成しようとしました。テーブルの各フィールドは固有の名前を持っている必要があります。


このフィールドは削除できません。1 つ以上のリレーションシップで使用されています。(Error 3303)

データベースでリレーションシップが定義されているフィールドを削除しようとしています。フィールドを削除するには、先にそのリレーションシップを削除してください。


インデックスとして使用されているフィールド、またはシステムに必要なフィールドは削除できません。(Error 3280)

インデックスの要素になっているフィールドを削除するには、先にそのインデックスを削除する必要があります。


既にレプリケート可能になっているオブジェクトでは、Column Level Tracking プロパティを変更できません。(Error 3779)

いったんレプリケート可能にされたオブジェクトでは、列レベル トラッキング プロパティを変更できません。オブジェクトのトラッキングのみを変更する場合は、オブジェクトをローカルに戻して列レベル トラッキング プロパティを変更し、もう一度オブジェクトをレプリケート可能にしてください。


フィールドが見つかりませんでした。(Error 3018)

原因：

  • 指定したフィールドが存在しません。

  • フィールド名に誤りがあります。アンダースコア (_) などの区切り記号が抜けていないかどうか、または先頭にスペースを入れていないかどうかを確認してください。

  • 無効なフィールド識別子を入力しました。たとえば、Mytable![My Field] ではなく、[My Table] [My Field] と入力しています。

  • スペースを含むフィールド名を角かっこで囲んでいるかどうかを確認してください。


フィールド '<フィールド名>' が見つかりませんでした。(Error 3799)

存在しない列名を参照しています。


JOIN 操作 '<操作>' は結合テーブルにないフィールドを参照しています。(Error 3082)

SQL ステートメントを実行しようとしましたが、正しくない結合を指定しています。結合したテーブルのいずれかに存在しないフィールドで結合しようとすると、このエラーが発生します。たとえば、次のステートメントはエラーになります。

SELECT 著者.氏名, タイトル.ISBN

FROM 著者, タイトル, 著者またはタイトル

著者 INNER JOIN タイトル ON 著者.番号 = 著者またはタイトル.ISBN;

この結合では [著者] テーブルと [タイトル] テーブルが対象になっていますが、結合したフィールドは [著者] テーブルと [著者またはタイトル] テーブルにあるため、エラーになります。


フィールドを更新できません。(Error 3164)

原因：

  • 現在、ほかのユーザーによってロックされているレコードまたはテーブルのフィールドを更新しようとしました。ほかのユーザーがレコードやテーブルの処理を完了してから、もう一度実行してください。

  • Microsoft® Access で、Locked プロパティが Yes に設定されているコントロールの値を変更しようとしました。


列数が上限値を超えているため、テーブルをレプリケートできません。(Error 3585)

テーブルの列数が使用できる最大数を超えています。テーブルの列数が 251 よりも少ない場合は、データベースを最適化することで、使用可能な列を取得できる可能性があります。


フィールド サイズが長すぎます。(Error 3017)

原因：

  • 255 バイト以上のテキスト型 (Text) フィールドを定義または作成しようとしました。文字数を 254 バイト以下にするか、または、メモ型 (Memo) フィールドを使用してください。

  • 255 バイトを超える文字数を持つクエリ パラメータを定義しようとしています。


UNICODE テキスト列の幅は、偶数バイト数であることが必要です。(Error 3702)

データベースでは、データは Unicode 表示形式に変換されてから格納されます。Unicode 文字セットの各文字は、サイズが 1 ワード (2 バイト) の値です。列に Unicode 文字の正しい数を保持させるためには、テキスト用の列の宣言で、偶数バイトの列幅を指定する必要があります。

  • このエラー メッセージがデータベースの作成中に表示された場合は、無効なデータベースを修正する必要があります。

  • このエラー メッセージが実行中に表示された場合は、データベースが破損している可能性があります。データベースを最適化または修復してください。


インターネット サーバー名、HTTP 共有名、および FTP 別名を合わせた文字数は、252 文字以下にします。(Error 3745)

指定した間接またはインターネット値が、内部上限値の 252 文字を超えています。この上限を超えないように、名前を短くする必要があります。


このレコードは現在ほかのユーザーによってロックされているので、読み取ることができませんでした。(Error 3624)

2KB のデータベース ページにあるレコードを読み取ろうとしましたが、そのページは現在、ほかのユーザーによってロックされています。そのユーザーがレコードの処理を完了するまで待ってから、もう一度実行してください。


マシン '<マシン名>' のユーザー '<ユーザー名>' によってロックされているので、読み取れませんでした。(Error 3187)

現在、ほかのユーザーによってロックされているデータベースのページにある情報を読み取ろうとしました。ほかのユーザーが処理を完了してから、もう一度実行してください。


同時スキーマを変更したので、レプリカの作成に失敗しました。再度実行してください。(Error 3763)

レプリカを作成する操作を実行中に、作成元のレプリカで新しいオブジェクトが作成された可能性があります。作成する操作を連続して行うことはできません。もう一度実行してください。


新しい参照に対する連鎖オプションが既存の参照 '<参照名>' と矛盾しています。(Error 3707)

このエラーは、既に CASCADE 操作が定義されている列に、ほかの種類の CASCADE 操作を定義すると発生します。たとえば、CASCADE DELETE が既に指定されている場合は、ユーザーは CASCADE UPDATE を追加できません。希望する CASCADE 操作を適用するには、元の CONSTRAINT (制約) を削除する必要があります。これは、ALTER TABLE ALTER COLUMN 構文または DROP CONSTRAINT 構文を使用して行うことができます。


競合テーブル '<テーブル名>' に新しい列を追加できません。古い列を削除して、データベースを最適化してください。(Error 3740)

競合テーブルの列の上限を超えています。ベース テーブルの列を少なくしてください。


競合テーブルは、名前を変更できません。(Error 3769)

競合テーブルは、名前を変更することができないシステム テーブルです。競合しているテーブルの内容を削除できます。また、レプリカでの競合問題を解決するために、競合しているテーブル自身を削除できます。


接続文字列が長すぎます。(Error 3210)

SQL ステートメントの IN 句で指定している接続文字列が 255 バイトを超えています。255 バイト以内に修正してから、もう一度実行してください。


フィールドの参照 '<参照名>' が認識できません。または無効な参照です。(Error 3345)

式の中のフィールド参照に誤りがあるか、または存在しないフィールドを参照しています。フィールド名が正しいかどうかを確認してください。


ファイルをロックできませんでした。(Error 3050)

Microsoft® Jet を使って、データベース ファイル (.mdb) と同じディレクトリへのロック ファイル (.ldb) の作成が、オペレーティング システムから許可されていない可能性があります。開こうとしているデータベースが存在するディレクトリに対して、書き込み権限が必要です。また、データベースが排他的に開かれているとき、パッシブ シャットダウンまたは接続制御機能の使用を試みると、このエラーが発生することがあります。


現在ロックされているので、更新できませんでした。(Error 3218)

更新しようとしたデータは、現在ロックされているページにあります。

原因：

  • 保存しようとしたクエリは、現在ほかのユーザーが使用しています。ほかのユーザーが処理を完了するまで待つか、または別のクエリ名を入力してから、もう一度実行してください。

  • 既に開いているか、またはロックされているレコードのあるデータ ページに対して、Edit メソッドを適用しようとしました。


カウンタの定義が有効な範囲ではありません。(Error 3770)

このエラーは、ID 属性または COUNTER 型である列を作成するとき、省略可能なシードとインクリメントの値を指定した場合に発生します。シードとインクリメントは、長整数型 (Long)の有効な値でなければなりません。


ファイルを作成できませんでした。(Error 3436)

Microsoft® Excel、テキスト ファイル、または Lotus の組み込み可能な ISAM を作成しようとしましたが、エラーが発生しました。

原因：

  • ディスク容量が足りません。

  • ネットワーク障害が発生しました。


この操作には別のカーソル ライブラリが必要です。(Error 3663)

レコードセットを開いたときに選択したカーソル型が、要求した操作をサポートしていません。適切なカーソル型でもう一度開くか、または現在のカーソル型に有効な操作を実行します。このエラーは、ODBCDirect を使用する場合にだけ発生します。


開こうとしたデータベースは、既にほかのアプリケーションが使用しています。(Error 3576)

排他モードでデータベースを開く場合、別のアプリケーションがそのデータベースを既に開いている可能性があります。共有モードでデータベースを開く場合は、別のアプリケーションがそのデータベースを排他モードで開いている可能性があります。データベースを使用しているほかのアプリケーションを閉じてから、もう一度実行してください。


データベースでエラーが発生しました。データベースを修復し、最適化してください。(Error 3428)

データベースになんらかの問題が見つかりました。このデータベースは破損データベースとしてマークされます。

次のように対処してください。

  1. データベースを閉じます。

  2. RepairDatabase メソッドを使用してデータベースを修復します。Microsoft® Access では、[ツール] メニューの [データベース ユーティリティ] をポイントして [修復] をクリックしても、データベースを修復することができます。

  3. CompactDatabase メソッドを使用してデータベースを最適化します。Microsoft Access では、[ツール] の [データベース ユーティリティ] をポイントして [最適化] をクリックしても、データベースを最適化することができます。

重要 必ず修復と最適化の両方を行ってください。


データベースは既に存在しています。(Error 3204)

既に使用されている名前でデータベースを作成、または既に存在しているデータベース名に変更しようとしました。別のデータベース名を入力してから、もう一度実行してください。


これ以上ワークシートに書き込むことはできません。(Error 3437)

Lotus 1-2-3、Microsoft® Excel Version 3.0、または Microsoft® Excel Version 4.0 のファイルに新しいレコードを追加しようとしましたが、このファイルにはこれ以上データを追加できません。これらの形式のファイルに保存できるレコードの数は最大 16,384 個までです。


データベース '<データベース名>' はほかのユーザーまたはプロセスによって既に使用されています。データベースが使用可能になった時点で、再度実行してください。(Error 3196)

指定したデータベースは、現在ほかのユーザーまたはセッションが排他的に使用しています。ほかのユーザーまたはセッションがデータベースの処理を完了してから、もう一度実行してください。


データベース名 <データベース名> は正しくありません。(Error 3005)

指定したデータベース名はファイル名の名前付け規則に従っていません。データベース名が長すぎてパス名とファイル名を格納するバッファに入りきらなかった可能性があります。新しい名前を入力してから、もう一度実行してください。


データベース <データベース名> は排他ロックされています。(Error 3006)

現在ほかのユーザーが排他モードで開いているデータベースを開こうとしました。ほかのユーザーの処理が完了してから、もう一度実行してください。


データベースがレプリケートされていないので、このオブジェクトをレプリケートすることはできません。(Error 3485)

データベースのオブジェクトは、そのデータベースがレプリケートされていない限りレプリケートできません。データベースは次のいずれかの方法でレプリケートできます。

  • データベースを Microsoft® Windows® ブリーフケースまでドラッグしてドロップします。

  • DAO のプログラミングを使用し、Replicable プロパティに "T" を設定するか、または ReplicableBool プロパティに True を設定します。

  • Microsoft Access を使用します。

  • Microsoft レプリケーション マネージャを使用します。

データベースのすべてのオブジェクトは、KeepLocal プロパティが設定されている場合を除いて、データベースがレプリケートされる場合にレプリケートされます。


ライブラリ データベース <データベース名> を開くことができません。(Error 3007)

指定したファイルは、Microsoft Jet データベース エンジンの使用するライブラリ データベースであるため、開くことはできません。


データベースは既にレプリケート可能になっています。(Error 3784)

データベースは既にレプリケート可能であるため、再びレプリケート可能にすることはできません。レプリケート可能にしようとするローカル オブジェクトが存在する場合は、デザイン マスターで Replicable プロパティを True に設定し、オブジェクトをレプリケート可能にしてください。


レプリカのシステム テーブルの信頼性がありません。このため、このレプリカを使用することはできません。(Error 3595)

使用しているコンピュータのレプリカが破損しています。Microsoft Jet データベース エンジンがそのレプリカを修復したときに、1 つまたは複数のシステム テーブルが変更された可能性があります。レプリカを削除し、新しいレプリカに置き換えてください。


Jet データベースがこの SQL/Jet レプリカ セットに対して正しくないか、見つかりません。(Error 3778)

次の理由で、指定した Microsoft® Jet データベースが間違っているか、または存在しません。

  • SQL Server 上のリンク サーバーで指定したデータ ソース パスが、このパブリケーションに対して無効なレプリカを指しています。レプリカが置き換えられているか、破損しているか、または正しく作成されていない可能性があります。

  • ハブ行がないか、または無効です。

  • 指定したデータベースがレプリケート可能ではありません。

この問題を解決するには、SQL Server 上で Re-Initialize ツールを使用して Jet Subscriber を再初期化します。


ほかのユーザーが同じデータに対して同時に変更を試みているので、プロセスが停止しました。(Error 3197)

このエラーはマルチユーザー環境で発生します。

更新しようとしたデータはほかのユーザーによって変更されています。たとえば、Edit メソッドを使用してから Update メソッドを使用するまでの間にほかのユーザーが同じデータを変更した場合など、複数のユーザーが同じテーブルを開いたり Recordset を作成したりしたときに共有的ロックを使用している場合に、このエラーが発生することがあります。

ほかのユーザーの変更に自分の変更を上書きする場合は、もう一度 Update メソッドを実行してください。


日付が範囲外であるか、書式が正しくありません。(Error 3175)

認識可能な日付の範囲は、1899 年 12 月 30 日 ～ 9999 年 12 月 30 日です。

原因：

  • 入力した日付が有効範囲内にありませんでした。

  • 入力した日付は有効ですが、その書式を認識できませんでした。日付を正しく入力したかどうかを確認してから、もう一度実行してください。


このデータベースは、マシン '<マシン名>' のユーザー '<ユーザー名>' が開いています。データベースが使用可能になった時点で、再度実行してください。(Error 3704)

このエラーは、データベースが排他的に開かれていて、共有されていない場合に発生します。また、ユーザーが DAO、ADO、または Microsoft® Access で新しいデータベースを作成し、このデータベースを閉じていない場合にも発生します。ほかのユーザーはデータベースを開くことはできますが、このエラー メッセージが表示されます。


この処理を実行できません。このバージョンの機能には、古いバージョンのデータベースでは使用できないものがあります。(Error 3301)

このデータベースは前のバージョンの Microsoft Jet データベース エンジンの形式で保存されていますが、実行しようとした機能はこの形式ではサポートされていません。データベースを Microsoft® Jet データベース エンジン Version 2.0 または 3.0 の形式に変換するか、あるいはこの機能を使用しないようにしてください。


ALTER TABLE ステートメントの構文エラーです。(Error 3293)

無効な ALTER TABLE ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


フィールド定義の構文エラーです。(Error 3292)

CREATE TABLE または ALTER TABLE ステートメントのフィールド定義に構文エラーがあります。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


フィールド '<フィールド名>' は、テーブル '<テーブル名>' に既に存在しています。(Error 3380)

同じフィールド名を 2 回入力しました。各フィールドが固有な名前になるようにコードを修正してください。また、フィールド名が Fields コレクションにあるかどうかも確認してください。


フィールド '<フィールド名>' は削除できません。1 つ以上のリレーションシップで使用されています。(Error 3383)

データベースでリレーションシップの定義に使用されているフィールドを削除しようとしました。フィールドを削除するには、先にそのリレーションシップを削除してください。


テーブル '<テーブル名>' に '<フィールド名>' という名前のフィールドが見つかりません。(Error 3381)

指定したテーブルには、指定したフィールドはありません。正しいフィールド名を入力したかどうかを確認してください。また、フィールド名が Fields コレクションにあるかどうかも確認してください。


指定されたフィールドは、テーブル '<テーブル名>' の固有インデックスではありません。(Error 3374)

CONSTRAINT 句の参照先テーブルで指定したフィールドには、固有インデックスが設定されていません。


フィールド '<フィールド名>' のサイズが長すぎます。(Error 3382)

Microsoft® FoxPro® のテーブルのテキスト フィールドには、254 バイトを超えるデータは格納できません。また、Microsoft Jet データベース エンジンのテーブルのテキスト フィールドには、255 バイトを超えるデータは格納できません。フィールドのサイズを定義し直してください。


CONSTRAINT 句の構文エラーです。(Error 3289)

無効な CONSTRAINT 句のある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


CREATE INDEX ステートメントの構文エラーです。(Error 3291)

無効な CREATE INDEX ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


CREATE TABLE ステートメントの構文エラーです。(Error 3290)

無効な CREATE TABLE ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


リレーションシップは、同じデータ型で同じ数のフィールドに設定する必要があります。(Error 3368)

リレーションシップの作成に使用しようとしている CONSTRAINT 句の中で、テーブル間で異なる数のフィールド、または異なるデータ型のフィールドを指定しています。CONSTRAINT 句で指定したフィールドの数とそれらのデータ型が一致しているかどうかを確認してから、もう一度実行してください。


DROP INDEX ステートメントの構文エラーです。(Error 3294)

無効な DROP INDEX ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


DROP TABLE または DROP INDEX ステートメントの構文エラーです。(Error 3295)

無効な DROP ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


テーブル '<テーブル名>' には既に '<インデックス名>' という名前のインデックスがあります。(Error 3375)

既に存在するインデックスを作成しようとしています。


テーブル '<テーブル名>' に インデックス '<インデックス名>' が見つかりませんでした。(Error 3372)

指定したインデックスが、指定したテーブルにありません。入力に誤りがないかどうかを確認してください。または、指定したインデックスが Indexes コレクションにあることを確かめてください。


参照整合性を設定したリレーションシップを作成できません。テーブル '<テーブル名>' にある既存のデータが、テーブル '<テーブル名>' の参照整合性に違反しています。(Error 3379)

ALTER TABLE ステートメントの CONSTRAINT 句を使用してリレーションシップを作成しようとしましたが、2 つのテーブルにある既存のデータが参照整合性の規則に反しています。たとえば、ある社員に関連するレコードがリレーション テーブルにあるにもかかわらず、対応するその社員のレコードが主テーブル側にない、というような場合が考えられます。

リレーションシップを作成するには、リレーション テーブル側のすべてのレコードに対応するレコードが主テーブル側に存在するように、データを編集してください。


リレーションシップを作成できません。参照先のテーブル '<テーブル名>' に主キーがありません。(Error 3373)

CONSTRAINT 句で参照したテーブルには主キーがありません。リレーションシップを作成するには、先にそのテーブルに主キーを作成しておくか、または、リレーションシップで使用する 1 つまたは複数の固有インデックス付きフィールドを参照先として具体的に指定してください。


テーブルまたは規則を見つけることができません。(Error 3371)

指定したテーブルまたはリレーションシップが存在しません。正しいテーブルまたは制約の名前を指定してください。


テーブル '<テーブル名>' のデザインは変更できません。データベースが読み取り専用になっています。(Error 3370)

読み取り専用のデータベースのテーブルは修正できません。


カレント データベースには既に '<リレーションシップ名>' という名前のリレーションシップが存在します。(Error 3378)

データベースに追加する各リレーションシップには、それぞれ固有の名前を指定する必要があります。これには、データ定義クエリを使用します。指定したリレーションシップ名が Relations コレクションにあるかどうかを確認してください。


テーブル '<テーブル名>' にリレーションシップ '<リレーションシップ名>' はありません。(Error 3377)

指定したリレーションシップは、このデータベースにはありません。指定したリレーションシップ名が Relations コレクションにあるかどうかを確認してください。


このテーブルで DDL を完了できません。この DDL は、テーブル <テーブル名> の制約 <制約名> で参照されています。(Error 3803)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


テーブル '<テーブル名>' は存在しません。(Error 3376)

指定したテーブルがありません。指定したテーブル名が TableDefs コレクションにあるかどうかを確認してください。


小数を丸めたために、データがオーバーフローしました。(Error 3760)

このエラーは、10 進型 (Decimal) へ更新または追加するデータが、列に定義された桁数より大きい場合に発生します。


指定された数値は、小数フィールドの精度と合致しません。(Error 3761)

このエラーは、10 進型 (Decimal) へ更新または追加するデータが、列に定義された精度と一致しない場合に発生します。


小数を丸めたために、データが切り捨てられました。(Error 3758)

このエラーは、10 進型 (Decimal) へ更新または追加するデータが、列に定義された桁数および精度と一致しない場合に発生します。


ファイルを解読できませんでした。(Error 3161)

暗号化された Btrieve または Paradox のテーブルにアクセスしようとしましたが、指定したパスワードが正しくありません。正しいパスワードを入力してください。


小数を丸めたために、データが切り捨てられました。(Error 3759)

このエラーは、10 進型 (Decimal) へ更新または追加するデータが、列に定義された桁数および精度と一致しない場合に発生します。


既定値の構文エラーです。(Error 3355)

原因：

  • テーブル レベルの入力規則の既定値の式の中に、未定義の関数名が含まれています。

  • テーブル レベルの入力規則の既定値の式の構文に誤りがあります。


FTP を使用してサーバーのファイルを削除できませんでした。FTP ドロップボックスに読み取り/書き込み権限があることを確認してください。(Error 3682)

インターネット サーバー上のファイルを削除できません。サーバーが実行中で、FTP 共有フォルダの読み取り/書き込みアクセスが正しく設定されているのを確認してください。


この ISAM では、リンク テーブル内のデータを削除することはできません。(Error 3617)

現在使用している組み込み可能な ISAM では、外部テーブルのレコードの削除が禁止されています。ただし、新規レコードの追加は可能です。


1 つ以上のオブジェクト <オブジェクト名> を削除できません。(Error 3773)

このエラーは、DROP TABLE 構文を使用し、存在しないテーブルまたはほかのユーザーが開いているテーブルを指定した場合に発生します。


削除/RI 競合です。(Error 3717)

別のレプリカでレコードの主キーが削除されたので、レコードの参照は拒否されました。参照整合性制約を満たす新しい主キー レコードを作成して更新データを再発行するか、この競合レコードを削除してください。


ローカルまたは匿名のレプリカは、デザイン マスターにはできません。(Error 3771)

デザイン マスターのローカルまたは匿名のレプリカは、レプリカ セットの完全なシステム情報を保持していないので、作成できません。デザイン マスターのグローバル レプリカのみを作成できます。現在のデザイン マスターが無効で、既に機能していないこと確認した場合、またはデザイン マスターを移動する必要がある場合にのみ、新しいデザイン マスターを作成してください。


デスティネーション ドロップボックス フォルダでアクセスが拒否されました。(Error 3562)

デスティネーション ドロップボックス フォルダのあるドライブに対する権限があるかどうかを確認してください。


ほかの操作により、この操作は実行できなくなっています。(Error 3667)

通常、このエラーは、オブジェクトに対する非同期操作が既にビジー状態であり、その非同期操作が完了するか取り消されるまで、ほかの操作を実行できないことを示します。


同期を試みた 2 つのレプリカは、異なるレプリカ セットのものです。(Error 3545)

異なるレプリカ セットに属する 2 つのレプリカの同期を取ることはできません。正しいレプリカを選択しているかどうかを確認してください。


書き込みを試みたディスク ドライブはいっぱいです。(Error 3575)

処理を完了するための必要なディスク ドライブの空き容量が不足しています。ディスクから不要なファイルを削除して、処理に必要な空き容量を確保してください。保存などの操作を行うファイルのサイズ以上の空き容量をディスク上に確保してください。


指定のディスク ドライブを読み取ることができません。(Error 3465)

フロッピー ディスクにアクセスする場合は、ディスク ドライブにディスクが完全に挿入されていることを確認してください。ハード ディスクにアクセスする場合は、そのハード ディスクのセクタが破損している可能性があります。


ディスクまたはネットワークのエラーです。(Error 3043)

ディスクまたはドライブの障害のため、ディスクへの書き込みやディスクからの読み取りができません。

原因：

  • ネットワーク ドライブを使用しようとしましたが、ネットワークが一時的に混雑しているか、またはネットワークへの接続が既に切断されています。ネットワークの接続状態を確認してから、もう一度実行してください。

  • ディスクまたはドライブに障害があります。


デスティネーション ドロップボックス フォルダでディスク I/O エラーが発生しました。(Error 3558)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ログ ファイル '<ファイル名>' にアクセス中にディスク エラーが発生しました。(Error 3473)

ログ ファイルのディスク ドライブのセクタが破損している可能性があります。

Microsoft レプリケーション マネージャの [ツール] メニューの [レプリケーション マネージャの構成] をクリックし、ログ ファイル用の別のディスク ドライブを選択するか、またはレプリケーション機能を使用するアプリケーションのセットアップ プログラムを実行してください。


ドロップボックス フォルダ '<フォルダ名>' へのアクセス中に、ディスク エラーが発生しました。(Error 3470)

ディスクのセクタが破損している可能性があります。


ディスクの空き容量が不足しています。(Error 3026)

ディスクの空き容量が不足しています。不要なファイルを削除してデータベースを最適化してから、もう一度実行してください。


システム エラーが発生したか、スワップ ファイルの上限に達しました。(Error 3539)

シンクロナイザのシステム コールの実行によって、予期しない障害が発生しました。コンピュータをシャットダウンし、電源を切ってから、再起動してください。


'*' (<テーブル名>) で選択したフィールドはグループ化できません。(Error 3120)

アスタリスク (*) で選択した単一テーブルのすべてのフィールドについてグループ化または集計を行う SELECT ステートメントを実行しようとしました。たとえば、次のような SQL ステートメントを入力するとこのエラーが発生します。

SELECT Orders.* FROM Orders GROUP BY ShipVia;


ドロップボックス フォルダ '<フォルダ名>' へのアクセス中に、アクセスが拒否されました。((Error 3468)

ドロップボックス フォルダへのアクセス権があるかどうかを確認してください。


ドロップボックスのアドレス '<アドレス名>' の構文が正しくありません。(Error 3477)

ドロップボックス フォルダを再設定してください。Microsoft レプリケーション マネージャの [ツール] メニューの [レプリケーション マネージャの構成] をクリックするか、またはレプリケーション機能を使用するアプリケーションのセットアップ プログラムを実行してください。


ドロップボックス フォルダ '<フォルダ名>' のディスクがいっぱいです。(Error 3469)

ドロップボックス フォルダのディスク ドライブの空き容量が不足しているため、処理を完了できません。ディスクから不要なファイルを削除して、処理に必要な空き容量を確保してください。


シンクロナイザがドロップボックス フォルダに書き込むためのパスワードが正しくありません。(Error 3484)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


EOF エラーです。(Error 3179)

インポートしようとするファイルの中で、予期しない位置に EOF があります。

原因と対策：

  • インポート ファイルが破損しています。バックアップ コピーを使用してインポート ファイルをロールアップしてから、もう一度実行してください。

  • ファイル変換の定義が、インポート ファイルのデータと一致していません。インポート/エクスポートの指定を編集してから、もう一度実行してください。


テーブル '<テーブル名>' はマシン '<マシン名>' のユーザー '<ユーザー名>' によって使用されているので、連鎖更新を実行できません。(Error 3413)

このエラーは、CASCADE DELETE、UPDATE、または NULL アクションのいずれかを使用して参照整合性を定義した場合に発生します。また、このエラーは、1 つまたは複数の外部キーおよび参照される主キーを含む、共有読み取りまたは書き込みモードでの外部キー側のテーブルのオープンを許可しないモードで開かれたテーブルを変更しようとしたときに発生します。


ローカル ドロップボックス フォルダへのアクセス中に致命的エラーが発生しました。(Error 3563)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


部分フィルタの式を評価するときにエラーが発生しました。(Error 3588)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


部分式の評価でエラーが発生しました。(Error 3656)

部分レプリカで使用するレコードを指定するブール型 (Boolean) のフィルタに無効な式を入力しています。レプリカ フィルタは次の値を取ることができます。

値 | 説明
文字列 | レプリケートされたテーブルで表示されるレコードが満たす必要がある抽出条件。文字列は SQL の WHERE 句に似ていますが、サブクエリ、Count などの集計関数、または抽出条件にあるユーザー定義の関数などを指定することはできません。
True | すべてのレコードをレプリケートします。
False | (既定) レコードをレプリケートしません。


テーブルの入力規則や列に対する CHECK 制約を作成するときに、データ型が一致しませんでした。(Error 3072)

たとえば、Numeric 型 (Numeric) を参照するテーブル レベルの入力規則には、数値の入力規則に関する句が必要です。文字列の入力規則に関する句を使用すると、このエラーが返されます。


イベントの待ち時間は終了しました。(Error 3531)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


リンクされている Excel のワークシートを表示するための接続が切断されました。(Error 3620)

リンクされている Microsoft® Excel ワークシートを表示するための接続が切断されました。Microsoft Excel のセッションが終了している可能性があります。


インポート/エクスポートで、例外テーブルを作成できませんでした。(Error 3618)

外部ファイルのインポートまたはエクスポート中に、問題が発生しました。インポート/エクスポート ドライバは、問題を報告するためのエラー テーブルを作成することができませんでした。


例外テーブルにレコードを追加できませんでした。(Error 3619)

外部ファイルのインポートまたはエクスポート中に、問題が発生しました。インポート/エクスポート ドライバを使用して、問題を報告するためのエラー テーブルに新しい行を追加することができませんでした。


<説明> のために要求された交換は失敗しました。(Error 3661)

交換はキャンセルされています。


インターネット シンクロナイザがサーバー上で異常終了しました。インターネット サーバーにあるパートナー レプリカのデータ交換履歴を確認して、問題の原因を特定してください。(Error 3683)

インターネット サーバーからの応答が無効です。再度実行してください。


同じレプリカを管理するために、2 つの異なるシンクロナイザを指定することはできません。(Error 3500)

同期の要求では、正しいリモート シンクロナイザ ID を使用してください。


実行しようとした同期の種類が正しくありません。(Error 3546)

要求された同期は、Synchronize メソッドの exchange オプションが無効なため実行できません。有効な同期の型をプログラムで使用してください。


このデータベースは、マシン '<マシン名>' のユーザー '<ユーザー名>' が排他的に開いています。データベースが使用可能になった時点で、再度実行してください。(Error 3356)

原因と対策：

  • データベースを開こうとしましたが、<ユーザー名> で指定したほかのユーザーが既に排他モードで開いています。そのユーザーがデータベースを閉じるまで、データベースを開くことはできません。

  • データベースを排他モードで開こうとしましたが、<ユーザー名> で指定したほかのユーザーが既に共有モードで開いています。そのユーザーがデータベースを閉じるまで、データベースは共有モードでのみ開くことができます。


シンクロナイザまたはレプリケーション マネージャは、共有メモリ上に未読のデータを見つけました。既存のデータは上書きされます。(Error 3529)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


'EXECUTE' の後にクエリ名が必要です。(Error 3732)

このエラーは、EXECUTE ステートメントを使用する場合に発生します。EXECUTE ステートメントの後には有効なストアド クエリ (ビューまたはプロシージャ) が必要です。


SQL ステートメントに無効なデータ型が使用されているので、実行できませんでした。(Error 3169)

無効なフィールドのデータ型のある SQL ステートメントを実行しようとしました。

原因：

  • メモ型 (Memo) または OLE オブジェクト型 (OLE Object) を指定できない式で、メモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールドを指定しようとしました。

  • Sum、StDev などの集計関数を指定して、テキスト フィールドで計算を実行しようとしました。別の集計関数を選択してください。


式に未定義関数 <関数名> があります。(Error 3085)

認識できない Function プロシージャ名を含む SQL 式を入力しました。この関数が存在するかどうか、SQL 式で使用できるかどうか、または式に入力した関数名が正しいかどうかを確認してください。


不要な ')' があります。(Error 2435)

閉じかっこ (右かっこ) の数が多すぎる式を入力しました。開きかっこ (左かっこ) と一致していない閉じかっこを削除してください。


RDOCURS.DLL の読み込みに失敗しました。(Error 3672)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ドロップボックス フォルダを読み取ることができませんでした。(Error 3512)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


出力するディスクがいっぱいなので、書き込むことができません。(Error 3559)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ドロップボックス フォルダに書き込むことができませんでした。(Error 3513)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


シンクロナイザ ログに書き込むことができません。(Error 3507)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


FastFind では、列ではない参照は検索できません。(Error 3768)

DAO の FINDメソッドは、パラメータまたは式に基づく列を参照できません。


この操作は、このタイプのオブジェクトには実行できません。(Error 3251)

通常のオブジェクトでは、有効なメソッドの実行やプロパティへの値の割り当てを行おうとしましたが、このインスタンスではサポートされていません。たとえば、Edit メソッドは通常の Recordset オブジェクトに対して有効なメソッドですが、スナップショット タイプの Recordset オブジェクトに対しては無効です。また、たとえば前方スクロール タイプの Recordset オブジェクトに対して、MovePrevious メソッドを使用しようとした場合など、オブジェクトのタイプや状態のために操作が実行できない場合にも、このエラーは発生します。さらに、Microsoft Jet データベースまたは ODBC データ ソースのどちらにアクセスしているかによって、サポートされなくなる操作があります。


ファイル <ファイル名> を開くことができませんでした。ほかのユーザーが排他的に開いているか、データを読み取る権限がありません。(Error 3051)

原因：

  • 指定したファイルのデータを読み取る権限がありません。システム管理者、またはテーブルやクエリの作成者に依頼して、権限の割り当てを変更してください。

  • ファイルを排他モードで開こうとしましたが、既にほかのユーザーがそのファイルを開いています。


テキスト ファイルをインポートまたはリンクするには、ファイルにデータが含まれている必要があります。(Error 3440)

空のテキスト ファイルをインポートまたはリンクしようとしました。テキスト ファイルをインポートまたはリンクするには、なんらかのデータが含まれていることが必要です。


ほかのユーザーによってロックされているため、保存できませんでした。(Error 3046)

現在ほかのユーザーによってロックされているデータベース ページの情報を保存しようとしました。変更を保存するには、ほかのユーザーの処理が完了するまで待ってから、もう一度実行してください。


指定したファイル名が長すぎます。(Error 3549)

ファイル名を短くしてください。


ファイル <ファイル名> が見つかりませんでした。(Error 3024)

原因：

  • 指定したファイルが存在しません。

  • ファイル名に誤りがあります。アンダースコア (_) などの区切り記号が抜けていないかどうか、または先頭にスペースを入れていないかどうかを確認してください。

  • ネットワーク接続に失敗しています。


<ファイル名> は既に使用されているので、使用できませんでした。(Error 3045)

指定したファイルは、現在ほかのユーザーまたはセッションが使用しています。ほかのユーザーまたはセッションによるそのファイルの処理が完了してから、もう一度実行してください。


テキスト ファイルの指定 '<名前>' で、<オプション名> オプションの設定値が正しくありません。(Error 3442)

テキスト ISAM のテキスト ファイルの指定の中にあるオプションの一部が無効です。テキスト ファイルの指定は、次の方法で設定できます。

  • Microsoft® Access では、テキスト リンク ウィザードを使用してこれらの値を設定できます。これには、[ファイル] メニューの [外部データの取り込み] をポイントして [テーブルのリンク] をクリックします。また、システム テーブル MSysIMEXSpec および MSysIMEXColumns を使用して参照することもできます。

  • Microsoft Jet データベース エンジン対応のその他のホスト アプリケーションを使用し、Schema.ini ファイルに値を保存します。


前のバージョンのアプリケーションで作成されたデータベースを開くことはできません。(Error 3041)

古い形式のデータベースにアクセスしようとしました。データベースを最適化してから、もう一度アクセスしてください。


式の <メッセージ>。(Error 3077)

メッセージで示された理由のため、入力した式は無効です。フィールド名と区切り記号を正しく入力したかどうかを確認してから、もう一度実行してください。


外部キー違反です。(Error 3719)

この外部キー違反は、レプリケーション競合に関係する無効な主キー レコードが原因です。参照整合性制約を満たす新しい主キー レコードを作成して、更新を再発行するか、有効な主キーの値と一致するように、この競合レコードの外部キーの値を変更して、この競合レコードを再発行するか、またはこの競合レコードを削除してください。


インターネット サーバー上の FTP サービスへの接続に失敗しました。FTP サービスがサーバー上で正しく実行され、匿名での接続をサポートしていることを確認してください。(Error 3678)

FTP 接続を開くことができません。インターネット サーバーと FTP サービスが実行中で、FTP サービスが非同期接続をサポートしているのを確認してください。


この関数は式では使用できません。(Error 2426)

入力した式には、使用できない関数が含まれています。DoEvents、LBound、UBound、Spc、Tab などの関数は式の中では使用できません。


<予約されているエラー警告>。(Error 3416)

このエラーは、Microsoft Jet データベース エンジン Version 3.5 以降にリリースされたアプリケーションから出たものです。マイクロソフト社のテクニカル サポートにお問い合わせください。


FTP を使用してサーバーからファイルを取得できませんでした。FTP ドロップボックスに読み取り権限があることを確認してください。(Error 3680)

インターネット サーバーからファイルを取得できません。サーバーが実行中で、FTP 共有フォルダの読み取り/書き込みアクセスが正しく設定されているのを確認してください。取得対象のファイルが削除されている可能性があります。


GUID が一致しないか、指定した GUID が見つかりません。(Error 3548)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


TRANSFORM ステートメントで HAVING 句は使用できません。(Error 3092)

選択の抽出条件を指定する場合は、WHERE 句を使用してください。


グループまたは集合のない HAVING 句 (<名前>) です。(Error 3091)

このエラーは、クエリが SELECT ステートメントに記述された識別子を評価するときに発生します。HAVING 句の前に GROUP BY 句が指定されていないか、HAVING 句が参照される列が集計関数に含まれていない場合に、このエラーが発生しす。たとえば、SELECT col1 FROM table1 HAVING col1 > 20 は、無効なステートメントです。このステートメントを SELECT col1 FROM table1 GROUP BY col1 HAVING col1 > 20 に変更すると、有効になります。また、SELECT col1, count(col2) FROM table1 GROUP BY col1 HAVING count(col1) > 20 も有効なステートメントです。


HTTP 要求の実行に失敗し、インターネット サーバー上にあるインターネット シンクロナイザを起動できませんでした。Replication Manager を使用して、インターネット サーバー上のインターネット シンクロナイザを設定してください。(Error 3677)

インターネット サーバーへの要求の送信に失敗しました。要求は次のいずれかであったと考えられます。

  • インターネット上でファイルを開き、読み取りをしようとした。

  • インターネット上でファイルの削除を要求した。

  • インターネット サーバー上で Mstrai40.exe 同期化プロセスを起動しようとした。


構文エラー : カンマがありません。(Error 2432)

式またはステートメントで、正しくない箇所にカンマ (,) を使用しているか、引数を区切るためのカンマがありません。


定義域関数の引数が正しくありません。(Error 2428)

集計関数の引数として無効な値を入力しました。関数の引数の詳細については、「SQL 集計関数」を参照し、該当する関数名を選択してください。


レジストリの Xbase キーの Century 設定値が正しくありません。(Error 3227)

Microsoft® Windows® レジストリの Xbase キーの Century の設定が無効です。

次の手順に従って Century の設定を修正してください。

  1. アプリケーションを終了します。

  2. レジストリ エディタを起動し、\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase キーを検索し、Century 値を選択します。

  3. [編集] メニューの [変更] をクリックします。

  4. [値のデータ] ボックスで Century 値を修正します。

  5. アプリケーションを再起動してから、もう一度操作を実行します。


選択された CollatingSequence は OS でサポートされていません。(Error 3228)

Microsoft® Windows® レジストリの Paradox キーの CollatingSequence の設定が無効です。

次の手順に従って CollatingSequence の設定を修正してください。

  1. アプリケーションを終了します。

  2. レジストリ エディタを起動し、\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox キーを検索して、CollatingSequence 値を選択します。

  3. [編集] メニューの [変更] をクリックします。

  4. [値のデータ] ボックスで [ascii] または [International] のどちらかを指定します。

  5. アプリケーションを再起動してから、もう一度実行してください。


列レベルの制約が正しくありません。(Error 3789)

このエラーは、CREATE TABLE または ALTER TABLE ALTER COLUMN 構文を使用する場合に発生します。ANSI SQL では、テーブル定義の一部として CHECK 制約を作成することができますが、Microsoft® Jet では、ユーザーは COLUMN 定義とは別に CHECK 制約を作成する必要があります。これは、カンマの後に CHECK キーワードを使用して行います。たとえば、CHECK 制約はカンマの後で、列とは別に定義されるので、次のステートメントは有効です。

CREATE TABLE Orders (OrderId IDENTITY (100,10) CONSTRAINT pkOrders PRIMARY KEY, CustId LONG CONSTRAINT fkCustomersCustId REFERENCES Customers (CustId), Balance DOUBLE, CONSTRAINT CustomerExceededCreditLimit CHECK (CustId IN (SELECT CustId FROM Customers C WHERE C.CustId = Orders.CustId AND C.CreditLimit >= (SELECT SUM(Balance)FROM Orders O WHERE O.CustId = Orders.CustId))));


DataCodePage オプションの設定値が正しくありません。(Error 3337)

使用しようとしている外部データ ソースに対して設定された DataCodePage の設定値が無効です。この設定は、Microsoft® Windows® レジストリの \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engine\<external data source ISAM> キーにあります。

有効な設定値：

  • OEM - データは OEM データとして保存されます。OemToAnsi 変換と AnsiToOem 変換が行われます。

  • ANSI - データは ANSI データとして保存されます。OemToAnsi 変換と AnsiToOem 変換は行われません。


レジストリの Xbase キーの Date 設定値が正しくありません。(Error 3213)

Microsoft® Windows® レジストリの Xbase キーの Date の設定が無効です。

次の手順に従って Date の設定を修正してください。

  1. アプリケーションを終了します。

  2. レジストリ エディタを起動し、\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase キーの Date 値を選択します。

  3. [編集] メニューの [変更] をクリックします。

  4. [値のデータ] ボックスで Date 値を修正します。

  5. アプリケーションを再起動してから、もう一度操作を実行します。


レジストリの Xbase キーの Deleted 設定値が正しくありません。(Error 3208)

Microsoft® Windows® レジストリの Xbase キーの Deleted の設定が無効です。

次の手順に従って Deleted の設定を修正してください。

  1. アプリケーションを終了します。

  2. レジストリ エディタを起動し、\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase キーを検索して、Deleted 値を選択します。

  3. [編集] メニューの [変更] をクリックします。

  4. [値のデータ] ボックスで Deleted 値を修正します。

  5. アプリケーションを再起動してから、もう一度操作を実行します。


集計関数の一部として指定された式 '<名前>' を含んでいないクエリを実行しようとしました。(Error 3122)

指定した式を集計関数やグループ化の一部として指定せずにクエリを実行しようとしました。

原因：

  • TRANSFORM ステートメントで集計関数を入力しませんでした。


レジストリの Engines セクションの Excel キーに設定されている値が正しくありません。(Error 3433)

Microsoft® Windows® レジストリの \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel キーのいずれかの設定が無効です。Windows レジストリを編集し、すべてのパラメータを有効にしてください。


レジストリの Xbase キーの Mark 設定値が正しくありません。(Error 3214)

Microsoft® Windows® レジストリの Xbase キーの Mark の設定が無効です。

次の手順に従って Mark の設定を修正してください。

  1. アプリケーションを終了します。

  2. レジストリ エディタを起動し、\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase キーを検索して、Mark の値を選択します。

  3. [編集] メニューの [変更] をクリックします。

  4. [値のデータ] ボックスで Mark 値を修正します。

  5. アプリケーションを再起動してから、もう一度操作を実行します。


レジストリの NetworkAccess 設定値が正しくありません。(Error 3248)

Microsoft® Windows® レジストリの NetworkAccess の設定が無効です。

次の操作を行ってください。

  1. アプリケーションを終了します。

  2. レジストリ エディタを起動し、NetworkAccess 値を検索します。

  3. 使用する組み込み可能な ISAM に応じて、\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase キーに無効なエントリがあります。

  4. [編集] メニューの [変更] をクリックします。

  5. [値のデータ] ボックスで [On] または [Off] のどちらかを指定します。

  6. アプリケーションを再起動してから、もう一度操作を実行します。


無効な処理です。(Error 3219)

原因：

  • 読み取り専用のプロパティに対して設定を行おうとしました。オンライン ヘルプで該当するプロパティを検索し、設定可能かどうかを確認してください。

  • メソッドやプロパティを設定できない Recordset のオブジェクト型で、メソッドまたはプロパティを使用しようとしました。特定の Recordset のオブジェクト型で設定できるメソッドやプロパティを調べるには、オンライン ヘルプの「Recordset オブジェクトの概要」を参照してください。

  • ユーザー定義プロパティがサポートされていないオブジェクトの Properties コレクションに、プロパティを追加しようとしました。

  • 読み取り専用の Recordset オブジェクトに対して Update メソッドを使用しようとしました。


フォームを開くことができません。元になるクエリで、このフォームの RecordsetClone プロパティの設定または取得を行うユーザー定義関数が見つかりました。(Error 3252)

Microsoft® Access では、ユーザー定義関数を含むクエリを実行して、そのクエリを元にフォームを作成した場合に、このエラーが発生することがあります。


クエリの参照が不正です。(Error 3451)

このエラーは、認識できないデータ型を持つパラメータを定義したときに発生します。


リレーションシップを作成できません。(Error 3300)

たとえば、テーブルが別のデータベースにある場合など、使用できないリレーションシップを作成しようとしています。


Jet SQL Server レプリカで不正な操作を行いました。(Error 3777)

多くの操作が、Microsoft® Jet SQL のレプリカから実行できません。たとえば、テーブルの削除や名前の変更、またはテーブルの列の追加、削除、名前の変更などを実行できません。また、ローカル テーブルをレプリケート可能にしたり、Jet SQL Server 上のレプリカ セットで、別の Jet Subscriber と交換できません。直接同期以外の方法で、SQL Publication との交換を実行することはできません。


レジストリの PageTimeout 設定値が正しくありません。(Error 3249)

Microsoft® Windows® レジストリの PageTimeout の設定が無効です。

次の操作を行ってください。

  1. アプリケーションを終了します。

  2. レジストリ エディタを起動し、PageTimeout 値を検索します。

  3. 使用する組み込み可能な ISAM に応じて、\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase キーに無効なエントリがあります。

  4. [編集] メニューの [変更] をクリックします。

  5. [値のデータ] ボックスで新しい値を指定します。

  6. アプリケーションを再起動してから、もう一度操作を実行します。


組み込み可能な ISAM ドライバのバージョンに互換性がありません。(Error 3429)

現バージョンの Microsoft Jet データベース エンジンで、前のバージョンの組み込み可能な ISAM を使用しようとしました。もう一度セットアップ プログラムを起動し、正しいバージョンの組み込み可能な ISAM をセットアップしてください。


クエリの構文エラーです。クエリの句が不完全です。(Error 3450)

このエラーは、ストアド クエリ (ビューまたはプロシージャ) を保存しようとしたときに発生します。


カレント フィールドは、一対多リレーションシップの '一' 側のテーブルにある結合キー '<キー名>' と一致する必要があります。(Error 3341)

外部結合の "多側のみ" のテーブルの結合フィールドに値を入力しようとしましたが、それと一致する値が "一" 側のテーブルの結合フィールドにありません。

このエラーを回避するには、必要なキーの値を "一" 側のテーブルのレコードに入力してから、対応する結合フィールドを持つエントリを "多側のみ" のテーブルに作成してください。


インデックス化された Paradox テーブルのレコードが長すぎます。(Error 3608)

インデックス付きの Paradox テーブルの最大レコード長は 1,350 バイトです。テキスト型 (Text) フィールドまたはメモ型 (Memo) フィールドのサイズを小さくしてください。


インデックスは既に存在しています。(Error 3284)

1 つのテーブルに同じ名前のインデックスを 2 つ持たせることはできません。いずれかのインデックスの名前を変更してください。


Paradox のインデックスが主インデックスではありません。(Error 3288)

ほかのインデックスが定義されていない Paradox テーブルにインデックスを作成しようとしています。Paradox テーブルに作成する最初のインデックスは、主インデックスでなければなりません。

対策：

  • インデックスを主インデックスとして再定義してください。

  • 作成しようとしているインデックスが主インデックスでない場合は、先に主インデックスを作成してください。


主キーは既に存在しています。(Error 3283)

このテーブルに再度主キーを定義しようとしています。1 つのテーブルに設定できる主キーは 1 つのみです。


このフィールドまたはテーブルは削除できません。カレント インデックスとして使用されているか、リレーションシップで使用されています。(Error 3281)

リレーションシップの中で使用されているインデックスやテーブルを削除するには、先にそのリレーションシップを削除する必要があります。また、Index プロパティによってカレント インデックスとして指定しているインデックスを削除するには、カレント インデックス プロパティを別のインデックスに設定する必要があります。


インデックスの定義が正しくありません。(Error 3285)

原因：

  • 1 つのインデックスまたはリレーションシップの中で、同じフィールドを 2 回使用しています。Microsoft Jet データベース エンジンでは、同じフィールドを 2 回使用することはできません。

  • データ型が互いに一致しないフィールドを使用してリレーションシップを作成しようとしています。Microsoft® Jet データベース エンジンでは、リレーションシップを作成できるのは、データ型がまったく同じフィールドか、または Number フィールドが長整数型 (Long) に設定されたオートナンバー型 (AutoNumber) フィールドのみです。


インデックスが見つかりませんでした。(Error 3015)

インデックスではない値を使用しようとしました。TableDef オブジェクトの Indexes コレクションを調べれば、有効なインデックス名がわかります。


'<インデックス名>' は、このテーブルのインデックスではありません。(Error 3800)

インデックスの参照時に、無効なインデックス名を使用しました。


無効な .INF ファイルです。(Error 3168)

dBASE のテーブルにアクセスしようとしましたが、そのテーブルに関連する .inf ファイルが無効であるか、または破損しています。正しいインデックスを指定するためにもう一度テーブルをリンクしてください。


インデックス ファイルが見つかりません。(Error 3256)

dBASE のテーブルにアクセスしようとしましたが、テーブルに関連付けられた .inf ファイルの中で指定しているインデックスが見つかりませんでした。インデックスの名前が変更されているか、別の場所に移動されているか、または削除された可能性があります。テーブルをもう一度リンクするか、または Microsoft® Windows® のメモ帳などのテキスト エディタを使用して .inf ファイルを更新してください。


入力テーブルまたはクエリ '<クエリ名>' が見つかりませんでした。そのテーブルやクエリが存在していること、または名前が正しいことを確認してください。(Error 3078)

原因：

  • 指定したテーブルまたはクエリが存在しません。

  • テーブルまたはクエリの名前に誤りがあります。アンダースコア (_) などの区切り記号が抜けていないかどうか、または先頭にスペースを入れていないかどうかを確認してください。


INSERT INTO ステートメントに、認識できないフィールド '<フィールド名>' があります。名前が正しいことを確認して、再度実行してください。(Error 3127)

指定したフィールド名を使用して INSERT INTO ステートメントを実行しようとしましたが、そのフィールドが出力テーブルに存在しません。フィールド名を正しく入力したかどうかを確認してから、もう一度実行してください。


インストール可能な ISAM ドライバが見つかりませんでした。(Error 3170)

組み込み可能な ISAM の DLL ファイルが見つかりません。このファイルは、ODBC や Microsoft Jet データベースのテーブルを除く外部テーブルのリンクに必要です。ISAM ドライバの格納場所はすべて Microsoft® Windows® レジストリに保存されており、これらのエントリはアプリケーションのセットアップ時に自動的に作成されます。ドライバの格納場所を変更する場合は、変更内容を反映してレジストリに正しいエントリを作成するために、アプリケーションのセットアップ プログラムを修正する必要があります。

原因：

  • レジストリのエントリが無効です。たとえば、Paradox の外部データベースを使用していて、Paradox のエントリが指すディレクトリやドライバが存在しない場合に、このエラーが発生します。アプリケーションを終了し、Windows レジストリを修正してから、もう一度実行してください。

  • レジストリのエントリの 1 つがネットワーク ドライブを指していますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。


メモリ不足のため、操作を完了できません。(Error 3584)

データベースをレプリケートしようとした場合にメモリ不足が発生しました。コンピュータ上で実行中のほかのアプリケーションを終了してから、もう一度実行してください。


リレーションシップが設定されたレコードがテーブル '<テーブル名>' にあるので、レコードの削除や変更を行うことはできません。(Error 3200)

リレーション テーブルに対して参照整合性の規則に反する操作を実行しようとしました。たとえば、一対多リレーションシップの "一" 側のテーブルでレコードを削除または変更しようとした場合に、そのレコードと関連するレコードが "多" 側のテーブルに存在している場合に、このエラーが発生します。

このようなレコードを削除または変更する場合は、"多" 側のテーブルから関連するレコードを先に削除してください。


テーブル '<テーブル名>' にリレーションシップが設定されたレコードが必要なので、レコードの追加や変更を行うことはできません。(Error 3201)

リレーション テーブルに対して参照整合性の規則に反する操作を実行しようとしました。たとえば、一対多リレーションシップの "多" 側のテーブルでレコードを変更または挿入しようとした場合に、そのレコードと関連するレコードが "一" 側のテーブルに存在しない場合に、このエラーが発生します。

このようなレコードを追加または更新する場合は、一致するフィールドが同じ値の "一" 側のテーブルにレコードを先に追加してください。


システムで予約されているエラー <アイテム> です。このエラーに対するメッセージはありません。(Error 3000)

予期しないエラーが発生しました。このエラー コードから、エラー発生の原因を調べることができます。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


インターネット DLL (WININET.DLL) が見つからないか、ロードできませんでした。(Error 3674)

パス内で Wininet.dll が見つかりません。セットアップをやり直してください。


インターネット機能がタイムアウトしました。(Error 3742)

インターネット操作が完了する前にタイムアウトになりました。レジストリのタイムアウト値を増やしてください。レジストリ値は次の場所に格納されています。\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Transporter


インターネット ハンドルからの読み込みに失敗しました。再度実行してください。(Error 3675)

ファイルの読み取りまたはインターネット操作からの応答の読み取りで、インターネット エラーが発生しました。


インターネット ハンドルへの書き込みに失敗しました。再度実行してください。(Error 3676)

ファイルへの書き込みでインターネット エラーが発生しました。


インターネットが遅すぎるか、インターネット サーバーのレプリケーション マネージャの設定に問題があります。(Error 3650)

インターネットの通信速度が原因で失敗しました。


インターネットのログインに失敗しました。(Error 3652)

入力したログイン情報をサーバーが認識しませんでした。


インターネットがセットアップされていません。(Error 3653)

インターネットのセットアップに問題があります。


インターネット トランスポートはリモート シンクロナイザ上では効果的ではありません。(Error 3632)

このリモート シンクロナイザは、リモートの同期作業用には設定されていません。


この操作は、トランザクションには実行できません。(Error 3246)

トランザクション内部で無効となる処理を実行しようとしました。BeginTrans ステートメントで作成したトランザクションを使用するか、または 1 回の操作で複数のレコードを削除する場合には、Microsoft Jet データベース エンジンで作成したトランザクションを使用してください。


アカウント名 <アカウント名> は正しくありません。(Error 3030)

指定したアカウント (ユーザー) 名は無効です。ユーザー名は 20 バイト以内で、次の文字を除く任意の英数字、アクセント付き文字、スペース、および記号が使用できます。

  • 文字列 " / \ [ ] | < > + = ; , : ? *

  • 先頭がスペース

  • 制御文字

ユーザー名は、大文字と小文字の区別をしません。


デスティネーション ドロップボックス フォルダのアドレスが正しくありません。(Error 3557)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ブックマークが正しくありません。(Error 3159)

ブックマークに無効な文字列を設定しようとしました。

Bookmark プロパティの値を、Bookmark プロパティを読み込んでからまだ保存していない文字列に設定しようとすると、このエラーが発生します。たとえば、次のコードを実行するとエラーになります。

Sub SetBookmark()

    Dim dbs As Database

    Dim rstEmployees As Recordset

    Dim strPlaceholder As String

    Set dbs = OpenDatabase("Northwind.mdb")

    Set rstEmployees = _

        dbs.OpenRecordset _

        ("社員", dbOpenDynaset)

    strPlaceholder = "1"

    rstEmployees.Bookmark = strPlaceholder    '無効なブックマーク

End Sub


指定されたデータ量がフィールド サイズを超えています。データ量を減らし、挿入または貼り付けを行ってください。(Error 3163)

フィールドが小さすぎるため、挿入または貼り付けができません。データを少なくして、もう一度実行してください。


インデックスまたはリレーションシップの定義で使用されているフィールド定義 '<フィールド名>' が正しくありません。(Error 3409)

原因：

  • フィールド名が正しく入力されていません。フィールド名を確認してください。

  • 使用しようとしているメモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールド型は、インデックス化できません。


フィールドのデータ型が正しくありません。(Error 3259)

Field オブジェクトの Type プロパティに指定したデータ型が正しくありません。有効なデータ型の一覧については、オンライン ヘルプの「Type プロパティ」を参照してください。


リンク テーブルへの接続文字列で、国番号が指定されていません。(Error 3449)

接続文字列で、国番号が見つかりませんでした。


データベース <データベース名> を開くことができません。アプリケーションで認識できないデータベースであるか、またはファイルが破損しています。(Error 3049)

原因と対策：

  • Btrieve、dBASE、Paradox のデータベース、またはテーブルを開こうとしました。直接それらを開かずに、Microsoft Jet データベース以外にそれらのデータベースやテーブルをリンクしてください。

  • Paradox のデータベースまたはテーブルをインポートまたはリンクしようとしましたが、関連する .px ファイルが見つかりませんでした。.px ファイルが Paradox のデータベースやテーブルのあるディレクトリと同じディレクトリにあるかどうかを確認してから、もう一度実行してください。

  • 指定したデータベースが Microsoft Jet データベースであれば、そのデータベースは破損しています。直ちにデータベースを修復してください。修復できない場合は、バックアップ コピーからロールバックするか、または新しいデータベースを作成し直してください。


データベース のオブジェクト参照が正しくありません。(Error 3276)

指定した Database オブジェクトは、OpenDatabase メソッドで作成されたものではないか、または既に変更されているために無効になっています。


データベースの形式 <ファイル名> を認識できません。(Error 3343)

原因：

  • 指定したファイル名は Microsoft Jet データベースではありません。

  • 指定したファイル名はデバイス名 (たとえば、プリンタまたはコンソール) です。

  • .mdb ファイルに無効なヘッダー情報や未定義の並べ替え順序があります。

  • ほかのユーザーによってコミットが中断されていますが、ロック ファイルが見つかりません。

  • コミット中に最大ページ サイズの 2KB を超える長整数型 (Long) の値を書き込もうとしました。

  • データベースは破損しています。データベースを最適化してから、もう一度開いてください。


リンクされているデータ ソースに対してデータ定義ステートメントを実行することはできません。(Error 3611)

Microsoft Jet データベース エンジンは、ISAM のリンク テーブル、または固有インデックスを既に持っている ODBC テーブルに対して、インデックスを作成することはできません。


デスティネーション ドロップボックス フォルダのパスが正しくありません。(Error 3556)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ドロップボックス フォルダ '<フォルダ名>' のパスワードが正しくありません。(Error 3483)

Microsoft レプリケーション マネージャの [ツール] メニューの [レプリケーション マネージャの構成] をクリックし、ドロップボックス フォルダのパスワードを入力し直してください。


ドロップボックス '<ドロップボックス名>' のパスが正しくありません。(Error 3476)

ドロップボックス フォルダのパスが正しいかどうかを確認してください。

Microsoft レプリケーション マネージャの [ツール] メニューの [レプリケーション マネージャの構成] をクリックするか、またはレプリケーション機能を使用するアプリケーションのセットアップ プログラムを実行してください。


ファイル名が正しくありません。(Error 3055)

指定したファイル名は、オペレーティング システムの名前付け規則に従っていません。正しいファイル名を入力してから、もう一度実行してください。


部分レプリカのフィルタ式が正しくありません。(Error 3482)

ReplicaFilter プロパティに無効な文字列が設定されています。


部分フィルタの式に含まれるリレーションシップ '<リレーションシップ名>' が正しくありません。(Error 3480)

有効なリレーションシップを指定してください。


Find 系メソッドの抽出条件では、GUID は使用できません。(Error 3614)

Find 系メソッドの抽出条件式で GUID 型 (GUID) を参照することはできません。


HTTP アドレスが正しくありません。(Error 3685)

指定した HTTP アドレスが、このレプリカ セットに対して無効です。指定した HTTP アドレスが、MSysTranspAddress システム テーブルの InternetAddress フィールドの値と一致しません。


オブジェクト (<オブジェクト名>) は、CHECK CONSTRAINT 句には使用できません。(Error 3801)

このエラーは、CREATE TABLE または ALTER TABLE ALTER COLUMN 構文と、CHECK 制約句を使用した場合に発生します。また、CHECK 制約で添付/リンクしたテーブル、またはビュー/プロシージャ/ストアド クエリを参照しようとした場合に発生します。


インターネットのアドレスが正しくありません。(Error 3651)

無効か、または使用できないインターネットのアドレスを要求しています。アドレスが有効かどうかを確認して、もう一度実行してください。


データベースを作成できません。データベースの並び順の設定が正しくありません。(Error 3424)

無効な locale パラメータを指定しました。有効な DAO 定数を使用して locale パラメータを指定しているかどうかを確認してください。データベースを作成できません。


アカウント名またはパスワードが正しくありません。(Error 3029)

入力したアカウント (ユーザー) 名やパスワードは無効です。

ユーザー名

ユーザー名は 20 バイト以内で、次の文字を除く任意の英数字、アクセント付き文字、スペース、および記号が使用できます。

  • 文字 " / \ [ ] | < > + = ; , : ? *

  • 先頭がスペース

  • 制御文字

ユーザー名は、大文字と小文字の区別をしません。

パスワード

パスワードは 14 バイト以内で、制御文字を含めることはできません。また、大文字と小文字の区別をします。


'<名前>' が見つかりません。パラメータや別名が正しいこと、無効な文字や区切り記号が含まれていないこと、または名前が長すぎないことを確認してください。(Error 3125)

指定した名前は名前付け規則に従っていません。または、パラメータや別名が正しくありません。文字や区切り記号を正しく入力したかどうか、または名前が長すぎないかどうかを確認してください。


オブジェクトが正しくありません。(Error 3350)

リンク テーブル以外のオブジェクトに対して RefreshLink メソッドを使用しました。オブジェクトは、オブジェクトが破棄されてそれに関連付けられている DAO オブジェクトが閉じられた場合、または、オブジェクトが破棄されて現在の適用範囲で既に定義されなくなった場合に存在しなくなります。


この操作は実行できません。(Error 3032)

原因：

  • 管理者グループの 1 つのみのユーザー アカウントを削除しようとしました。管理者グループには、ユーザー アカウントが少なくとも 1 つは必要です。ユーザー アカウントを削除する場合は、新しいアカウントを作成してそれを管理者グループに追加するか、または既存のアカウントを管理者グループに追加してから、アカウントを削除してください。

  • 既に登録されているユーザーをグループに登録しようとしました。既に追加されている同名の Group オブジェクトを User オブジェクトの Groups コレクションに追加しようとしたか、または、既に追加されている同名の User オブジェクトを Group オブジェクトの Users コレクションに追加しようとしました。


引数が無効です。(Error 3001)

DLL のルーチンを使用する実行時に、DLL ルーチンに渡す引数に誤りがあります。正しい引数を指定してから、もう一度実行してください。

このエラーは、メソッドの引数の中で互いに排他的な定数を指定しようとした場合にも発生します。たとえば、OpenRecordset メソッドで引数 options に定数 dbConsistent と dbInconsistent の両方を指定した場合、このエラーが発生します。


パスワードが正しくありません。(Error 3031)

入力したパスワードは無効です。パスワードは 14 バイト以内で、制御文字を含むことはできません。また、大文字と小文字の区別をします。


パス '<パス名>' は正しくありません。パス名に間違いがないことと、ファイルが置かれたサーバーに接続していることを確認してください。(Error 3044)

原因：

  • 無効なパスを含むファイルを指定しました。たとえば、指定したパスが存在しないか、または入力したパス名に誤りがあります。

  • 指定したファイルのあるネットワーク ドライブに接続していません。ネットワークが使用できる状態であるかどうかを確認してから、もう一度実行してください。


4 桁 (バイト) 以上、20 桁 (バイト) 未満の PID (パーソナル ID) を入力してください。(Error 3304)

パーソナル ID (PID) は半角で 4 ～ 20 バイトの英数字で指定してください。


この精度は、decimal データ型には適用できません。(Error 3700)

10 進型 (Decimal) の精度と桁数は 0 ～ 28 です。たとえば、次の SQL ステートメントはこのエラーを返します。

CREATE TABLE foo (foo DECIMAL(38,0));


レプリカのパス、または名前が正しくありません。(Error 3686)

HTTP アドレスで識別されるシンクロナイザは、URL に指定されているデータベース名を管理しません。


この桁数は、decimal データ型には適用できません。(Error 3701)

10 進型 (Decimal) の桁数は精度と等しいか、または精度より小さくなければなりません。たとえば、次の SQL ステートメントはこのエラーを返します。

CREATE TABLE foo (foo DECIMAL(10,12));


データベース オブジェクトが正しくありません。(Error 3263)

指定した Database オブジェクトは、OpenDatabase メソッドで作成されたものではないか、または既に変更されているために無効になっています。


部分フィルタの式に含まれるテーブル名 '<テーブル名>' が正しくありません。(Error 3481)

式の中で使用されているテーブル名が正しいかどうかを確認してください。


フィルタのテーブル名が正しくありません。(Error 3631)

無効な値を持つ、ブール型 (Boolean) フィルタのテーブルを参照しています。ブール型 (Boolean) フィルタは、フィルタ処理を行ったテーブルからのみ参照することができます。


選択クエリの TOP 引数が正しくありません。(Error 3308)

SELECT ステートメントの TOP 句に無効なパラメータがあります。TOP の後には、必ず正の値を指定してください。予約語 PERCENT と共に使用する場合は、100 以下の整数値を指定してください。


シンクロナイザ ID が、MSysTranspAddress テーブル内の既存の ID と一致しません。(Error 3504)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


Jet SQL レプリカのレプリカは作成できません。(Error 3753)

Microsoft® Jet SQL のレプリカ セットでは、ハブ/スポーク トポロジを設定することができます。このトポロジでは、SQL Publication がハブになり、Jet Subscriber がスポークになります。Jet SQL のレプリカを作成する場合は、SQL Publication から Push/Pull Subscription を作成する必要があります。


結合式がサポートされていません。(Error 3296)

原因と対策：

  • SQL ステートメントに複数の結合があり、その実行順序によってクエリの結果が異なる可能性があります。最初の結合を実行するクエリを別に作成し、そのクエリを SQL ステートメントに追加してください。

  • JOIN 操作の ON ステートメントが不完全であるか、または指定したテーブルが多すぎます。WHERE 句で ON 式を使用してください。


レコードを追加できません。テーブル '<テーブル名>' の結合キーがレコードセットにありません。(Error 3348)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


結合テーブル <テーブル名> が FROM 句に指定されていません。(Error 3080)

指定したテーブル名をクエリの FROM 句に追加してから、もう一度実行してください。


このプロパティは、外部データ ソースまたは前のバージョンの Microsoft Jet データベース エンジンで作成されたデータベースではサポートされていません。(Error 3310)

指定したオブジェクトは Microsoft® Jet データベース エンジン Version 1.x または 2.x のデータベース、あるいは外部のデータ ソースに格納されていますが、そのオブジェクトで使用できないプロパティを設定または参照しようとしました。有効なプロパティの一覧については、オンライン ヘルプでそのオブジェクトの概要を参照してください。


データベースの KeepLocal プロパティを設定することはできません。このプロパティは、データベース内のオブジェクトに対してだけ設定できます。(Error 3458)

データベースのオブジェクトをレプリケートしない場合は、その KeepLocal プロパティに "T" を設定します。データベース全体に対して KeepLocal プロパティを設定することはできません。


インデックス、主キー、またはリレーションシップで値が重複しているので、テーブルを変更できませんでした。(Error 3022)

元になるテーブルの主キー フィールド、または重複を許可しないインデックスに重複する値を入力しようとしました。

この問題を回避するには、重複データの変更、インデックスの削除、またはインデックスの再定義による重複の許可を行ってから、もう一度実行してください。


この操作は、リンク テーブルには実行できません。(Error 3057)

テーブルからデータをインポートして、もう一度実行してください。


ローカルまたは匿名のレプリカは、レプリケーション元だけと同期する必要があります。(Error 3738)

ソース レプリカは、ローカルまたは匿名レプリカです。間違ったハブ レプリカに交換しようとしています。ローカルまたは匿名レプリカを同期させることができるのは、作成元のグローバル レプリカとだけです。


ロックされたテーブル。テーブルがほかのユーザーにロックされていたので、 このレコードは同期中には適用されませんでした。この競合レコードを再発行してください。(Error 3714)

テーブルに対するロックを解除するときに、レプリカを再同期してください。


パス '<パス名>' のディスクがいっぱいです。(Error 3472)

ディスク ドライブから不要なファイルを削除して、空き容量を確保してください。


ログ ファイルのパス '<パス名>' が正しくありません。(Error 3591)

Microsoft® Windows® レジストリの \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Transporter キーの Logfile 値で指定した場所に、ログ ファイルがあることを確認してください。または、シンクロナイザの再設定を行ってください。

シンクロナイザの設定を行うには、次の操作を行ってください。

  1. Microsoft レプリケーション マネージャを起動します。

  2. [ツール] メニューの [レプリケーション マネージャの構成] をクリックします。

  3. ウィザードの指示に従ってください。


レプリカの一覧用のフォルダは管理されていません。(Error 3573)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


列の数が多いので、<テーブル名> テーブルをレプリケートできません。(Error 3705)

レプリケーション システム列を追加できないため、テーブルをレプリケート可能にすることができません。これらの列を追加すると、列の上限を超えてしまいます。テーブルをレプリケート可能にするには、テーブル内の列数を少なくします。


インデックスの数が多いので、<テーブル名> テーブルをレプリケートできません。(Error 3706)

レプリケーション システム インデックスを追加できないため、テーブルをレプリケート可能にすることができません。これらのインデックスを追加すると、最大インデックス数を超えてしまいます。


MAPI フォルダまたはアドレス帳が見つかりません。(Error 3710)

アクセスしようとしたフォルダまたはアドレス帳が、Microsoft® Outlook または Microsoft Exchange ドライバによって見つけられませんでした。

  • MAPI フォルダやアドレス帳が格納されている MAPI ストアにアクセス可能であること、および必要な権限を持っていることを確認してください。

  • 接続情報が、他のコンピュータのドライブを割り当てるような、場所に固有のものではないことを確認してください。

  • MAPI フォルダやアドレス帳の名前が正しいことを確認してください。


この MAPI フォルダ/アドレス帳には、インデックスを作成できません。(Error 3788)

多くの Microsoft® Outlook/Exchange フォルダとアドレス帳は、ユーザーが変更できないシステム単位の構成要素です。このエラー メッセージは、グローバル アドレス リスト、パブリック フォルダなど、ユーザーが権限を持たないオブジェクトでインデックスを作成しようとしたことを示します。


メモリ不足のため、演算を実行できません。(Error 2446)

アプリケーションが演算を実行するために必要なメモリが不足しています。RAM が十分にあるかどうか、また、仮想スワップ ファイルが設定されているかどうかを確認してください。ほかのプログラムを終了したり、デスクトップで壁紙の使用をやめたり、不要なデバイス ドライバを削除するなどして、必要なメモリを確保することもできます。


ほかのアプリケーションがメッセージ データベースを開いているため、ソース ドロップボックス フォルダで共有違反が発生しました。(Error 3565)

メッセージ データベースを閉じてください。ユーザーはメッセージ データベースを直接開かないでください。


ドロップボックス フォルダ内のメッセージは不正なシンクロナイザのものです。(Error 3567)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


指定された Xbase メモ ファイルを見つけることができません。(Error 3166)

dBASE ファイル (.dbf) にアクセスしようとしましたが、そのファイルに関連するメモ ファイル (.dbt) が見つかりませんでした。.dbf ファイルと同じフォルダに .dbt ファイルがあるかどうかを確認してから、もう一度実行してください。


構文エラー : 演算子がありません。(Error 2431)

式またはステートメントに必要な演算子がありません。


構文エラー : 演算子がありません。(Error 2434)

式またはステートメントに必要な演算子がありません。


')'、']'、または Item がありません。(Error 2436)

閉じかっこ、閉じ角かっこ、または垂直バーが足りません。入力した式が正しいかどうかを確認してください。


NULL 属性および NOT NULL 属性は複数作成することはできません。(Error 3806)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


このコレクションには項目がありません。(Error 3265)

コレクションの名前を参照しようとしましたが、失敗しました。

原因と対策：

  • コレクションの中にオブジェクトが存在しません。参照しようとしたオブジェクトがコレクションに追加されていることを確認してください。

  • 指定した名前を持つオブジェクトがコレクションの中に複数存在しており、その結果あいまいな参照になっています。オブジェクトのコレクションでの順序位置 (Recordsets(3) など) を指定してオブジェクトを参照してください。


この操作を実行するには、システム データベースの Version 4.x 以上が必要です。(Error 3808)

セキュリティで Microsoft® OLE DB Provider for Jet を使用する場合、セキュリティ データベースは Jet 4.x ファイル形式である必要があります。これは、既存のセキュリティ データベースを圧縮するか、または Microsoft OLE DB Provider for Jet を使用して新しいセキュリティ データベースを作成して行います。


<テーブル名> を開くことができません。ほかのユーザーが別のネットワーク コントロール ファイルまたは別のロック形式を使用してテーブルを開いています。(Error 3418)

現在の初期設定とテーブルを開いているほかのユーザーの初期設定との間に矛盾があるため、Microsoft Jet データベース エンジンは Paradox の外部テーブルを開くことができませんでした。データベースを共有するすべてのユーザーは、Microsoft® Windows® レジストリの \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox キーの ParadoxNetPath と ParadoxNetStyle の設定を同じにする必要があります。現在の初期設定がデータベースを共有するほかのユーザーの設定と一致するかどうかを確認してから、もう一度テーブルを開いてください。


ネットワーク I/O エラー。(Error 3566)

使用しているコンピュータとネットワークとの間の通信に障害が発生しています。ネットワークが正常に動作しているか、またはネットワークのケーブルがコンピュータに確実に接続されているかどうかを確認してください。コンピュータをシャットダウンし、電源を切ってから、再起動してください。


コンテナ <コンテナ名> 内のオブジェクト <オブジェクト名> をレプリケート可能にできないため、新しいレプリカを作成できません。(Error 3582)

指定したオブジェクトをレプリケートできなかったので、データベースをレプリケート可能にできませんでした。たとえば、テーブルのインデックス数が使用できる最大数を超えている場合は、テーブルをレプリケート可能にできません。データベースのオブジェクトが、レプリケーション処理での規則に従っていることを確認した後、データベースをレプリケート可能にしてください。


アクティブな接続が存在しないので、この操作を実行することはできません。(Error 3668)

オブジェクトに対してアクティブなオープン接続が存在しないので、次の操作を実行できません。接続をアクティブにして、この操作を再度実行してください。


シンクロナイザに対するアクティブなトランスポートがありません。(Error 3508)

Microsoft レプリケーション マネージャの再設定を行う必要があります。

シンクロナイザの設定を行うには、次の操作を行ってください。

  1. レプリケーション マネージャを起動します。

  2. [ツール] メニューの [レプリケーション マネージャの構成] をクリックします。

  3. ウィザードの指示に従ってください。


長さ 0 の文字列を使用できるのは、テキスト型またはメモ型のフィールドだけです。(Error 3415)

テキスト型 (Text) およびメモ型 (Memo) 以外のデータ型のフィールドに長さ 0 の文字列を入力しようとしています。代わりに Null 値を入力してください。


ネットワーク パスまたはユーザー名が見つかりませんでした。(Error 3171)

Microsoft® Windows® レジストリの \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox キーのエントリの 1 つまたは複数が無効です。無効なエントリを修正してから、もう一度実行してください。


テーブル <テーブル名> のチェック制約はこのテーブルに転送されません。チェック制約を作成する場合は、SQL DDL ステートメントを使用する必要があります。(Error 3805)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


カレント インデックスを指定してください。(Error 3019)

Index プロパティを設定してから、もう一度実行してください。


カレント レコードがありません。(Error 3021)

FindFirst、FindLast、FindNext、FindPrevious、および Seek のいずれかのメソッドの適用に失敗したか、または元になる Recordset にレコードが含まれていないか、レコードが削除されています。別のレコードに移動するかまたは別のレコードを選択してから、もう一度実行してください。Recordset が空の場合、それをカレント レコードに設定することはできません。BOF または EOF プロパティを確認してください。


接続文字列または IN 句にデータベースが指定されていません。(Error 3321)

接続先のデータベース名を指定していないため、Microsoft Jet データベース エンジンは外部 ISAM データベースに接続できません。外部のデータ ソースに接続する場合は、データベース名を指定する必要があります。

原因：

  • SELECT ステートメントの FROM 句の接続文字列に、"DATABASE=" というパラメータがありません。

  • SELECT ステートメントの IN 句で、外部データベースからデータを選択するためにデータベースの種類を引数として指定していますが、データベース名の引数がありません。


シンクロナイザは、スケジュールされた同期またはオンデマンドの同期を見つけることができませんでした。(Error 3514)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


GUID 列にはインデックスがありません。(Error 3550)

ｾGUID 列にはインデックスがありません。(Error 3550)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


INSERT INTO ステートメント (<ステートメント>) に出力するフィールド名が指定されていません。(Error 3352)

INSERT INTO ステートメントの SELECT 句の式から、1 つまたは複数のデスティネーション フィールド (出力するフィールド) の名前を判定できません。


シンクロナイザのレジストリに必要なキー値が設定されていません。(Error 3503)

使用しているコンピュータのシンクロナイザの再設定を行う必要があります。

シンクロナイザの設定を行うには、次の操作を行ってください。

  1. Microsoft レプリケーション マネージャを起動します。

  2. [ツール] メニューの [レプリケーション マネージャの構成] をクリックします。

  3. ウィザードの指示に従ってください。


このマシンには MAPI クライアントがインストールされていません。Outlook などの MAPI クライアントをインストールしてください。(Error 3804)

Microsoft® Outlook/Exchange IISAM は、Messaging API (MAPI) を使用してフォルダやアドレス帳の情報を取得します。MAPI を使用するには、Outlook Client、Outlook Express、Exchange Client など、MAPI を使用する Microsoft 電子メール クライアントのいずれかをインストールする必要があります。これらをインストールするまでは、Outlook/Exchange IISAM は機能しません。


インポートするフィールド名と一致するフィールドが追加先テーブルにありません。(Error 3243)

インポートするテーブルと追加先のテーブルの両方には、一致するフィールド名が 1 つまたは複数なければなりません。


シンクロナイザは処理対象のメッセージを見つけることができませんでした。(Error 3517)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


これ以上テーブルまたはクエリを開くことはできません。(Error 3037)

一度に開くことのできるテーブルまたはクエリの最大数に達しました。1 つ以上のテーブルまたはクエリを閉じてから、もう一度実行してください。


MS-DOS のファイル ハンドルが不足しています。(Error 3042)

いくつかのファイルを閉じるか、またはほかのアプリケーションを閉じてください。あるいは、使用できる MS-DOS ファイル ハンドルの数を増やしてください。

ファイル ハンドルの数を増やすには、次の操作を行います。

  1. Microsoft® Windows® のメモ帳などのテキスト エディタを使用し、Config.sys ファイルを編集します。通常、Config.sys ファイルは起動ドライブのルート ディレクトリにあります。システムに Config.sys ファイルがない場合は、手順 2. で説明している行を記述した Config.sys ファイルを作成してください。

  2. FILES = x (x は数値) という行を検索し、FILES コマンドで指定している数を増やします。入力するハンドルの数は、実行するアプリケーションや同時に開くファイルの数を基にして決めます。ほかのアプリケーションで複数のファイルを開く場合は、ファイル ハンドルを多めに指定します。

    ハンドルの数を増やすと、その分だけメモリを消費するので注意してください。詳細については、オペレーティング システムのマニュアルを参照してください。

  3. Microsoft Windows を終了します。

  4. システムを再起動して、もう一度実行します。


ワークグループ情報ファイルの 'MSysAccounts' テーブルを開くことができませんでした。(Error 3173)

この操作を実行するには、Microsoft Jet データベース テーブルのセキュリティ設定とオプション設定が含まれている System.mdw ファイルが必要です。

原因と対策：

  • Microsoft® Windows® レジストリの \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet キーの SystemDB の値がネットワーク ドライブを指していますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。

  • System.mdw ファイルが破損しています。System.mdw のバックアップ コピーがあれば、レジストリの SystemDB エントリで指定している場所にそれをコピーしてください。


ワークグループ情報ファイルの 'MSysGroups' テーブルを開くことができませんでした。(Error 3174)

この操作を実行するには、Microsoft Jet データベースのテーブルのセキュリティ設定とオプション設定が含まれている System.mdw ファイルが必要です。

原因と対策：

  • Microsoft® Windows® レジストリの \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Access\Jet\4.0\Engines\Jet キーの SystemDB の値がネットワーク ドライブを指していますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。

  • System.mdw ファイルが破損しています。System.mdw のバックアップ コピーがあれば、レジストリの SystemDB エントリで指定している場所に System.mdw ファイルをコピーしてください。


シンクロナイザまたはレプリケーション マネージャ用の共有メモリには、新しいデータはありません。(Error 3528)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


2 つのシンクロナイザ間に同期スケジュールはありません。(Error 3495)

2 つのシンクロナイザ間のスケジュールが削除されているか、または使用しているコンピュータのシンクロナイザとそれ自身との間でスケジュールを設定しようとしています。Microsoft レプリケーション マネージャを使用し、正しいシンクロナイザとの間でスケジュールを設定してください。


SELECT INTO ステートメント (<ステートメント>) に出力するフィールド名が見つかりません。(Error 3105)

指定したステートメントにデスティネーション フィールド名 (出力するフィールド名) を入力してから、もう一度実行してください。


固定長の指定 '<名前>' で、列幅が指定されていません。(Error 3443)

テキスト ISAM のテキスト ファイルの指定の中にある固定長パラメータが無効であるか、または列幅を指定していません。テキスト ファイルの指定は、次の方法で設定できます。

  • Microsoft® Access では、テキスト リンク ウィザードを使用してこれらの値を設定できます。これには、[ファイル] メニューの [外部データの取り込み] をポイントして、[テーブルのリンク] をクリックします。

  • Microsoft Jet データベース エンジン対応のその他のホスト アプリケーションを使用し、Schema.ini ファイルに値を保存します。


テキスト ファイルの指定 <名前> が存在しません。この指定を使用してインポート、エクスポート、またはリンクすることはできません。(Error 3625)

指定テーブル名を使用して、テキスト ファイルをインポート、エクスポート、またはリンクしようとしましたが、この名前が MSysIMEXSpecs テーブルに存在しません。正しい指定テーブルを使用して、もう一度リンクを作成してください。


指定された値は、レプリカ セットのメンバに対する ReplicaID ではありません。(Error 3488)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


同期を完了するために、シンクロナイザは正しいセットでレプリカを見つけることができませんでした。(Error 3547)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


外部テーブルのフォーマットが正しくありません。(Error 3274)

テーブルの形式がリンク後に変更されています。テーブルをリンクし直してから、もう一度実行してください。


テーブルまたはクエリをインポートできませんでした。レコードが何も見つからないか、すべてのレコードにエラーがあります。(Error 3297)

インポートしようとしたテーブルまたはクエリが、Microsoft Jet データベース エンジンでは見つかりませんでした。また、指定したソースでレコードが見つからないか、すべてのレコードにエラーがあります。指定したパスを確認してからもう一度実行してください。


Microsoft Jet データベース エンジンが初期化されていません。(Error 3278)

データベース エンジンを初期化できません。

原因と対策：

  • Microsoft Jet データベース エンジンを使用する別のアプリケーションと競合しています。ほかのアプリケーションをすべて終了してから、アプリケーションを再起動してください。

  • セットアップ処理中にエラーが発生しました。アプリケーションをセットアップし直してください。


コミットまたはロールバックを実行するには、BeginTrans メソッドを使用してください。(Error 3034)

トランザクションをコミットまたはロールバックしようとしましたが、このトランザクションは BeginTrans ステートメントで開始されていません。


DBF ファイル <ファイル名> に結合されている FoxPro 3.0 にアクセスできません。(Error 3623)

Microsoft® FoxPro® Version 3.0 の連結 .dbf ファイルにアクセスしようとしました。連結ファイルは、連結先の FoxPro データベース コンテナからのみアクセスできます。


UPDATE ステートメント (<ステートメント>) に出力するフィールド名が見つかりません。(Error 3106)

指定したステートメントにデスティネーション フィールド名 (出力するフィールド名) を入力してから、もう一度実行してください。


オブジェクトに値がありません。(Error 2427)

入力した式には、値を持たないオブジェクトの識別子が含まれています。プロパティに既定値があるオブジェクト、または既定のメソッドを返すオブジェクトである可能性があります。

入力した式が正しいかどうかを確認してください。


結合キーに含まれるフィールド '<フィールド名>' は Null に設定できません。(Error 3100)

結合キーのいずれかのフィールドを Null 値に設定して、テーブルを結合しようとしました。別のフィールドを選択するか、またはデータをフィールドに入力してから、もう一度実行してください。


バリアント型でない変数に Null 値を代入しようとしました。(Error 3162)

バリアント型 (Variant) 以外の変数に Null 値を割り当てようとしました。Dim ステートメントを使用して変数をバリアント型 (Variant) として宣言して、もう一度実行してください。


インデックスまたは主キーには、Null 値を使用できません。(Error 3058)

原因：

  • 主キー フィールドに Null 値を追加しようとしました。

  • 新しいレコードを追加しようとしましたが、主キーを含む列に値を入力しませんでした。

  • 主キー フィールドに Null 値を設定するクエリを実行しました。


指定する別名の数は、出力列の数と同じにします。(Error 3731)

このエラーは、SQL DDL によりビューを作成しようとした場合に発生します。また、SELECT ステートメントでの数と異なる数の相関関係名または別名を定義した場合に発生します。たとえば、次の構文はこのエラーになります。

CREATE VIEW foo (col1, col2) AS SELECT col1 FROM table1


数値フィールドがオーバーフローしました。(Error 3349)

Btrieve フィールドのデータが大きすぎるため、アプリケーションで表示できません。


コンテナ '<コンテナ名>' のオブジェクト '<オブジェクト名>' をレプリケートできないため、新しいレプリカを作成できません。(Error 3490)

Microsoft Jet データベース エンジンは、レプリカを作成するためにエラー メッセージに示されているオブジェクトおよびコンテナに対して処理を実行しようとしましたが、失敗しました。


オブジェクト <オブジェクト名> は既に存在しています。(Error 3012)

作成しようとしたオブジェクトに指定した名前は、既にデータベースに存在しています。指定した名前を変更してから、もう一度実行してください。


必要なリソースがないため、指定したオブジェクトをレプリケートできません。(Error 3489)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


オブジェクト <オブジェクト名> が見つかりませんでした。オブジェクトが存在していること、名前やパス名が正しいことを確認してください。(Error 3011)

原因：

  • 指定したオブジェクトが存在しません。

  • オブジェクト名に誤りがあります。アンダースコア (_) などの区切り記号が抜けていないかどうか、または先頭にスペースを入れていないかどうかを確認してください。

  • Btrieve テーブルを開こうとして、このエラーが発生した場合は、データ定義ファイル .ddf の中で示されているパスが正しくない可能性があります。データ ファイル (.dat) が正しいディレクトリにあるかどうかを確認してください。


コンテナ <コンテナ名> 内のオブジェクト <オブジェクト名> をレプリケート可能にできません。(Error 3456)

オブジェクトの操作に必要なリソースが不足したため、Microsoft Jet データベース エンジンはオブジェクトをレプリケート可能にする処理に失敗しました。オブジェクトがテーブルの場合は、レプリケーション完了後のテーブルの全フィールド数が 255 個以下になること、および、レコードの全バイト数が 2,048 バイト以下になることを確認してください。フィールド数やバイト数がこの制限を超えている場合は、レコードのサイズを小さくしてください。


オブジェクトはストアド プロシージャではありません。(Error 3749)

このエラーは、EXECUTE キーワードを使用し、データベースにないプロシージャまたはビューの名前、あるいはベース テーブルの名前を渡した場合に発生します。


'.'、'!'、または '()' の使い方が正しくありません。(Error 2447)

式の中での区切り記号の使い方が正しくありません。DAO オブジェクトのプロパティを参照するには、.propertyname の構文の使用をお勧めします。


古い Paradox のロック ファイルです。(Error 3230)

Paradox のテーブルを使用しようとしましたが、そのテーブルのロック ファイル (.lck) は以前の形式で作成されたものです。ロック ファイル (.lck) を削除してから、もう一度実行してください。


ODBC の仕様適合エラー (<メッセージ>) です。アプリケーションの作成者に通知してください。(Error 3299)

このエラーは、ODBC ドライバに何らかの問題が起きた場合に発生します。メッセージに示されたエラー番号を書き留めて、アプリケーションの開発元に報告してください。報告されたエラー番号はさらにドライバの開発元にも報告されます。


Excel 5.0 形式のファイルを開くことができません。(Error 3432)

Microsoft® Excel Version 5.0 形式のファイルを開いているときに OLE エラーが発生しました。


Excel ISAM ドライバの読み込み中に、OLE を初期化できませんでした。(Error 3430)

Microsoft® Excel の 組み込み可能な ISAM を読み込む場合に、OLE オートメーションを初期化することができませんでした。OLE DLL ファイルをセットアップし直してください。


Excel 5.0 形式のファイルではありません。(Error 3431)

ファイルを Microsoft® Excel Version 5.0 形式のファイルとして読み取ろうとしましたが、ファイルの形式が違います。


バインド パラメータの 1 つが正しくありません。(Error 3645)

GetRows または GetRowsEx に渡された結合構造のデータ型、または結合型が無効であるか、フィールドの最大幅が指定したデータ型に対して無効です。

結合構造を確認してください。


レコードセットのレコードの 1 つがほかのプロセスによって削除されました。(Error 3643)

クエリが実行された後に、Recordset の 1 つまたは複数のレコードが削除されています。Recordset を更新して、クエリをもう一度実行する必要があります。


非同期の OpenConnection 呼び出しはまだ完了していません。呼び出しが完了するまで返された Connection オブジェクトを参照することはできません。(Error 3664)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


データベースをレプリケートにするには、まず排他モードで開く必要があります。(Error 3491)

共有モードでデータベースを開いた後に、データベースをレプリケートしようとしました。いったんデータベースを閉じ、排他モードで再度開いてから、レプリケートしてください。


FTP サービスを使用してファイルを開くことができませんでした。FTP ドロップボックスに読み取り権限があることを確認してください。(Error 3679)

インターネット サーバー上のファイルを開くことができません。サーバーが実行中で、FTP 共有フォルダの読み取り/書き込みアクセスが正しく設定されているのを確認してください。


ユーザーによって処理が中止されました。(Error 3059)

正常終了する前に処理が中断されました。データ変更が一部保存されなかった可能性があります。


実行を試みた操作は、レプリカ セットのメンバを含む既存の操作と矛盾します。(Error 3460)

レプリカ セットのこのメンバーに対して、既にほかのユーザーまたはアプリケーションが同じ処理を実行しています。しばらくしてからもう一度実行してください。


この操作は、現バージョンに変換されていないレプリケート可能なデータベースには実行できません。(Error 3703)

このレプリカは Microsoft® Jet の以前のバージョンで作成されました。レプリケーション操作を実行するには、最初にレプリカ セットを圧縮/変換する必要があります。


この操作は、サブクエリでは実行できません。(Error 3787)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ORDER BY 句 (<句>) が DISTINCT 句と矛盾しています。(Error 3093)

作成した SQL ステートメントには、SELECT ステートメントで列挙していないフィールドを含む、ALL、DISTINCT、DISTINCTROW 述語や ORDER BY 句を指定しています。予約語である DISTINCT を削除するか、または指定したフィールドを ORDER BY 句から削除してください。


ORDER BY 句 (<句>) が GROUP BY 句と矛盾しています。(Error 3094)

選択クエリを作成する場合に、グループ化していない並べ替え済みのフィールドの右側にグループ化したフィールドを指定した場合に、このエラーが起こります。たとえば、作成した SQL ステートメントで、ORDER BY 句のフィールドの順序を正しく指定していません。指定したフィールドを、グループ化していないフィールドの左側に移動するか、または ORDER BY 句から削除してください。


ORDER BY 式 (<式>) にクエリに選択されていないフィールドが含まれています。ORDER BY 式 (<式>) に含めることができるのは、最初のクエリで要求されたフィールドだけです。(Error 3351)

ユニオン クエリの中で指定していないフィールドが ORDER BY 式の中に含まれています。ORDER BY 式に使用することができるのは、最初のクエリで要求されたフィールドのみです。


クエリ定義の SELECT で指定されている別名 '<別名>' が循環参照を発生させています。(Error 3103)

指定した別名によって、不適切な参照が作成されました。たとえば、次の SQL ステートメントの例では、A や week1 が循環参照されるため、エラーになります。

SELECT A + B AS C, C + D AS E, E + F AS A
FROM MyTable;

SELECT week1 + week2 as hours, hours + overtime as gross, gross + ytdpay as week1FROM EmployeePay


出力テーブル '<テーブル名>' が見つかりませんでした。(Error 3192)

INSERT INTO ステートメントで指定しているテーブルが存在しません。入力したテーブル名が正しいかどうかを確認してから、もう一度実行してください。

テーブル作成クエリを使用してテーブルを作成する場合は、SELECT...INTO の構文を代わりに使用してください。


スワップ ファイルの上限に達したか、ファイルが壊れています。(Error 3540)

シンクロナイザの動作中に予期しないシステム障害が発生しました。コンピュータをシャットダウンしてから、再起動してください。


データベースが行ロック モードにあり、要求されたページがロックされています。(Error 3752)

このエラーは、あるユーザーがデータベースをページ ロック専用モードで開くことを指定したが、ほかのユーザーが既にそのデータベースを行/ページ ロック モードで開いている場合に発生します。


パラメータ <パラメータ名> にはデフォルト値はありません。(Error 3748)

このエラーは、プロシージャを使用する場合に発生します。また、パラメータに既定値が定義されていないときに既定値の使用を試みた場合に発生します。このエラー メッセージを回避するには、プロシージャで既定値を定義するか、またはパラメータに値を渡します。


パラメータにはデフォルト値はありません。(Error 3747)

このエラーは、プロシージャを使用する場合に発生します。また、パラメータに既定値が定義されていないときに既定値の使用を試みた場合に発生します。このエラー メッセージを回避するには、プロシージャで既定値を定義するか、またはパラメータに値を渡します。


レジストリ パラメータのサイズが、上限値を超えています。(Error 3552)

Microsoft® Windows® レジストリの各パラメータには、それぞれ最大サイズが規定されています。設定しようとした値は、その最大サイズを超えていました。パラメータの最大サイズを確認してください。


部分レプリカを定義するフィルタが変更されています。部分レプリカを再設定する必要があります。 (Error 3570)

最後に部分レプリカが生成された後で、その部分レプリカに適用したフィルタが変更されています。部分レプリカ ウィザードを実行するか、VBA コードで PopulatePartial メソッドを使用して、部分レプリカを再生成する必要があります。


パートナー レプリカはシンクロナイザによって管理されていません。(Error 3628)

シンクロナイザが管理していないパートナー レプリカと同期を取ろうとしました。


無効なパートナー シンクロナイザです。ローカルまたは匿名のレプリカは、レプリケーション元だけと同期する必要があります。(Error 3741)

指定したシンクロナイザは、このレプリカ セットに対して無効であるか、ローカルまたは匿名レプリカのハブ サーバーではありません。ローカルまたは匿名レプリカを同期させることができるのは、作成元のグローバル ハブ レプリカとだけです。


パスワードで保護されているワークシートはインポートできません。(Error 3244)

ワークシートの保存に使用したアプリケーションに戻り、パスワードを設定せずにワークシートを保存してから、もう一度インポートしてください。


データベースまたはオブジェクトは読み取り専用なので、更新できません。(Error 3027)

読み取り専用として開いているデータベースを変更して保存しようとしました。

次のいずれかの理由により、データベースは読み取り専用になっています。

  • OpenDatabase 関数を使用して読み取り専用でデータベースを開きました。

  • Microsoft® Visual Basic® で、Data コントロールの ReadOnly プロパティを True に設定しました。

  • データベース ファイルがオペレーティング システムまたはネットワークによって読み取り専用として定義されています。

  • データベース ファイルが読み取り専用のメディアに保存されています。

  • ネットワーク環境で、そのデータベース ファイルに書き込む権限がありません。

  • セキュリティが設定されたデータベースを使用している場合、データベースやそのテーブル、フィールドなどが読み取り専用に設定されている可能性があります。また、現在のユーザー名とパスワードでは、データにアクセスする権限がない可能性もあります。

データベースを閉じ、読み取り専用を解除して読み取り/書き込みを可能にしてから、もう一度ファイルを開いてください。


Prevent Deletes Replica からは削除できません。(Error 3754)

Prevent Deletes レプリカは、ユーザーがレコードを削除してしまうことを防ぐために作成されます。レコードを削除したい場合は、削除が可能なレプリカで削除を実行してください。


レコードを追加できません。テーブル '<テーブル名>' の主キーがレコードセットにありません。(Error 3347)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


SQL 構文が正しくありません。プロシージャ名が必要です。(Error 3781)

このエラーは、SQL DDL の CREATE PROCEDURE または DROP PROCEDURE 構文を使用してプロシージャを作成または削除しようとした場合に発生します。また、有効な名前を指定しない場合に発生します。たとえば、次のステートメントはこのエラーになります。

DROP PROCEDURE


シンクロナイザ クライアントを終了しようとしたときに処理が中断しました。(Error 3542)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


指定されたプロパティは既に存在しています。(Error 3311)

新しい Property オブジェクトをコレクションに追加しようとしましたが、既に同じ名前のプロパティが存在します。新しい Property オブジェクトの Name プロパティを正しく入力しているかどうかを確認してください。または、オンライン ヘルプでこの名前のプロパティを参照し、新しい Property オブジェクトを作成する必要があるかどうかを確認してください。


プロパティは 2KB 以下で設定してください。(Error 3309)

オブジェクトのプロパティには、2KB を超える値を設定することはできません。プロパティの値の長さを 2KB 以下にしてください。


プロパティを保存できません。このプロパティはスキーマ プロパティです。(Error 3394)

スキーマ プロパティを設定または変更しようとしました。スキーマ プロパティを設定または削除できるようにするには、作成時に CreateProperty メソッドの第 4 引数に True を指定してください。


FTP を使用してサーバーにファイルを置くことができませんでした。FTP ドロップボックスに書き込み権限があることを確認してください。(Error 3681)

インターネット サーバー上にファイルを格納できません。サーバーが実行中で、FTP 共有フォルダの読み取り/書き込みアクセスが正しく設定されているのを確認してください。


抽出条件式の <名前>。(Error 3076)

メッセージで示された理由のため、入力した式は無効です。フィールド名と区切り記号を正しく入力したかどうかを確認してから、もう一度実行してください。


クロス集計クエリには、複数の固定列見出し '<値>' を指定できません。(Error 3104)

固定列見出しのあるクロス集計クエリを作成する場合、指定する値は固有でなければなりません。重複している列見出しを修正して、もう一度実行してください。


クエリ <クエリ名> にあいまいな列名があり、関連名 (別名) と重複しています。(Error 3807)

列名として完全修飾名を使用するか、または相関関係名 (別名) を変更してください。SQL SELECT ステートメントは、ベース テーブルのいずれかで使用している相関関係名 (別名) をステートメントの FROM 句で使用しています。Microsoft® Jet の以前のバージョンでは、この場合には間違ったレプリカ セットが返されます。レプリカ セットの変更が行われないように、このエラー メッセージは使われています。

Microsoft OLE DB Provider for Jet を使用するか、または ADO (アクティブ データ オブジェクト) を介する場合、この SQL SELECT ステートメントは正しく機能します。Microsoft OLE DB Provider for Jet を使用して、ADO 以外で Microsoft Access のどの部分でもこの SQL SELECT ステートメントを使用する場合、相関関係名 (別名) をベース テーブル内の列名以外の名前に変更する必要があります。

次に 1 例を示します。

CREATE TABLE Orders (OrderDate DATE, Freight DOUBLE);

次の SQL SELECT ステートメントはエラーになります。

SELECT OrderDate AS A1, Freight + Freight AS OrderDate

この問題を解決するには、相関関係名 (別名) OrderDate をほかの名前に変更するか、または Microsoft OLE DB Provider for Jet を使用して ADO を介してこのクエリを実行します。


指定されたフィールド <フィールド名> が SQL ステートメントの FROM 句にある複数のテーブルを参照しました。(Error 3079)

指定したフィールドから、SQL ステートメントの FROM 句で指定している複数のテーブルを参照している可能性があります。次の例では、"伝票番号" フィールドが [売上] テーブルと [売上明細] テーブルの両方に存在します。

SELECT 伝票番号

FROM 売上, 売上明細;

このステートメントはテーブルを指定していないため、エラーが発生します。フィールドを参照するには、テーブル名を追加します。

SELECT 売上.伝票番号

FROM 売上, 伝票番号;


あいまいな外部結合が含まれているので、SQL ステートメントを実行できません。いずれかの結合を最初に実行するために、第一次結合を実行する分割クエリを作成し、SQL ステートメントにそのクエリを含めてください。(Error 3258)

実行しようとした SQL ステートメントには、複数の結合を指定しています。クエリの結果は結合が実行される順序によって異なることがあります。たとえば、次のような SQL ステートメントを実行しようとした場合に、このエラーが発生します。

SELECT * FROM Customers, Orders, [Order Details],

Customers LEFT JOIN Orders

ON Customers.CustomerID = Orders.CustomerID,

Orders INNER JOIN [Order Details]

ON Orders.OrderID = [Order Details].OrderID;

このステートメントは、結合の順序があいまいなため、実行するとエラーになります。これらの結合のうちのどれか 1 つを強制的に先に実行するようにするには、その結合を実行するためのクエリを別に作成し、SQL ステートメントの中にそのクエリを挿入します。次のクエリの例では、LEFT JOIN 操作と RIGHT JOIN 操作を行う前に先に INNER JOIN 操作が実行されます。

Query1

SELECT * FROM Orders, [Order Details],

Orders INNER JOIN [Order Details]

ON Orders. OrderID = [Order Details].OrderID;

Query2

SELECT * FROM Customers, Query1,

Customers LEFT JOIN Query1

ON Customers.CustomerID = Orders.CustomerID;


'<名前>' のかっこの使い方が正しくありません。(Error 3126)

指定した名前がかっこで囲まれていないか、またはかっこが正しく一致していません。かっこが正しく一致していることを確認してから、もう一度実行してください。


SELECT ステートメントの参照が正しくありません。(Error 3242)

フィールドまたはテーブルの無効な参照を SELECT ステートメントで入力しました。たとえば、参照の入力に誤りがあるか、または参照先が存在しない可能性があります。


クロス集計クエリに、無効な固定列見出しが 1 つ以上見つかりました。(Error 3322)

クロス集計クエリの固定列見出しのエントリのリスト (TRANSFORM ステートメントの PIVOT 句) が無効です。

原因：

  • リストの中にエントリがありません。PIVOT 句の予約語 IN の後にくるかっこの中には、少なくとも 1 つの値が必要です。

  • リストの中に空のエントリがあります。カンマが 2 つ連続している (,,) と空のエントリができます。

  • 64 文字を超えるフィールド名がリストにあります。

PIVOT 句を修正してからもう一度クエリを実行してください。


指定されたテーブルから削除できませんでした。(Error 3086)

1 つまたは複数のテーブルからデータを削除できませんでした。

原因：

  • テーブルを変更するために必要な権限がありません。システム管理者、またはテーブルの作成者に依頼して、権限の割り当てを変更してください。

  • 次のいずれかの理由により、データベースが読み取り専用として開いています。

    • OpenDatabase メソッドを使用して、読み取り専用でデータベースを開きました。

    • データベース サーバーのオペレーティング システムまたはネットワークによって、データベース ファイルが読み取り専用として定義されています。

    • ネットワーク環境で、そのデータベースに書き込む権限がありません。

    • Microsoft® Visual Basic® で、Data コントロールの ReadOnly プロパティを True に設定しました。

データを削除するには、データベースを閉じ、読み取り専用を解除して、読み取り/書き込みを可能にしてから、もう一度ファイルを開いてください。


外部結合の '一' 側の空白フィールドには値を入力できません。(Error 3332)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


フィールド '<フィールド名>' は更新できません。フィールドが更新可能ではありません。(Error 3113)

原因：

  • 指定したフィールドは、TableDef オブジェクトまたはダイナセット タイプの Recordset オブジェクトの更新できない部分です。たとえば、オートナンバー型 (AutoNumber) フィールドを更新しようとすると、このエラーが発生します。

  • 更新できる TableDef オブジェクトと更新できない TableDef オブジェクトが混在するクエリを実行し、クエリの結果得られたダイナセット タイプの Recordset オブジェクトのフィールドの 1 つを更新しようとしました。


クエリにはデータベースのパラメータを含めることはできません。(Error 3222)

パラメータ クエリのパラメータのフィールドのデータ型を正しいフィールド データ型に変更してから、もう一度実行してください。


出力の別名 '<別名>' が重複しています。(Error 3062)

実行しようとした SQL ステートメントには、同じ名前の別名が複数あります。たとえば、次のような SQL ステートメントを実行するとこのエラーが発生します。

SELECT 都道府県名 AS 住所, [住所 1] AS 住所 FROM 社員;

別名を変更してから、もう一度実行してください。


出力先 <デスティネーション名> が重複しています。(Error 3063)

実行しようとしたクエリには、同じ名前のデスティネーション フィールド (出力するフィールド) が複数あります。

原因：

  • INSERT INTO、SELECT...INTO、UPDATE などの SQL ステートメントで、同じフィールド名を複数個指定しました。

重複しているフィールドを削除するか、またはデスティネーション フィールド名の別名を指定してから、もう一度実行してください。


サブクエリに非固定列のクロス集計を使用することはできません。(Error 3637)

クロス集計の変数の列で並べ替えを行おうとしています。クエリの実行結果を保存して、[昇順] または [降順] ボタンを使用して実行結果を並べ替える必要があります。


式が正しく入力されていないか、複雑すぎるために評価できません。たとえば、数式に複雑な要素が多すぎます。変数に式の一部を割り当て、式を簡単にしてください。(Error 3071)

原因：

  • 入力した式には、無効な構文が含まれています。必要なオペランドや演算子が入力されていない、文字やカンマ (,) が正しくない、またはテキストがダブル クォーテーション ("") で囲まれていないなどの可能性があります。入力した式が正しいかどうかを確認してください。

  • 入力した式が複雑です。たとえば、数式の中に複雑な部分式が多数あります。部分式を変数に割り当てて、式を簡単にしてください。


フィールド '<フィールド名>' は式に基づいているので、編集できません。(Error 3327)

たとえば、式で構成された列を持つストアド クエリまたはビューを作成した場合、その列を更新することはできません。次のステートメントを実行すると、このエラーが返されます。

CREATE VIEW VCustomer AS SELECT (FirstName & LastName) AS Test FROM Customer followed by UPDATE Test FROM VCustomer


クエリ式 '<式>' の <メッセージ> (Error 3075)

メッセージで示された理由のため、入力した式は無効です。フィールド名と区切り記号を正しく入力したかどうかを確認してから、もう一度実行してください。


このフィールドを変更する前に、まずレコードを保存してください。(Error 3331)

このエラーは、複数のテーブルから成るビューまたはストアド クエリに配置された行を編集しようとした場合に発生します。


アクション クエリを使用してデータを挿入することはできません。(Error 3084)

実行しようとした追加クエリには、入力に対するアクション クエリを指定しています。アクション クエリを選択クエリに変更してから、もう一度実行してください。


別名が正しくありません。(Error 3068)

入力した別名は、名前付け規則に従っていません。新しい名前を入力して、もう一度実行してください。


アクション クエリをデータ ソースとして使用することはできません。(Error 3417)

原因：

  • レコードのソースとして、アクション クエリまたはデータ定義クエリが使用されています。


アクション クエリ '<クエリ名>' をデータ ソースとして使用することはできません。(Error 3069)

アクション クエリ名は使用できません。選択クエリ名を使用してください。アクション クエリを実行するには、FROM 句の中でアクション クエリ名ではなく Execute メソッドを使用してください。


内部のレポート クエリ (<クエリ名>) から入力することはできません。(Error 3124)

実行しようとした SQL ステートメントで、使用禁止にされている内部レポート クエリを明示的に参照しています。


パラメータ名 '<パラメータ名>' は正しくありません。名前が長すぎるか、無効な文字を含んでいます。(Error 3223)

パラメータ名が長すぎるか、または無効な文字が含まれています。名前を修正してから、もう一度実行してください。


アクション クエリ '<クエリ名>' を開くことができません。(Error 3064)

OpenQueryDef メソッドを使用して、アクション クエリを開こうとしました。指定したメソッドはバージョンが古く、選択クエリでのみ有効です。アクション クエリを実行する場合は、QueryDef オブジェクトの Execute メソッドを使用してください。


クエリ '<クエリ名>' は破損しています。(Error 3340)

未定義のクエリ名を参照しました。QueryDefs コレクションで指定しているクエリを調べ、有効なクエリ名を参照しているかどうかを確認してください。


このクエリは DDL クエリなので、データ ソースとして使用することはできません。(Error 3324)

Execute メソッドを使用せずにアクション クエリまたはデータ定義クエリを実行しようとしました。


内部レポート クエリは使用できません。(Error 3083)

禁止されている内部レポート クエリに対する参照を含む SQL ステートメントを実行しようとしました。この参照を削除してから、もう一度実行してください。


選択クエリを実行できません。(Error 3065)

選択クエリで Execute メソッドを実行しようとしました。Execute メソッドはアクション クエリでのみ有効です。アクション クエリと異なり、選択クエリは SELECT ステートメントを含み、レコードを返すことができます。


このクエリは、正しく指定されたデータ定義クエリではありません。(Error 3357)

このクエリは、データ定義クエリの正しい形式に従っていません。


このクエリは、データ ソースとして使用することはできません。(Error 3323)

原因：

  • レコードのソースとして、アクション クエリまたはデータ定義クエリが使用されています。


このレコードセットは更新できません。(Error 3326)

スナップショット タイプの結果セット オブジェクトに連結されているフィールドのデータを編集しようとしました。Microsoft Jet データベースのスナップショット タイプのフィールドは編集できません。


式で型が一致しません。(Error 3615)

JOIN 式で、データ型の異なるフィールドを使用して 2 つのテーブルを結合しようとしています。たとえば、メモ型 (Memo) フィールドとテキスト型 (Text) フィールドを結合しようとすると、このエラーが発生します。


結合、グループ化、並べ替え、インデックスを実行できません。検索または並べ替えの対象である値が大きすぎます。(Error 3393)

結合、グループ化、並べ替えに使用する各フィールドの長さの合計が、255 バイトを超えないようにしてください。フィールドの数を減らすか、またはフィールドのデータ型やサイズを小さくしてください。


集計関数の引数 (<ステートメント>) にメモ型または OLE オブジェクト型のフィールドを指定することはできません。(Error 3115)

集計関数には、メモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールドを指定することはできません。


固有の値 (<ステートメント>) を選択した場合は、メモ型または OLE オブジェクト型のフィールドを含むことはできません。(Error 3114)

予約語 DISTINCT、またはメモ型 (Memo) や OLE オブジェクト型 (OLE Object) のフィールドを、ステートメントから削除してください。


メモ型または OLE オブジェクト型 (<句>) のフィールドはグループ化できません。(Error 3119)

SQL ステートメントの GROUP BY 句には、メモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールドを指定することはできません。


集計関数の抽出条件 (<条件>) にメモ型または OLE オブジェクト型のフィールドを指定することはできません。(Error 3116)

SQL ステートメントの HAVING 句には、メモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールドを指定することはできません。


メモ型または OLE オブジェクト型 (<名前>) のフィールドを結合することはできません。(Error 3118)

メモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールドを結合することはできません。複数のテーブルを論理的に結び付けるために使用するフィールドは、テキスト型 (Text) や整数型 (Integer) などのほかのデータ型である必要があります。


メモ型または OLE オブジェクト型のフィールド (<句>) で並べ替えを行うことはできません。(Error 3117)

SQL ステートメントの ORDER BY 句には、メモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールドを指定することはできません。


ユニオン クエリの SELECT 句では、メモ型または OLE オブジェクト型のフィールド '<フィールド名>' を使用できません。(Error 3364)

SQL ステートメントのユニオン クエリの SELECT 句で指定したフィールドのデータ型が、メモ型 (Memo) または OLE オブジェクト型 (OLE Object) になっています。これらの型のフィールドは指定できません。


サブクエリ '<サブクエリ名>' のメモ型または OLE オブジェクト型のデータが正しくありません。(Error 3342)

サブクエリはメモ型 (Memo) または OLE オブジェクト型 (OLE Object) のデータを返せないため、式の中でメモ型 (Memo) または OLE オブジェクト型 (OLE Object) のデータと比較することはできません。


サブクエリでは、マルチレベル GROUP BY 句は使用できません。(Error 3612)

SQL サブクエリでは、GROUP BY 句に複数のフィールドを列挙することはできません。


パラメータが少なすぎます。<数> を指定してください。(Error 3061)

このパラメータ クエリに、指定した数のパラメータ入力しませんでした。必要な数のパラメータを指定してから、もう一度クエリを実行してください。

このメッセージは、未知のフィールド名や式がクエリのパラメータとして解釈した場合にも表示されます。スペースや区切り記号を含むフィールド名は、必ず角かっこ ([ ]) で囲んでください。


'<名前>' の削除権限がないので、レコードを削除できません。(Error 3109)

指定したテーブルまたはクエリのデータを削除するためには、データ削除の権限が必要です。システム管理者、またはテーブルやクエリの作成者に依頼して、権限の割り当てを変更してください。


削除するレコードを含んだテーブルを指定してください。(Error 3128)

削除クエリを実行しようとしましたが、削除するレコードのあるテーブルの名前を指定していません。

原因：

  • ALL、DISTINCT、または DISTINCTROW の述語で、各テーブルごとにアスタリスク (*) を入力しないで、フィールド名を入力しました。たとえば、「得意先.*」ではなく「得意先.住所」を入力しました。


クエリの入力には、1 つ以上のテーブルまたはクエリが必要です。(Error 3067)

Microsoft Jet データベースで、クエリを作成する場合に、テーブル名を選択しませんでした。テーブルまたはクエリを 1 つ以上選択してください。

ODBCDirect データベースの場合、SQL ステートメントのないクエリを実行しようとしました。QueryDef オブジェクトの SQL プロパティには、1 つ以上のクエリまたはストアド プロシージャが必要です。


'<名前>' の挿入権限がないので、レコードを追加できません。(Error 3107)

指定したテーブルまたはクエリにデータを挿入するためには、データ挿入の権限が必要です。システム管理者、またはテーブルやクエリの作成者に依頼して、権限の割り当てを変更してください。


レコードを追加できません。'一' 側に対応するレコードがありません。(Error 3363)

このエラーは、複数のテーブルを含むストアド クエリまたはビューを編集したときに発生します。[顧客] テーブル ("一" 側) と [注文] テーブル ("多" 側) の間の結合であったビューをとおして行を保存しようとすると、このエラーが発生します。[顧客] テーブルに注文に関する情報は入力したのに、主キー値などの情報を入力しなかった場合に、このエラーが返されます。


クエリには、出力フィールドが 1 つ以上必要です。(Error 3066)

クエリを作成する場合に、デスティネーション フィールド名 (出力するフィールド名) を指定しませんでした。少なくとも 1 つまたは複数のデスティネーション フィールドを選択してください。


テーブルまたはクエリ '<クエリ名>' の定義を読み取る権限がないので、定義を読み取ることができませんでした。(Error 3110)

指定したテーブルまたはクエリの定義を読み取るためには、定義読み取りの権限が必要です。システム管理者、またはテーブルやクエリの作成者に依頼して、権限の割り当てを変更してください。


'<参照名>' の読み取り権限がないので、レコードを読み取ることができません。(Error 3112)

指定したテーブルまたはクエリのデータを表示するためには、読み取りの権限が必要です。システム管理者、またはテーブルやクエリの作成者に依頼して、権限の割り当てを変更してください。


'<名前>' の更新権限がないので、レコードを編集できません。(Error 3108)

指定したテーブルまたはクエリのデータを置き換えるためには、データ更新の権限が必要です。ワークグループ管理者、またはテーブルやクエリの作成者に依頼して、権限の割り当てを変更してください。


テーブルまたはクエリ '<クエリ名>' のデザインを変更する権限がないので、作成できませんでした。(Error 3111)

指定したテーブルまたはクエリを作成しようとしましたが、デザイン変更の権限がありません。システム管理者、またはクエリの作成者に依頼して、権限の割り当てを変更してください。


クエリがサポートされていません。(Error 3389)

QueryDef オブジェクトの Relation オブジェクトに対して参照整合性を確立しようとしましたが、QueryDef オブジェクトでは参照整合性はサポートされていません。

Relation オブジェクトの Attributes プロパティの設定を、定数 dbRelationDontEnforce に変更してください。


更新可能なクエリであることが必要です。(Error 3073)

更新できないクエリを実行、変更、または開こうとしました。

原因：

  • 更新できないフィールドを更新するクエリを実行しようとしました。一対多リレーションシップの "一" 側のフィールドを更新しようとした場合などに、このエラーが発生します。

  • 読み取り専用で開いているデータベースのクエリで、以前のバージョンの OpenQueryDef メソッドを指定しようとしました。

    次のいずれかの理由により、このデータベースは読み取り専用になっています。

    • OpenDatabase メソッド、または Microsoft Visual Basic の Data コントロールを使用し、読み取り専用でデータベースを開きました。

    • ネットワーク環境で、データベース ファイルが読み取り専用として定義されています。

    • ネットワーク環境で、データベース ファイルに書き込む権限がありません。

    データベースを閉じ、読み取り専用を解除して、読み取り/書き込みを可能にしてから、もう一度データベースを開いてください。

  • クエリのデータを変更する権限がありません。システム管理者、またはクエリの作成者に依頼して、権限の割り当てを変更してください。


パラメータ '<名前>' にはデータベース名を指定してください。(Error 3217)

作成したパラメータ クエリに、無効な型のパラメータを指定しています。たとえば、次の SQL ステートメントを実行するとこのエラーが発生します。

PARAMETERS Param1 Text;

SELECT CustomerID

FROM Customers IN Param1;

Param1 はテキスト パラメータですが、FROM 句ではデータベース パラメータが必要です。

この場合は、パラメータの型を Text から Database に変更してから、もう一度実行します。


パラメータ '<名前>' にはテーブル名を指定してください。(Error 3216)

作成したパラメータ クエリに、無効な型のパラメータを指定しています。たとえば、次の SQL ステートメントを実行するとこのエラーが発生します。

PARAMETERS Param1 Text;

INSERT INTO Param1

SELECT *

FROM Customers;

Param1 はテキスト パラメータですが、INSERT INTO ステートメントではテーブル名が必要です。

この場合は、パラメータの型を Text から TableID に変更してから、もう一度実行します。


パラメータ <パラメータ名> のデータ型が正しくありません。(Error 3060)

このパラメータに定義しているデータ型と異なるデータ型の引数を使用しようとしました。たとえば、数値の引数を指定すべきパラメータに文字列式を指定しようとしました。正しいデータ型の引数を指定してから、もう一度実行してください。


テーブル '<テーブル名>' のレコードは、ほかのユーザーによって削除されています。(Error 3329)

編集しようとした行は、別のユーザーによって削除されています。データベースを使用しているすべてのユーザーが排他的ロックを使用すると、このエラーを回避することができます。


テーブル '<テーブル名>' のレコードは、ほかのユーザーによってロックされています。(Error 3330)

更新しようとした行またはページは、現在、別のユーザーによってロックされています。Microsoft® Jet Version 4.0 では、ユーザーは行レベル ロッキングを利用可能なモードで、データベースを開くことができます。このモードを使用すると、エラーの発生回数を減らすことができます。


テーブル作成クエリで同じテーブル ('<テーブル名>') が、作成元になるテーブルおよび作成されるテーブルの両方として指定されています。(Error 3610)

SELECT...INTO ステートメントで、ソース テーブル名の 1 つをデスティネーション テーブル名 (出力するテーブル名) として指定しています。ソース テーブルまたはデスティネーション テーブルのいずれかの一方からテーブルを削除してください。


テーブル '<テーブル名>' は読み取り専用です。(Error 3328)

このエラーは、別のユーザーが読み取り専用で開いたテーブルの列を、更新しようとしたときに発生します。


クエリが複雑すぎます。(Error 3360)

クエリが複雑すぎます。SELECT 句のフィールド数、サブクエリの数、または結合内のテーブルの数を減らしてください。


DISTINCT 出力の式が多すぎます。(Error 3089)

作成した SQL ステートメントの ALL、DISTINCT、または DISTINCTROW 述語で、11 個以上の式を指定しています。予約語である DISTINCT を削除するか、または DISTINCT 述語からフィールドをいくつか削除してください。


GROUP BY 句の式が多すぎます。(Error 3087)

作成した SQL ステートメントの GROUP BY 句で 11 個以上のフィールドを指定しています。GROUP BY 句からフィールドをいくつか削除してください。


ORDER BY 句の式が多すぎます。(Error 3088)

作成した SQL ステートメントの ORDER BY 句で 11 個以上の式を指定しています。ORDER BY 句からフィールドをいくつか削除してください。


クロス集計する列のヘッダー (<値>) が多すぎます。(Error 3205)

SQL ステートメントで作成される列の数が多すぎます。指定した値はエラーとなる列数を示します。

WHERE 句に条件を追加するか、または WHERE 句の記述がない場合はそれを追加して、列の数を減らしてください。


削除クエリやレポートでは、TOP 句に指定された値は使用できません。(Error 3318)

SELECT ステートメントの TOP 句で指定するトップ値は、削除クエリやレポートでは使用できません。


'<クエリ参照>' から循環参照が発生しています。(Error 3102)

実行しようとしたクエリは循環参照になっています。たとえば、次のいずれかのクエリを実行すると、このエラーが発生します。

Query1

SELECT * FROM Employees, Query2;

Query2

SELECT * FROM Query1;

循環参照が発生しないようにクエリを修正してください。


<名前> を有効なフィールド名、または式として認識できません。(Error 3070)

指定した名前はフィールド名や有効な式として認識できません。クエリでは、データベース、テーブル、またはフィールドを正しく参照しない名前を入力した場合に、このエラーが発生します。

Microsoft® Access での原因：

  • クロス集計クエリのパラメータ、またはクロス集計クエリやチャートの基になっているパラメータのデータ型が [クエリ パラメータ] ダイアログ ボックスで明示的に指定されていません。これを解決するには、次の手順を実行します。

    • [クエリ パラメータ] ダイアログ ボックスで、クエリのパラメータとデータ型を指定するか、

      • パラメータを持つクエリの ColumnHeadings プロパティを設定します。

  • クエリで参照しているデータベース、テーブル、またはフィールドが正しくありません。このエラーは、たとえば実際のフィールド名が "売上" であるのに、式の中で "売り上げ" というフィールドを参照している場合などに起こります。


テーブル '<テーブル名>' のレコードに、'一' 側と対応するレコードがなくなります。(Error 3333)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


クエリの値と出力するフィールドの数が一致しません。(Error 3346)

INSERT INTO ステートメントにより作成した追加クエリで、VALUES 句または SELECT ステートメントで指定したデスティネーション フィールド (出力するフィールド) の数が、デスティネーション テーブル (出力するテーブル) にあるフィールドの数よりも少ないか、または多くなっています。フィールドの数を同じにしてください。


ほかのユーザーによってロックされているので、保存できませんでした。(Error 3202)

原因：

  • 現在、ほかのユーザーによってロックされている 2KB のデータベースのページにあるレコードを保存しようとしました。ほかのユーザーがレコードの処理を完了してから、もう一度実行してください。


読み取り中にディスク I/O エラーが発生しました。(Error 3040)

ディスクまたはドライブの内部的な障害のため、ディスクへの書き込みやディスクからの読み取りができません。

原因：

  • ネットワーク ドライブを使用しようとしましたが、ネットワークが一時的に混雑しているか、またはネットワークへの接続が既に切断されています。ネットワークの接続状態を確認してから、もう一度実行してください。

  • ディスクまたはドライブに障害があります。


シンクロナイザは、管理するレプリカ セットのメンバに対する無効なメッセージを受信しました。(Error 3536)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


レコードは削除されています。(Error 3167)

既に削除したレコード、またはマルチユーザー環境で別のユーザーが削除したレコードを参照しようとしました。別のレコードへ移動してから、もう一度実行してください。


ほかのユーザーによってロックされているので、レコードを保存できませんでした。(Error 3158)

現在、ほかのユーザーによってロックされているデータベースのページにあるレコードを保存しようとしました。ほかのユーザーがレコードの処理を完了してから、もう一度保存してください。


Update または CancelUpdate メソッドには、対応する AddNew または Edit メソッドが必要です。(Error 3020)

Microsoft Jet データベースで、Update または CancelUpdate メソッドを呼び出しましたが、データをレコードに書き込む前に AddNew または Edit メソッドを使用しませんでした。

ODBCDirect データベースでは、AddNew または Edit メソッドを先に呼び出さずにデータをレコードに書き込もうとすると、このエラーが発生します。


レコードが大きすぎます。(Error 3047)

2KB を超えるレコードを持つテーブルを定義またはインポートしました。このエラーは、テーブルの構造を定義する場合ではなく、データをレコードに入力する場合に起こります。フィールドを短くするか、不要なフィールドを削除するか、またはフィールドの一部をほかのテーブルに移動して、テーブルを再定義してください。


復旧されたレプリケート可能なデータです。この行は、破損したレプリケート可能なデータベースから復旧しました。レコードの内容が正しいことを確認し、レコードを再度挿入するか、この競合するレコードを削除してください。(Error 3711)

レプリカを回復すると、破壊されたレプリカにあった新しいレコードは、回復したレプリカの競合テーブルに追加されます。これにより、データを再追加する前にデータを確認できます。


参照が見つかりませんでした。(Error 3199)

入力したファイル、テーブル、またはフィールドの参照が見つかりませんでした。参照の名前や区切り記号を正しく入力しているかどうかを確認してから、もう一度実行してください。


リレーションシップ '<リレーションシップ名>' は実行できません。部分フィルタ式のリレーションシップは実行する必要があります。(Error 3659)

実行していないリレーションシップが存在するテーブル内の部分レプリカでフィルタを適用しようとしました。デザイン マスターでリレーションシップを実行し、次にフィルタを適用し、部分レプリカを再作成してください。


主テーブルで参照されているフィールド用の固有インデックスが見つかりません。(Error 3609)

テーブル間でリレーションシップを作成する場合には、主テーブルの参照先フィールドに固有インデックスを持たせることが必要です。この方法の詳細については、｢Index オブジェクトおよび Primary プロパティ｣を参照してください。


チェック制約は、レプリケート可能なデータベースには使用できません。(Error 3798)

データベースまたはテーブルをレプリケート可能にする前に、すべての CHECK 制約を削除してください。


MSysFilters テーブルに存在しない部分フィルタに関する情報を削除または取得しようとしました。(Error 3505)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


このレプリカの ReplicaID は、移動またはコピーの処理中に再度割り当てられました。(Error 3574)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


設定または削除を試みたレプリケーション プロパティは読み取り専用であり、変更できません。(Error 3461)

レプリケーションに関連するプロパティの多くは内部的にのみ使用されるか、または開発者が参照用として使用します。プログラム コードを調べて、参照専用のプロパティを変更しようとしていないかどうかを確認してください。


デザイン マスターまたはレプリカがシンクロナイザによって管理されていません。(Error 3502)

シンクロナイザが管理していないデザイン マスターまたはレプリカに関する情報を取得しようとしています。


このレプリカはレプリカ セットから論理的に削除されているため、使用できません。(Error 3569)

レプリカ セットのこのメンバーは、必要な日数期限内に同期が取られなかったか、または 2 つ目のデザイン マスターと同期が取られたために、既に削除されています。このメンバーはコンピュータから削除してください。

レプリカ セットのほかのメンバーと同期が取られなかったメンバーがデータを持っている場合は、そのデータを手動で別のメンバーに入力してください。各テーブルの s_Generation フィールドを調べれば、同期が取られなかったデータのあるレコードを特定することができます。s_Generation フィールドの値が 0 であれば、そのレコードは挿入または更新されたレコードであり、レプリカ セットのほかのレプリカとまだ同期が取られていないことを示します。s_Generation フィールドを表示するには、Microsoft® Access で、[ツール] メニューの [オプション] をクリックし、[表示] タブをクリックして、[システム オブジェクト] チェック ボックスをオンにします。

このメンバーがデザイン マスターである場合は、レプリカの構造をレプリカ セットのほかのレプリカと比較して、まだ同期が取られていないデザインの変更があるかどうかを調べてください。


レプリカの名前または ID が、現在管理されているレプリカ セットのメンバと一致しません。(Error 3520)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


同期を試みたレプリカ セットのメンバは、現在ほかの同期で使用されています。(Error 3510)

デザイン マスターまたはレプリカ間では、一度に 1 つずつしか同期を取れません。レプリカのメンバーがロックされている間は、そのメンバーを使用することはできますが、2 つ目の同期を開始することはできません。しばらくしてから、もう一度同期処理を実行してください。


このレプリカは部分レプリカではありません。(Error 3478)

部分レプリカのフィルタなどに関する情報を取得しようとしていますが、参照しているレプリカは部分レプリカではありません。Microsoft レプリケーション マネージャを使用してそのレプリカのプロパティ シートを表示し、そのレプリカが部分レプリカではないことを確認してください。


管理者の許可を得ていない場合は、レプリカの優先度は 0 - 1 の範囲にします。(Error 3772)

管理者の許可がない場合、レプリカの優先度 (プライオリティ) は、作成されている新しいレプリカの優先度数から 0 の範囲でなければなりません。


同期を試みた 2 つのレプリカ セットのメンバは両方ともデザイン マスターです。(Error 3561)

いずれかのデザイン マスターを削除してください。


同期を試みたレプリカ セットの 2 つのメンバの ReplicaID が同じです。(Error 3560)

レプリカ セットの別のレプリカを使用して同期を取ってください。


削除を試みたレプリケーション プロパティは読み取り専用のため、削除できません。(Error 3607)

削除しようとしているプロパティが正しいプロパティかどうかを確認してください。


データベースをレプリケート可能にするために必要なレプリケーション システム テーブルを作成できませんでした。(Error 3579)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


同期を開始する共通点がないため、この 2 つのレプリカを同期できません。(Error 3521)

レプリカ セットのこの 2 つのメンバーが最後に同期してから経過した時間が長すぎるために、Microsoft Jet データベース エンジンはこれらのメンバーの共通の参照ポイントを見つけることができません。このため、データベースの内容や構造の変更を有効にすることができません。


<description> のために要求された交換は失敗しました。(Error 3660)

変換が失敗した原因の詳細については、変換の履歴を参照してください。レプリケーション マネージャを使用している場合には、レプリケート オブジェクトで右クリックすると、変換の履歴を閲覧することができます。[表示] メニューの [同期の履歴] でもレプリケーションの履歴を閲覧することができます。

Microsoft® Access を使用してレプリケーションをしようとしている場合には、[データシート ビュー] で変換の履歴テーブルを開いて、変換の履歴を閲覧することができます。変換の履歴テーブルは隠しオブジェクトです。[オプション] ダイアログボックスの [表示] タブで、[システム オブジェクト] チェック ボックスをオンにすると、データベース ウィンドウで履歴テーブルを表示させることができます。[オプション] ダイアログボックスは、[ツール] メニューの [オプション] をクリックすると使用することができます。


レプリカ セットの保有期間内に、レプリカが同期しませんでした。(Error 3743)

レプリカの保存期間が満了した場合、レプリカ セット内の満了したレプリカとほかのレプリカの間での変更を同期させることはできません。保存期間内でレプリカ セット内のあるレプリカがほかのレプリカと同期しない場合、次にそのレプリカを同期させようとしたときに、そのレプリカはレプリカ セットから削除されます。保存期間は、最初にデータベースをレプリケート可能にしたときに設定されます。Replication Manager、DAO (データ アクセス オブジェクト)、ADO (アクティブ データ オブジェクト) のいずれかを使用してデータベースをレプリケートする場合、デフォルトの保存期間は 60 日です。Microsoft® Accessまたは Briefcase を使用してデータベースをレプリケートする場合、デフォルトの保存期間は 1000 日です。


無効なエントリです。フィールド '<フィールド名>' に入力された値が大きすぎ、テーブル '<テーブル名>' で連鎖処理を実行できません。(Error 3411)

リレーションシップに含まれている主キーのフィールドに値を保存しようとしています。

Microsoft® Access でリレーションシップに対して [フィールドの連鎖更新] オプションをオンにしているか、または、DAOのコードで Relation オブジェクトの Attributes プロパティに dbRelationUpdateCascade オプションを指定しています。いずれかの設定を行っても、アプリケーションはリレーション テーブルの中で一致するフィールドを更新しようとします。

このフィールドに変更を保存するためには、アプリケーションが更新しようとするリレーション フィールドのフィールド サイズよりも短いテキストを入力する必要があります。この場合、リレーション フィールドのサイズは更新しようとしているフィールドよりも小さくなっています。今後この問題を回避するには、一致する 2 つのフィールドの Size プロパティに同じ値を設定してください。


連鎖処理を実行できません。実行すると、テーブル '<テーブル名>' のキーが重複します。(Error 3399)

連鎖処理を行うと、このテーブルのキーが重複します。このテーブルでは、主キーの重複が許可されていません。更新する値を確認し、キーが重複しないように修正してください。


連鎖処理を実行できません。実行すると、テーブル '<テーブル名>' のキーが Null 値になります。(Error 3398)

連鎖処理を行うと、このテーブルの主キーのフィールド値が Null 値になります。このテーブルでは、Null 値の使用が許可されていません。更新する値を確認し、Null 値にならないように修正してください。


テーブル '<テーブル名>' は現在使用されているので、連鎖更新を実行できません。(Error 3414)

リレーションシップに含まれている主キーのフィールドに値を保存しようとしています。

Microsoft® Access でリレーションシップに対して [フィールドの連鎖更新] オプションをオンにしているか、または、DAO のコードで Relation オブジェクトの Attributes プロパティに dbRelationUpdateCascade オプションを指定しています。このため、アプリケーションはリレーション テーブルの中で一致するフィールドを更新しようとします。

コンピュータ上で既にテーブルを開いているかまたはロックしているため、一致するフィールドを更新できません。先にリレーション テーブルを閉じてから、レコードを保存してください。


連鎖処理を実行できません。実行すると、フィールド '<フィールド名>' が長さ 0 の文字列になります。(Error 3402)

連鎖処理を行うと、このフィールドが長さ 0 の文字列になります。このフィールドでは、長さ 0 の文字列は許可されていません。更新する値を確認し、長さ 0 の文字列にならないように修正してください。


連鎖処理を実行できません。実行すると、フィールド '<フィールド名>' が Null 値になります。(Error 3401)

連鎖処理を行うと、このフィールドの値が Null 値になります。このフィールドでは、Null 値の使用は許可されていません。更新する値を確認し、Null 値にならないように修正してください。


連鎖処理を実行できません。入力された値は、'<名前>' に設定されている入力規則 '<規則>' で禁止されています。(Error 3404)

連鎖処理を行うと、このフィールドの値はフィールドの入力規則によって無効にされます。更新する値を確認し、入力規則に反しないように修正してください。


連鎖処理 '<入力規則テキスト>' を実行できません。(Error 3403)

連鎖処理を行うと、データが無効になります。更新する値を確認し、入力規則に反しないように修正してください。


連鎖処理を実行できません。実行すると、テーブル '<テーブル名>' のフィールド '<フィールド名>' が 2 回更新されます。(Error 3400)

フィールドが 2 回更新されてしまうため、連鎖処理は実行できません。更新する値を確認し、次のいずれかの条件を満たすように修正してください。

  • フィールドが 1 回のみ更新される。

  • フィールドが 2 回以上更新される場合、いずれの更新結果も同じになる。


連鎖処理を実行できません。関連レコードがテーブル '<テーブル名>' に存在しているので、参照整合性の規則に違反することになります。(Error 3396)

このテーブルの参照整合性の規則に反する連鎖処理を行おうとしています。更新または削除する値を確認し、参照整合性の規則に反しないように修正してください。


連鎖処理を実行できません。テーブル '<テーブル名>' に関連レコードが存在する必要があります。(Error 3397)

このテーブルの参照整合性の規則に反する連鎖処理を行おうとしています。この連鎖処理では、テーブルにリレーション レコードが必要です。更新または削除する値を確認し、参照整合性の規則に反しないように修正してください。


このテーブルは現在ほかのユーザーによって使用されているので、連鎖更新を実行できません。(Error 3412)

リレーションシップに含まれている主キーのフィールドに値を保存しようとしています。

Microsoft® Access でリレーションシップに対して [フィールドの連鎖更新] オプションをオンにしているか、または、DAO のコードで Relation オブジェクトの Attributes プロパティに dbRelationUpdateCascade オプションを指定しています。アプリケーションは、リレーション テーブルの中で対応するフィールドを更新しようとします。

ほかのユーザーとのロック競合を起こしているため、一致するフィールドを更新できません。ほかのユーザーがリレーション テーブルの使用を終えてから、レコードを保存してください。


パススルー クエリで使用されている接続文字列が正しくありません。(Error 3305)

パススルー クエリの接続文字列は "ODBC;" で始めてください。


ODBC--フィールドが長すぎるので、データが切り捨てられました。(Error 3231)

ODBC データ ソースの処理を実行した結果、作成されたフィールドが最大長を超えました。最大長を超えるデータは切り捨てられます。


ODBC--テーブルを作成できませんでした。(Error 3232)

ODBC データベースにテーブルをエクスポートしようとしましたが、テーブルを作成できませんでした。ODBC データベースが読み取り専用になっているか、またはそのデータベースでテーブルを作成する権限がありません。読み取り専用を解除するか、またはシステム管理者やデータベースの作成者に依頼して、必要な権限を取得してください。


ODBC--リンク テーブル '<テーブル名>' での削除に失敗しました。(Error 3156)

ODBC 接続を使用して、ODBC データベースからデータを削除しようとしましたが、削除できませんでした。

原因：

  • 規則違反のため削除できませんでした。

  • ODBC データベースが読み取り専用であるか、またはそのデータベースからデータを削除する権限がありません。読み取り専用を解除するか、またはシステム管理者やデータベースの作成者から必要な権限を取得してください。

  • ODBC データベースはネットワーク ドライブにありますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。


ODBC--すべてのレコードをロックできません。(Error 3254)

ODBC 接続を使用して ODBC データベースのレコードをすべてロックしようとしました。


ODBC を使用して、外部 Microsoft Jet データベース エンジンのテーブルや組み込み可能な ISAM データベースのテーブルのインポート、エクスポート、またはリンクを行うことはできません。(Error 3423)

Microsoft Jet データベース エンジンの外部テーブル、または dBASE、Microsoft® FoxPro®、Paradox、Btrieve などの ISAM 外部テーブルに対して、リンク、インポート、またはエクスポートを行おうとしていますが、既にデータ ソースとして <SQL データベース> を選択しています。リンクするデータに対応したデータ ソースを選択してください。


ODBC--リンク テーブル '<テーブル名>' への挿入に失敗しました。(Error 3155)

ODBC 接続を使用して、ODBC データベースにデータを挿入しようとしましたが、挿入できませんでした。

原因：

  • 規則違反のため挿入できませんでした。

  • ODBC データベースが読み取り専用であるか、またはそのデータベースにデータを挿入する権限がありません。読み取り専用を解除するか、またはシステム管理者やデータベースの作成者から必要な権限を取得してください。

  • ODBC データベースはネットワーク ドライブにありますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。


ODBC--'<名前>' への接続が失敗しました。(Error 3151)

ODBC を使用して、ODBC データベースのサーバーに接続できませんでした。ODBC データベースにネットワーク接続経由でアクセスする場合は、ネットワークを利用できる状態にしてから、もう一度実行してください。


リンクするテーブルが見つからないので、クエリを実行できませんでした。(Error 3184)

原因と対策：

  • リンク テーブルが存在しないか、リンク テーブル名が変更されているか、または別のディレクトリに移動されています。テーブルをリンクしてから、もう一度クエリを実行してください。

  • リンク テーブルはネットワーク ドライブ上にありますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。


ODBC--リンク テーブルの定義が変更されています。(Error 3247)

リンクを作成した時点から現在までの間に、リンク テーブルの定義または構造が変更されています。リンクを削除してから、もう一度テーブルをリンクしてください。


ODBC--DLL '<DLL ファイル名>' が見つかりませんでした。(Error 3154)

ODBC 接続を使用して、指定した DLL を必要とする操作を実行しようとしました。

原因：

  • DLL ファイルはネットワーク ドライブにありますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。

  • DLL ファイルが正しくセットアップされていません。ODBC ドライバをセットアップし直してから、もう一度実行してください。


1 行の更新/削除により、1 行以上のリンク テーブルに影響がありました。固有インデックスに重複する値が含まれています。(Error 3362)

実行した更新クエリまたは削除クエリの効果が、リンクされている SQL テーブルにあるほかのレコードにも作用しました。更新および削除クエリは、1 回に 1 つのレコードのみに作用します。


IDENTITY 列を持つ SQLServer テーブルにアクセスする場合は、OpenDatabase メソッドで dbSeeChanges オプションを使用する必要があります。(Error 3622)

DAO プロパティ dbSeeChanges を使用しない場合は、サーバーの作成した ID 属性値がクライアント側に反映されません。


ODBC--サーバーの応答がありません。(Error 3234)

ODBC サーバーが正しくセットアップされていないか、または必要なネットワーク接続が確立されていません。QueryTimeout プロパティの設定値を増やしてみてください。


ODBC--呼び出しが失敗しました。(Error 3146)

ODBC 接続を使用して ODBC データ ソースのデータを操作しようとしました。このエラーは、ODBC データ ソースがネットワーク ドライブにある場合にネットワークに接続していない場合に発生します。ネットワークを利用できる状態にしてから、もう一度実行してください。


同じ名前のテーブルが複数見つかりました。'所有者.テーブル名' の形式で所有者を指定してください。(Error 3298)

リモートの ODBC データ ソースで、指定した名前のテーブルが複数見つかりました。これを解決するには、owner.table 構文を使用してアクセス先のテーブルの所有者を指定してください。


リモート データベース上で SELECT INTO ステートメントを使用して作成しようとしたフィールドが多すぎます。(Error 3185)

Microsoft Jet データベースでは 1 つのテーブルで最大 255 個までのフィールドを使用できますが、ほかのデータベースではそれよりも少ない数のフィールドしか使用できません。SELECT...INTO ステートメントで作成しようとしているテーブルには、リモート データベースで使用できる数を超えるフィールドがあります。SELECT...INTO ステートメントで作成するフィールドの数を減らしてから、もう一度実行してください。


ODBC--サーバーでサポートされていないデータ型です。(Error 3235)

ODBC サーバーは、データベース エンジンやアプリケーションのものと同じ SQL データ型をサポートしていません。このため、データをサーバーに保存できませんでした。


ODBC--リンク テーブル '<テーブル名>' での更新に失敗しました。(Error 3157)

ODBC 接続を使用して、ODBC データベースのデータを更新しようとしましたが、更新できませんでした。

原因：

  • 規則違反のため更新できませんでした。

  • ODBC データベースが読み取り専用であるか、またはそのデータベースのデータを更新する権限がありません。読み取り専用を解除するか、またはシステム管理者やデータベースの作成者から必要な権限を取得してください。

  • ODBC データベースはネットワーク ドライブにありますが、ネットワークに接続していません。ネットワークを利用できる状態にしてから、もう一度実行してください。


ODBC--範囲外のデータです。(Error 3238)

ODBC を使用して、ODBC データベースに対して読み取りまたは書き込みをしようとしましたが、データが規定の範囲を超えています。


データベースがページ ロック モードにあり、要求された行がロックされています。(Error 3751)

このエラーは、あるユーザーがデータベースを行/ページ ロック モードで開くことを指定したが、ほかのユーザーが既にそのデータベースをページ ロック専用モードで開いている場合に発生します。


このテーブルに対する規則は現在使用されているので、変更できません。(Error 3302)

このテーブルのレコードは、ほかのユーザーによって変更されているか、またはアプリケーションの別のセッションで変更しているため、現在ロックされています。テーブルのレコードがロックされている間は、そのテーブルの規則は変更できません。

別のセッションでレコードをロックしている場合は、レコードを保存してから変更を行ってください。ほかのユーザーがレコードをロックしている場合は、しばらく待ってから規則の変更を保存してください。


シンクロナイザ '<シンクロナイザ名>' も同じ File System ドロップボックス '<ドロップボックス名>' を使用しています。(Error 3630)

各シンクロナイザには、固有のファイル システム ドロップボックスが必要です。複数のシンクロナイザに対して同一のドロップボックスを指定した場合、メッセージが消えたり、変換が不完全になったりする場合があります。アプリケーションで、別のシンクロナイザ (トランスポータ) によって既に開かれているシグナル ファイルを作成することはできません。


マシン '<マシン名>' のユーザー '<ユーザー名>' によってロックされているので、保存できませんでした。(Error 3186)

原因と対策：

  • 現在、ほかのユーザーによってロックされている 2KB のデータベースのページにあるレコードを保存しようとしました。ほかのユーザーがレコードの処理を完了してから、もう一度実行してください。


レプリカのデザイン変更の履歴が、デザイン マスターの履歴と一致しません。(Error 3524)

デザイン (またはスキーマ) の変更の履歴が各レプリカで異なるために、シンクロナイザはレプリカ セットの 2 つのメンバーの同期を取ることができません。デザイン マスターが 2 つある場合、または以前に作成したバックアップからデザイン マスターをロールバックした場合に、デザインの履歴が対応しなくなる場合があります。


レコードに検索キーが見つかりませんでした。(Error 3709)

このエラーは、ISAM SEEK の実行時にインデックスに一致する値がない場合に発生します。


システム オブジェクト用に指定した名前は既に使用されています。(Error 3526)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


同じフィールドの間でリレーションシップは作成できません。(Error 3206)

フィールドとそのフィールド自身との間にリレーションシップを設定しようとしました。主テーブルまたはリレーション テーブル用に別のフィールドを選択してから、もう一度リレーションシップを設定してください。


Jet SQL Server Reconciler (MSRPJT40.DLL) をロードできません。(Error 3775)

Microsoft® Jet Subscriber と SQL Publication 間の操作を実行しようとしましたが、指定したパスで Msrpjt40.dll ファイルが見つかりませんでした。または、このファイルが登録されていません。


このマシンのほかのセッションによってロックされているので、更新できませんでした。(Error 3188)

現在、別のセッションでロックされている情報を更新しようとしました。ほかのセッションが完了するまで待つか、またはそのセッションを閉じてから、もう一度実行してください。


サブクエリでは UNION 句を使用できません。(Error 3361)

サブクエリの式では UNION 操作はできません。サブクエリでユニオン クエリを使用するには、最初にユニオン クエリを作成してそれに名前を付けて保存してから、サブクエリの式でそのクエリの名前を指定します。


ファイルの共有ロック数が制限を超えています。(Error 3052)

レコード セットで使用することができる最大のロック数を超えています。ロック数の制限は、使用しているコンピュータのシステム レジストリの MaxLocksPerFile の設定で指定しています。既定値は、9500 に設定されており、Regedit.exe ファイルを使用してレジストリを編集するか、または、SetOption メソッドを使用することで既定値を変更することができます。

いくつかの要因により、アプリケーションによっては以下のことに関して問題が発生する可能性もあります。

  • 使用できるメモリ容量

  • レコード セットの行のサイズ

  • ネットワーク オペレーティング システムの制限


排他書き込みモードでログ ファイル '<ファイル名>' を開こうとしたときに、共有違反が発生しました。(Error 3475)

ほかのすべてのアプリケーションのログ ファイルを閉じてください


VIEWS には、単純な SELECT クエリしか使用できません。(Error 3766)

このエラーは、SQL DLL からビューを作成しようとした場合に発生します。また、ビュー定義の一部としてパラメータまたは従属選択ステートメントを含めようとした場合に発生します。


メイン クエリの FROM 句の予約語 EXISTS を使用しないフィールドを複数返すサブクエリを作成しました。サブクエリの SELECT ステートメントを変更し、1 つのフィールドだけを指定してください。(Error 3306)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


このサブクエリでは 1 つのレコードしか返せません。(Error 3354)

このサブクエリでは複数のレコードを返すことはできません。サブクエリの SELECT ステートメントを修正し、レコードを 1 つのみ要求するようにしてください。


Jet ソート DLL を正しくロードできませんでした。(Error 3757)

Microsoft® Jet データベース エンジンでは、比較や索引付けを実行するために Mswstr10.dll と Mswdat10.dll の 2 つのソート用の DLL が利用されます。これらの DLL が、DLL を読み込むためのパスに存在することを確認してください。

別のアプリケーションによってこれらの DLL が削除または破損された場合は、これらの DLL をもう一度インストールしてください。


ソース コントロール データベースはレプリケート可能にすることはできません。(Error 3638)

レプリケートしようとしているデータベースは、レプリケーションをサポートしていないデータベースのプログラムで制御されています。データベースをレプリケート可能にするには、ソース コントロール プログラムで制御されていない設定にする必要があります。


エクスポートしているデータが SCHEMA.INI ファイルで設定されている形式と矛盾しています。(Error 3438)

エクスポートしようとしたデータの形式が、Schema.ini ファイルに指定している形式と一致しているかどうかを確認してください。


テーブル '<テーブル名>' は、マシン '<マシン名>' のユーザー '<ユーザー名>' によって使用されているので、ロックできませんでした。(Error 3212)

テーブルは現在ほかのユーザーが使用しているため、ロックできません。ほかのユーザーのトランザクションが完了してから、もう一度実行してください。


テーブル '<テーブル名>' は、マシン '<マシン名>' のユーザー '<ユーザー名>' によって排他ロックされています。(Error 3189)

指定したテーブルはほかのユーザーによって排他的ロックされているため、アクセスできません。そのユーザーにロックの解除を依頼するか、またはそのユーザーがロックを解除するまで待ってから、もう一度実行してください。


ReturnsRecords プロパティが True に設定されているパススルー クエリから、レコードが返されませんでした。(Error 3325)

ReturnsRecords プロパティに True が設定されていますが、パススルー クエリはレコードを 1 つも返しませんでした。レコードを返さないパススルー クエリでは、ReturnsRecords プロパティに False を設定してください。


SQL 構文が正しくありません。正しいトークンは ACTION です。(Error 3762)

このエラーは、CREATE TABLE 構文または ALTER TABLE ALTER COLUMN 構文を使用して参照整合性制約を定義する場合に発生します。また、NO キーワードの後に ACTION キーワードがない場合に発生します。たとえば、次の場合に BOLD ON キーワードを省略すると、このエラーになります。

CREATE TABLE OrderDetail (OrderId LONG CONSTRAINT fkOrdersOrderId REFERENCES Orders (OrderId) ON UPDATE CASCADE ON DELETE NO ACTION, LineItem LONG, ProductID LONG CONSTRAINT fkProductsProductId REFERENCES Products (ProductId), Quantity LONG);


SQL 構文が正しくありません。正しいトークンは AS です。(Error 3728)

このエラーは、SQL DDL によりビューまたはプロシージャを定義または作成する場合に発生します。また、次の構文により発生することもあります。

CREATE VIEW viewname SELECT?

このエラーを回避するには、次のように構文を変更します。

CREATE VIEW viewname AS SELECT?


SQL ステートメントの後に文字が見つかりました。(Error 3142)

SQL ステートメントで、セミコロン (;) の後にデータが入力されています。たとえば、"SELECT * FROM table1; garbage" を実行すると、エラーになります。このエラーを回避するには、セミコロン (;) 以後の文字をすべて削除してください。


SQL 構文が正しくありません。WITH とその後に COMPRESSION が必要です。(Error 3723)

このエラーは、CREATE TABLE または ALTER TABLE ALTER COLUMN 構文を使用する場合に発生します。また、列のデータ型の NATIONAL CHARACTER シノニムのいずれかを参照し、WITH キーワードに続けて COMPRESSION キーワードを使用しない場合に発生します。次に有効な SQL ステートメントを示します。

CREATE TABLE foo (foo NCHAR WITH COMP);

また、次の SQL ステートメントはエラーを返します。

CREATE TABLE foo (foo NCHAR WITH);


SQL 構文が正しくありません。制約名が必要です。(Error 3721)

SQL DDL ステートメントから参照整合性を定義する場合に、CONSTRAINT キーワードを使用するときは制約に名前を付ける必要があります。制約名が必要ない場合は、CONSTRAINT キーワードは使用しません。次に、このエラーの例を示します。

CREATE TABLE Customers (CLstNm TEXT(50), CFrstNm TEXT(25), CONSTRAINT PRIMARY KEY (CFrstNm, CLstNm));

このエラーを防ぐには、CONSTRAINT キーワードの後に名前を指定します。

CREATE TABLE Customers (CLstNm TEXT(50), CFrstNm TEXT(25), CONSTRAINT pkCustomers PRIMARY KEY (CFrstNm, CLstNm));

または CONSTRAINT キーワードを使用しません。

CREATE TABLE Customers (CLstNm TEXT(50), CFrstNm TEXT(25), PRIMARY KEY (CFrstNm, CLstNm));


SQL 構文が正しくありません。正しいトークンは Database です。(Error 3785)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


SQL 構文が正しくありません。CREATEDB または CONNECT などのデータベース権限が必要です。(Error 3786)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


SQL 構文が正しくありません。正しいトークンは DEFAULT です。(Error 3722)

このエラーは、ALTER TABLE ALTER COLUMN 構文を使用する場合に発生します。USER または NULL キーワード、あるいはリテラルのいずれかの後に DEFAULT キーワードを続けないで使用すると、このエラーになります。


DELETE ステートメントの構文エラーです。(Error 3130)

無効な DELETE ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


SQL 構文が正しくありません。正しいトークンは 'CASCADE'、'SET NULL'、または 'NO ACTION' です。(Error 3725)

このエラーは、CREATE TABLE ステートメントまたは ALTER TABLE ALTER COLUMN ステートメントで参照整合性を定義する場合に発生します。また、UPDATE または DELETE キーワードを使用し、そのキーワードの後に CASCADE、SET NULL、NO ACTION のいずれかのキーワードがない場合に発生します。


SQL 構文が正しくありません。正しいトークンは NULL です。(Error 3726)

このエラーは、インデックスに関連付けられた DDL ステートメントを実行する場合に発生します。また、CREATE INDEX、WITH PRIMARY、または IGNORE キーワードの後に NULL キーワードがない場合に発生することもあります。


FROM 句の構文エラーです。(Error 3131)

無効な FROM 句のある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


GROUP BY 句の構文エラーです。(Error 3132)

無効な GROUP BY 句のある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


HAVING 句の構文エラーです。(Error 3133)

無効な HAVING 句のある SQL ステートメントを実行しようとしました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


INSERT INTO ステートメントの構文エラーです。(Error 3134)

無効な INSERT INTO ステートメントのある SQL ステートメントを実行しようとしました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


パススルー クエリには、1 文字以上指定してください。(Error 3359)

パススルー クエリの SQL ステートメントには少なくとも 1 文字以上の文字が必要です。


JOIN 操作の構文エラーです。(Error 3135)

無効な結合操作のある SQL ステートメントを入力しました。内部結合、外部結合、自己結合の可能性があります。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


LEVEL 句が間違っている予約語や引数を含んでいるか、区切り記号が正しくありません。(Error 3136)

無効な予約語のある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


リンク ODBC テーブル間にリレーションシップを設定することはできません。(Error 3613)

Microsoft Jet データベース エンジンは、ODBC データ ソーステーブルのリンク テーブル間でリレーションシップを作成することはできません。


SQL ステートメントの最後には、セミコロン (;) が必要です。(Error 3137)

SQL ステートメントの後に、無効なトークンが追加されています。たとえば、"SELECT col1 FROM table1 garbage" を実行すると、このエラーが返されます。"SELECT col1 FROM table1; garbage" は有効なステートメントです。


SQL 構文が正しくありません。使用できるのは、1 つの更新規則または 1 つの削除規則です。(Error 3727)

このエラーは、SQL DDL により参照整合性を定義する場合に発生します。また、SET キーワードの後に NULL または DEFAULT がない場合に発生します。


ORDER BY 句の構文エラーです。(Error 3138)

無効な ORDER BY 句のある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


WITH OWNERACCESS OPTION 宣言の構文エラーです。(Error 3257)

原因と対策：

  • WITH OWNERACCESS OPTION 宣言が不完全であるか、または "OWNER" と "ACCESS" の間にスペースがあります。

  • SQL ステートメントの中の予期しない位置、または禁止されている位置に宣言が記述されています。たとえば次の SQL ステートメントは無効です。

    SELECT * WITH OWNERACCESS OPTION FROM [My Table];

    WITH OWNERACCESS OPTION 宣言は、SQL ステートメントの最後 (通常は ORDER BY 句の後) に記述します。たとえば、次のように記述します。

    SELECT * FROM [My Table] WITH OWNERACCESS OPTION;


PARAMETER 句の構文エラーです。(Error 3139)

無効な PARAMETERS 宣言のある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


SQL 構文が正しくありません。正しいトークンは Privileges です。(Error 3689)

このエラーは、GRANT または REVOKE 予約語を使用する場合に発生します。特権が指定されていません。有効な特権は、SELECT、UPDATE、DELETE、INSERT などです。


PROCEDURE 句の構文エラーです。(Error 3140)

無効な PROCEDURE 句のある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


SQL 構文が正しくありません。正しいトークンは SELECT です。(Error 3729)

このエラーは、SQL DDL からビューを作成しようとした場合に発生します。次の構文はこのエラーになります。

CREATE VIEW viewname AS

このエラーを回避するには、AS キーワードの後に有効な SELECT ステートメントを使用します。


SELECT ステートメントが間違っている予約語や引数を含んでいるか、区切り記号が正しくありません。(Error 3141)

無効な SELECT ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


SQL ステートメントが正しくありません。'DELETE'、'INSERT'、'PROCEDURE'、'SELECT'、または 'UPDATE' を使用してください。(Error 3129)

このステートメントは指定した予約語で始まっていないため、SQL ステートメントとして認識されませんでした。


TRANSFORM ステートメントの構文エラーです。(Error 3143)

無効な TRANSFORM ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


ユニオン クエリの構文エラーです。(Error 3319)

ユニオン クエリ の SQL ステートメントの中に、構文エラーがあります。

原因：

  • 予約語または引数が正しく入力されていません。

  • 必要な予約語または引数が入力されていません。

  • 区切り記号に誤りがあります。


SQL 構文が正しくありません。正しいトークンは UPDATE または DELETE です。(Error 3724)

このエラーは、CREATE TABLE ステートメントまたは ALTER TABLE ALTER COLUMN ステートメントで参照整合性を定義する場合に発生します。また、CASCADE キーワードを使用し、そのキーワードの前に UPDATE または DELETE キーワードがない場合に発生します。


UPDATE ステートメントの構文エラーです。(Error 3144)

無効な UPDATE ステートメントのある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


SQL 構文が正しくありません。ビュー名が必要です。(Error 3780)

このエラーは、SQL DDL の CREATE VIEW または DROP VIEW 構文を使用してビューを作成または削除しようとした場合に発生します。また、有効な名前を指定しない場合に発生します。たとえば、次のステートメントはこのエラーになります。

CREATE VIEW AS SELECT * FROM table1


WHERE 句の構文エラーです。(Error 3145)

無効な WHERE 句のある SQL ステートメントを入力しました。

原因：

  • 予約語または引数名を正しく入力していないか、または指定していません。

  • 区切り記号に誤りがあります。


クロス集計クエリに '*' を使用することはできません。(Error 3123)

フィールドのグループ化や集計を行うクロス集計クエリで、アスタリスク (*) を使用してフィールドを選択しようとしました。特定のフィールドを選択してから、もう一度実行してください。


'*' で選択したフィールドはグループ化できません。(Error 3121)

アスタリスク (*) で選択したすべてのテーブルのすべてのフィールドについてグループ化または集計を行う SELECT ステートメントを実行しようとしました。

原因：

  • 作成した SQL ステートメントの中に、アスタリスク (*) で選択したフィールドを参照する集計関数または GROUP BY 句があります。たとえば、次のような SQL ステートメントを入力するとこのエラーが発生します。

    SELECT * FROM Orders GROUP BY ShipVia;


マシン '<マシン名>' のユーザー '<ユーザー名>' がデータベースを開けない状態、またはロックできない状態にしています。(Error 3734)

このエラーは、新しいパッシブ シャットダウン/接続制御を使用する場合に発生します。このエラーは、ほかのユーザーがデータベースを開けないようにするモードでデータベースが設定されていることを示します。


認識できないユーザーがデータベースを開けない状態、またはロックできない状態にしています。(Error 3733)

このエラーは、新しいパッシブ シャットダウン/接続制御を使用する場合に発生します。このエラーは、ほかのユーザーがデータベースを開けないようにするモードでデータベースが設定されていることを示します。このエラーは error #3734 と関係し、Microsoft® Jet が、どのユーザーがパッシブ シャットダウン/接続制御を起動したのかを判断できない場合に表示されます。


オブジェクト <オブジェクト名> はストアド プロシージャではありません。(Error 3750)

このエラーは、EXECUTE キーワードを使用し、データベースにないプロシージャまたはビューの名前、あるいはベース テーブルの名前を渡した場合に発生します。


データを交換する適切なレプリカがありません。(Error 3684)

指定した HTTP アドレスと同期させる適切なレプリカがありません


レプリケートされていないデータベースと同期することはできません。データベース '<データベース名>' はデザイン マスターまたはレプリカではありません。(Error 3605)

レプリケートされたデータベースとレプリケート不可能なデータベースとの間で同期を取ろうとしているか、またはレプリケート不可能な 2 つのデータベース間で同期を取ろうとしています。レプリケートされた同じデータベースから作成されたレプリカ間でのみ、同期を取ることができます。

いずれかのデータベースが既にレプリケート可能にされている場合は、そのデータベースを使用して 2 つ目のデータベース レプリカを作成してください。

いずれのデータベースもレプリケート可能にされていない場合は、いずれかのデータベースを選択してレプリカ セット用のデザイン マスターのレプリカ セットとして使用してください。これには、Microsoft Access® を使用してそのデータベースを開き、[ツール] メニューの [レプリケーション] をポイントし、[レプリカの作成] をクリックします。Microsoft Access が利用できない場合は、Microsoft Windows® 95 のブリーフケースを使用し、データベースをブリーフケースまでドラッグしてドロップし、レプリカを作成してください。元の 2 つのデータベースのうち 2 つ目のデータベースをレプリケート可能にしてから 2 つのデータベースの同期を取らないでください。同期処理を正常に行うためには、2 つ目のデータベースは最初のデータベースのレプリカである必要があります。


シンクロナイザ '<シンクロナイザ名>' も同じ File System ドロップボックス '<ドロップボックス名>' を使用しています。(Error 3629)

各シンクロナイザには、固有のファイル システム ドロップボックスが必要です。複数のシンクロナイザに対して、同じ場所にあるドロップボックスを使用すると、メッセージが消えたり、変換が不完全になります。

シグナル ファイルを作成できません。このファイルは、別のシンクロナイザ (トランスポータ) によって既に開かれています。


パラメータ句の構文エラーです。パラメータが存在し、入力した値が正しいことを確認してください。(Error 3746)

このエラーは、次の場合に発生します。

  • パラメータ化クエリ/プロシージャで無効な parameterdadefParameter 型を使用した。

  • プロシージャおよび名前付きパラメータの前に @ 記号がない。

  • @ 記号の後に渡したパラメータ名が無効である。

  • パラメータの後に等号 (=) がない。

  • 適切なエスケープ文字を使用しないで予約語をパラメータとして使用した。


Transaction ステートメントの構文エラーです。TRANSACTION または WORK を使用するか、何も入力しないでください。(Error 3708)

(DAO や ADO などのオブジェクト モデルではなく) Microsoft® Jet により排他的にトランザクションを使用する場合は、BEGIN/ROLLBACK TRANSACTION、WORK または指定なしの構文を使用してください。BEGIN または ROLLBACK の後に文字がある場合は、このエラーが発生します。


Microsoft Jet データベース エンジンのワークグループ情報ファイルを開くことができません。(Error 3358)

セキュリティ関連の作業を行おうとしましたが、作業に必要なワークグループ情報ファイル (通常は System.mdw) が見つかりません。


Microsoft Jet データベース エンジンはコンピュータのシステム クロックを見つけることができませんでした。(Error 3515)

Microsoft Jet データベース エンジンは、コンピュータのシステム クロックを読み取ることができませんでした。Microsoft Jet データベース エンジンは、一部の内部処理を実行する場合にコンピュータのシステム クロックを使用します。コンピュータを再起動してください。


プロセスが終了した後も、このプロセスが使用したシステム オブジェクトが存在します。(Error 3533)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


レプリケーション システム テーブル '<テーブル名>' は既に使用されているため、開くことができません。(Error 3581)

この処理を完了するために必要なシステム テーブルは、既に使用されています。しばらくしてから、もう一度実行してください。


ワークシートのセルを削除できません。(Error 3435)

ワークシートの指定した範囲のセルのデータを削除できません。セルに数式が含まれているか、またはセルが保護されている可能性があります。


テーブル <テーブル名> は既に存在しています。(Error 3010)

このデータベースに既に存在しているテーブル名を使用してテーブルを作成しようとしたか、または既存のテーブル名に変更をしようとしました。ほかのテーブル名を使用してください。

マルチユーザー データベース環境では、テーブルを削除する場合、ほかのユーザーがそれと同じ名前のテーブルを作成した後に、削除するテーブルをロールバックしようとするとこのエラーが発生します。削除したテーブルをロールバックするには、先にそのユーザーが新しいテーブルを削除するか、またはテーブル名を変更する必要があります。その後、もう一度ロールバック操作を実行してください。


テーブル <テーブル名> はほかのユーザーが排他的に開いているか、既にユーザー インターフェイスを介して開いているので、プログラムによって操作することはできません。(Error 3008)

使用しようとしたテーブルは、現在ほかのユーザーが排他モードで開いています。または、アプリケーションのユーザー インターフェイスを介して開いているテーブルを、プログラムが操作しようとしました。正しい条件を設定してから、もう一度実行してください。


指定範囲を広げることはできません。(Error 3434)

Microsoft® Excel Version 5.0 の名前の付いた範囲に行を追加しようとしましたが、空でないセルが見つかりました。空でないセルを追加の操作によって上書きすることはできません。


テーブルをロックできませんでした。(Error 3262)

テーブルを開く場合にそのテーブルをロックしようとしましたが、既に使用中のためロックできませんでした。しばらくしてから、もう一度実行してください。


テーブル '<テーブル名>' は現在ほかのユーザーまたはプロセスで使用されているので、ロックできませんでした。(Error 3211)

現在、そのテーブルはほかのユーザーによって使用されているため、ロックできません。処理が終ってから、もう一度実行してください。


テーブル '<テーブル名>' はマシン '<マシン名>' のユーザー '<ユーザー名>' によって排他的にロックされています。(Error 3261)

テーブルは、現在ほかのユーザーが排他モードで開いています。ほかのユーザーがテーブルの操作を完了してから、もう一度実行してください。


この操作は、データを含んでいるテーブルには実行できません。(Error 3282)

既にデータのあるリンク テーブルにフィールドを追加したり、インデックスを追加することはできません。いったんデータが設定されたテーブルは、そのデザインやインデックスを変更することはできなくなります。別のデザインで新しいテーブルを作成し、アクション クエリを使用してそのテーブルにデータを転送してください。


テーブルの構造を変更できません。ほかのユーザーがテーブルを開いています。(Error 3422)

現在、ほかのユーザーがテーブルを開いているため、Microsoft Jet データベース エンジンはテーブルの構造を変更できませんでした。ほかのユーザーがテーブルを閉じてから、もう一度変更を行ってください。


このテーブルは開いていません。(Error 3160)

開いていないテーブルに対して処理を実行しようとしました。テーブルを開いてから、もう一度実行してください。


テーブル '<テーブル名>' を排他的に開くことができなかったので、レプリケート可能にできませんでした。(Error 3767)

レプリケートしたいテーブルのインスタンスをすべて閉じてから、もう一度実行してください。


FROM 句でテーブル名 <テーブル名> を繰り返すことはできません。(Error 3074)

FROM 句でテーブル名を繰り返し使用することはできません。余分なテーブル名を削除するか、または別名を使用してください。テーブルを自己結合する場合は、別名を使用して 2 番目のテーブル参照を変更してください。


クライアント タスクが多すぎます。(Error 3053)

同時に実行している Microsoft® Visual Basic® または Microsoft Visual Basic アプリケーションの数が多すぎます。1 つまたは複数のアプリケーションを終了してください。


環境変数 TEMP で指定されているフォルダの読み込みまたは書き込み中に、ディスク I/O エラーが発生しました。(Error 3572)

使用しているコンピュータの TEMP フォルダにアクセスしようとしたときに、障害が発生しました。TEMP フォルダのパスが正しく設定されていることを確認してください。


テンポラリ ファイル用の空き容量が不足しています。(Error 3183)

操作の実行に必要なテンポラリ ディスクの空き容量が不足しています。テンポラリ ディスクの位置は、MS-DOS システムの起動時に設定される TEMP 環境変数に基づいて決まります。

たとえば、テンポラリ ディスクの空き容量よりも大きいテンポラリ ファイルを作成するクエリを作成しようとした場合に、このエラーが発生します。一度にアクセスするデータの量を少なくしてテンポラリ ファイルのサイズを小さくするか、またはテンポラリ ディスクのサイズを大きくしてください。

次のいずれかの方法で、テンポラリ ディスクの空き容量を増やすことができます。

  • 選択するレコードを減らします。ダイナセット タイプ、前方スクロール タイプ、およびスナップショット タイプの Recordset オブジェクトは、キーとデータをテンポラリ ディスクに記録します。

  • テンポラリ ディスクとして別のドライブを選択します。

  • テンポラリ ディスクが RAM ディスクの場合は、RAM の容量を増やすか、またはハード ディスクに変更します。

  • データベースからデータや不要なオブジェクト (テーブル、クエリ、レポート、フォーム、マクロ、モジュール) を削除して、空き容量を確保します。

  • データベースを最適化して削除済みのレコードを取り除き、空き容量を確保します。

  • さらに空き容量が必要な場合は、未使用のファイルをディスクから削除してください。


要求したデータの量に対してフェッチ バッファが小さすぎます。(Error 3640)

GetRows メソッドまたは GetRowsEx メソッドを実行しようとしましたが、フェッチ バッファが小さすぎるため指定した行を格納できません。


言語固有のコード ページが指定されていないか、見つかりません。(Error 3649)

データベースを開こうとしていますが、このデータベースは、使用しているコンピュータにインストールされていない言語で作成されています。データベースを作成する場合には、データベースで使用する言語を指定して、この言語をシステムにインストールする必要があります。DAO オブジェクトを使用してデータベースを作成した場合には、CreateDatabase メソッドのローカルの引数により言語は指定されます。Microsoft® Access を使用してデータベースを作成した場合には、[オプション] ダイアログ ボックスの [全般] タブにある、 [新規データベースの並び順序] で言語を指定することができます。[オプション] ダイアログ ボックスは、[ツール] メニューの [オプション] をクリックすると使用できます。

使用する言語は、コントロール パネルの [地域] アイコンをダブルクリックし、表示される [地域のプロパティ] ダイアログ ボックスで設定して、システムに追加することができます。


レコードセットには、要求されたレコードより少ないレコードしかありません。(Error 3641)

Recordset の終端に達しました。


列の長さの合計より短い長さが指定されました。(Error 3646)

行の長さのパラメータで、列の結合に必要なだけのスペースを指定していません。


Microsoft Jet データベース エンジンで、入力検査の式にあるフィールド '<フィールド名>' またはテーブル '<テーブル名>' の既定値が認識されません。(Error 3344)

式の中のフィールド参照に誤りがあるか、または存在しないフィールドを参照しています。フィールド名が有効かどうか、またフィールド名が正しいかどうかを確認してください。


<エラー テキスト> のために、DefaultValue プロパティに使用している式は無効です。有効な式を使用して、このプロパティを設定してください。(Error 3406)

DefaultValue プロパティに、無効な式を設定しようとしています。有効な式を設定してください。


入力規則のエラー '<エラー テキスト>'。(Error 3405)

エラー メッセージに示された理由により、式を正しく評価できません。たとえば、"型が一致しません" というエラーが表示された場合は、プロパティの設定がフィールドに定義されたデータ型と一致していません。


テーブル レベル入力規則の <エラー>。(Error 3320)

テーブル レベルでの入力規則の式、またはその既定値の式に構文エラーなどのエラーがあります。


'<名前>' に設定されている入力規則または既定値の関数 '<関数名>' が見つかりません。(Error 3388)

参照している関数は、関数名が無効または正しく入力されていない未定義の関数であるか、または ValidationRule プロパティや DefaultValue プロパティによって使用が禁止されている関数です。使用が禁止されている関数には、ユーザー定義関数や SQL 集計関数などがあります。


指定された入力規則は、このフィールドには設定できません。(Error 3313)

入力規則プロパティが使用できないオートナンバー型 (AutoNumber) フィールドや OLE オブジェクト型 (OLE Object) フィールドなどのフィールドに対して入力規則プロパティを設定しようとしました。別のフィールドを使用してデータの入力検査を行ってください。テーブルにまだデータを追加していない場合は、フィールドのデータ型を定義し直してください。


システム テーブルとリンク テーブルには、入力規則と既定値を設定できません。(Error 3312)

アプリケーションで使用できないテーブルやフィールドなどのオブジェクトの DefaultValue プロパティ、ValidationRule プロパティ、ValidationText プロパティ、または Required プロパティを設定しようとしています。たとえば、システム オブジェクトにこれらのプロパティを設定しようとしています。


フィールド '<フィールド名>' には、長さ 0 の文字列を格納できません。(Error 3315)

このフィールドの AllowZeroLength プロパティには False が設定されているため、長さ 0 の文字列は入力できません。別の値を入力してください。


フィールドに必要なプロパティが True に設定されているため、このフィールド '<フィールド名>' には Null 値は挿入できません。値を入力してください。(Error 3314)

このフィールドの Required プロパティには True が設定されているため、Null 値は入力できません。別の値を入力してください。


<テーブル レベルの入力規則のメッセージ>。(Error 3316)

テーブル レベルの入力規則に従っていません。


'<フィールド名>' に設定されている入力規則 '<規則>' に違反する値が 1 つ以上あります。このフィールドの式で使用できる値を入力してください。(Error 3317)

このフィールドの ValidationRule プロパティには、フィールドに入力できる値を制限する式が使用されています。式によって禁止されていない値を入力してください。


TLV 違反です。(Error 3716)

このレコードには、テーブル レベル入力規則に違反するフィールド値が含まれています。入力規則に反するフィールド値を更新してこの競合レコードを再発行するか、この競合レコードを削除してください。


アクティブ ユーザーが多すぎます。(Error 3239)

マルチユーザー環境では、Microsoft Jet データベースは 255 人までのユーザーの同時操作をサポートしています。ほかのユーザーがシステムの使用を終えてから、もう一度実行してください。


多くのアプリケーションが実行されているので、シンクロナイザを初期化できません。(Error 3538)

システム リソース不足のため、開いているすべてのアプリケーションを実行したままでシンクロナイザを起動することはできません。1 つまたは複数のアプリケーションを終了してから、もう一度実行してください。


定義されているフィールドが多すぎます。(Error 3190)

255 を超えるフィールドを対象とする操作を行おうとしました。フィールド数を減らしてから、もう一度実行してください。


実行している高速検索のセッション数が多すぎます。(Error 3408)

DAO の Find メソッドは、1 つのテーブルまたはレコードセットに対して一度しか起動できません。


定義されているインデックスが多すぎるので、インデックスを作成できませんでした。(Error 3039)

このテーブルにこれ以上インデックスを作成することはできません。既存のインデックスを削除してから、新しいインデックスを作成してください。テーブルに作成できるインデックスの数の上限は 32 です。


テーブル <テーブル名> にインデックスが多すぎるため、この操作を実行できませんでした。インデックスをいくつか削除して、再度実行してください。この操作を実行できませんでした。(Error 3626)

Microsoft Jet データベースのテーブルは、最大 32 個までのインデックスを含むことができます。このテーブルのインデックスに、これ以上インデックスを追加することはできません。また、データベースを最適化するには、新しいインデックスを作成する必要があるため、このテーブルのデータベースを最適化することもできません。

このテーブルから 1 つまたは複数のインデックスを削除してから、もう一度実行してください。


1 つのインデックスで使用できるフィールド数は 10 以下です。(Error 3277)

11 個以上のフィールドを持つインデックスを定義しようとしました。フィールドの数を 10 個以下にしてください。


メモ型または OLE オブジェクト型のフィールドが多すぎます。(Error 3054)

メモ型、OLE オブジェクト型、またはハイパーリンク オブジェクト型のフィールドが多すぎます。(Error 3054)

Btrieve の処理を実行しようとしましたが、メモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールドが多すぎます。メモ型 (Memo) または OLE オブジェクト型 (OLE Object) のフィールドの数を減らしてから、もう一度実行してください。


これ以上データベースを開くことはできません。(Error 3048)

一度に開くことのできるデータベースの最大数に達しました。1 つまたは複数のデータベースを閉じてから、もう一度実行してください。


これ以上ファイルを開くことはできません。(Error 3025)

一度に開くことのできるファイルの最大数に達しています。1 つまたは複数のファイルを閉じてから、もう一度実行してください。


これ以上テーブルを開くことはできません。(Error 3014)

一度に開くことのできるテーブルの最大数に達しています。1 つまたは複数のテーブルを閉じてから、もう一度実行してください。


アクティブなセッションが多すぎるので、セッションを開始できませんでした。(Error 3198)

新しいセッションを開始する操作を行おうとしましたが、アクティブ セッションの数が多すぎます。1 つまたは複数のセッションが完了するまで待ってから、もう一度実行してください。


DLL を読み込むことができません。(Error 3462)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


シンクロナイザは既に実行されています。(Error 3544)

シンクロナイザのインスタンスは、一度に 1 つのみ実行できます。2 つ目のシンクロナイザを起動せずに、このコンピュータで現在動作中のシンクロナイザを使用してください。


シンクロナイザはファイルを削除できませんでした。(Error 3568)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


シンクロナイザがシンクロナイザ ログを開くことができません。(Error 3506)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


シンクロナイザはシステム イベントを検索しましたが、クライアントに報告するようなシステム イベントを見つけることができませんでした。(Error 3534)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


シンクロナイザを初期化できませんでした。(Error 3532)

シンクロナイザを起動できません。コンピュータをシャットダウンしてから再起動してください。その後も引き続きこのエラーが発生する場合は、シンクロナイザの再設定を行ってください。

シンクロナイザの設定を行うには、次の操作を行ってください。

  1. Microsoft レプリケーション マネージャを起動します。

  2. [ツール] メニューの [レプリケーション マネージャの構成] をクリックします。

  3. ウィザードの指示に従ってください。


シンクロナイザがセットアップされていません。(Error 3543)

使用しているコンピュータでシンクロナイザがまだセットアップされていません。

シンクロナイザの設定を行うには、次の操作を行ってください。

  1. Microsoft レプリケーション マネージャを起動します。

  2. [ツール] メニューの [レプリケーション マネージャの構成] をクリックします。

  3. ウィザードの指示に従ってください。

サードパーティー製のアプリケーションを使用している場合は、アプリケーションをサポートしている開発元からシンクロナイザのセットアップ ディスクを入手してください。


シンクロナイザは既にクライアントを起動しています。(Error 3530)

シンクロナイザの 2 つ目のクライアントを起動しようとしていますが、シンクロナイザは一度に 1 つのクライアントしか起動できません。既にシンクロナイザを使用しているアプリケーションまたはユーザーを調べて、そのアプリケーションを閉じてください。


シンクロナイザを正しくシャット ダウンできなかったので、アクティブのままです。(Error 3541)

シンクロナイザの終了をプログラムで要求しましたが、その処理は正常に完了しませんでした。シンクロナイザはバックグラウンドで引き続き動作しています。

シンクロナイザを終了するには、次の操作を行ってください。

  1. Ctrl + Alt + Del キーを押して [プログラムの強制終了] ダイアログ ボックスを表示します。

  2. [シンクロナイザ] をクリックします。

  3. [終了] をクリックします。


メッセージを送信できませんでした。(Error 3519)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


ネストされているトランザクションが多すぎるので、トランザクションを開始できませんでした。(Error 3003)

ネストが 5 レベルを超えるトランザクションを開始しようとしました。新しいトランザクションを開始する前に、CommitTrans または Rollback メソッドを使用して、カレント トランザクションを保存またはロールバックしてください。


抽出条件でデータ型が一致しません。(Error 3464)

Find 系メソッドの抽出条件式で、比較する値のデータ型がフィールドのデータ型と一致していません。


シンクロナイザのスケジュールを設定できません。(Error 3497)

スケジュールの設定に関する内部的な問題が発生しました。もう一度実行してください。


同じ名前 (<テーブル名>) で複数のテーブルを結合することはできません。(Error 3081)

同じ名前の複数のテーブルを結合しようとしました。別のテーブルを選択するか、重複するテーブルの名前を変更するか、または別名を使用してください。テーブルを自己結合する場合は、別名を使用して 2 番目のテーブル参照を変更してください。


外部データベース ドライバ (<エラー番号>) で予期しないエラーが発生しました。(Error 3275)

外部データベースのドライバがエラーを返しました。使用している外部データベースがサポートしていない操作を実行しようとすると、このエラーが発生します。


一意なキーの規則に違反しています。(Error 3715)

このレコードと別のレコードのキーの値が同じです。キーの値は、レコードに固有である必要があります。この競合レコードまたは優先するレコードのキー値を変更してこのレコードを再発行するか、この競合レコードを削除してください。


未定義の名前です。(Error 2424)

入力した式には、認識できないフィールドまたはプロパティの名前が含まれています。オブジェクトが存在しているかどうか、または入力した式が正しいかどうかを確認してください。


部分フィルタの式に未定義の関数が含まれています。(Error 3589)

使用している関数の名前が正しいかどうかを確認してください。また、フィルタ式ではすべての関数が有効であるとは限りません。


ReplicaFilter プロパティの式が正しくありません。(Error 3587)

ReplicaFilter 文字列に無効な文字が含まれています。構文に誤りがないかどうか、または必要な文字が欠けていないかどうかを確認してください。


未定義の関数名です。(Error 2425)

入力した式には、認識できない関数名が含まれています。関数が存在しているかどうか、または入力した式が正しいかどうかを確認してください。


構文エラー (Error 2433)

コマンドの綴りや区切り記号が正しくありません。必要な演算子がないか、指定した演算子が存在しない可能性があります。


インポートしたテーブルの先頭行からフィールド名を解析できませんでした。(Error 3245)

データの先頭行に無効なフィールド名があります。たとえば次の例のように、ダブル クォーテーション (") の付いている文字列と付いていない文字列が 1 つのフィールド名の中で使用されています。

"Name", Date, "ID " Number, Phone" Number"

先頭の 2 つのフィールドは有効ですが、3 番目と 4 番目のフィールドはダブル クォーテーションの外側にスペース以外の文字があるため無効になります。

インポート テーブルでダブル クォーテーションを正しく指定しているかどうかを確認してから、もう一度インポートしてください。


更新/更新の競合。ほかのレプリカもこのレコードを更新しました。このレコードには、競合がなくなりました。更新データを再発行するか、この競合データを削除してください。(Error 3713)

このレコードには、ほかのレプリカとの競合で失われたフィールド値が含まれます。この競合レコードを再発行するか、またはこの競合レコードを削除してください。


更新/削除の競合。この更新されたレコードは、ほかのレプリカによって削除されました。この競合レコードを再度挿入するか、削除してください。(Error 3736)

あるレプリカではレコードを削除し、別のレプリカではレコードを更新する場合、これらの 2 つのレプリカが同期するときに発生する競合では、削除レコードが優先します。更新レコードは競合テーブルに記録されます。競合の初期解決を逆にするには、競合レコードを再追加します。現在の解決を受け入れるには、競合レコードを削除します。


この ISAM では、リンク テーブル内のデータを更新することはできません。(Error 3616)

現在使用している組み込み可能な ISAM では、外部テーブルのレコードの更新が禁止されています。ただし、新規レコードの追加は可能です。


更新/RI 競合です。(Error 3718)

別のレプリカでレコードの主キーが更新されたので、レコードの参照は拒否されました。参照整合性制約を満たす新しい主キー レコードを作成して、更新を再発行するか、有効な主キーの値と一致するように、この競合レコードの外部キーの値を変更して、更新を再発行するか、またはこの競合レコードを削除してください。


使用できるのは、Version 1.0 形式だけです。(Error 3334)

現バージョンではサポートされていない機能を使用しようとしました。


フィールド '<フィールド名>' とキーが一致しているレコードをテーブル '<テーブル名>' で探すことができません。(Error 3101)

一対多リレーションシップで、"多" 側に入力したデータに一致するレコードが "一" 側にありません。たとえば、[得意先] テーブルと [売上] テーブルを "得意先コード" フィールドで結合してから、[得意先] テーブルに存在しない得意先コードを使用して売上データを追加すると、このエラーが発生します。


VIEW にはパラメータを使用できません。(Error 3730)

このエラーは、SQL DDL からビューを作成しようとした場合に発生します。CREATE view ステートメントの SELECT ステートメント部分がパラメータを含む場合に、このエラーが返されます。このエラーを解決するには、代わりに CREATE PROCEDURE ステートメントを使用します。


部分レプリカに適用される規則に違反するため、部分レプリカでは列を設定できません。(Error 3571)

部分レプリカの主キーは、参照先がない限り変更できません。


部分レプリカに適用される規則に違反します。(Error 3590)

部分レプリカのテーブルで、別のテーブルによって参照されている列を更新することはできません。ほとんどの場合、このエラーは、更新と参照整合性制約の間の競合が原因で発生します。この場合、関連するテーブルの情報が部分レプリカに存在しません。部分フィルタを定義する場合、部分フィルタが、関連するテーブルに対するリレーションシップのすべてに従っているかどうかを確認してください。


組み込みプロパティは削除できません。(Error 3384)

Microsoft Jet データベース エンジンにより定義されている Property オブジェクトを削除しようとしました。

削除できるプロパティは、アプリケーション定義のプロパティを含むユーザー定義のプロパティのうち、デザインを変更する権限のあるプロパティ、およびデザイン変更の権限を必要としないプロパティのみです。


既に Fields コレクションに属しているフィールドは追加できません。(Error 3266)

既存の Fields コレクションの要素になっている Field オブジェクトを、Append メソッドの引数に指定しました。Dim ステートメントと CreateField メソッドを使用して新しい Field オブジェクトを宣言し、その値を設定してから、その Field オブジェクトを指定してもう一度 Append メソッドを実行してください。


プロパティの値が正しくありません。(Error 3271)

原因：

  • Parameter オブジェクトの Value プロパティの設定が長すぎるか、または設定に誤りがあります。

  • Index オブジェクトの名前が長さ 0 の文字列 ("") です。Indexes コレクションに Index オブジェクトを追加する場合は、必ずオブジェクト名を入力してください。

  • Workspace オブジェクトの名前が長さ 0 の文字列です。Workspaces コレクションに Workspace オブジェクトを追加する場合は、必ずオブジェクト名を入力してください。


既に Indexes コレクションに属しているインデックスは追加できません。(Error 3269)

既存の Indexes コレクションの要素になっている Index オブジェクトを、Append メソッドの引数に指定しました。Dim ステートメントと CreateIndex メソッドを使用して新しい Index オブジェクトを宣言し、その値を指定してから、その Index オブジェクトを指定してもう一度 Append メソッドを実行してください。


REMOTE オブジェクトのプロパティの値が正しくありません。(Error 3365)

ODBC データベースに関連付けられているオブジェクトには、指定したプロパティは利用できません。


このメソッドを使用するには、プロパティ '<プロパティ名>' を設定する必要があります。(Error 3386)

新しい Property オブジェクトの Value、Type、Name の各プロパティをすべて設定せずに、その Property オブジェクトをコレクションに追加しようとしました。


フィールドが定義されていないので、テーブル定義またはインデックスを追加できません。(Error 3264)

TableDef オブジェクトは、フィールドを 1 つまたは複数定義すれば追加できます。CreateField メソッドを使用してフィールドを作成し、それを TableDef オブジェクトの Fields コレクションに追加してから、TableDef オブジェクトを TableDefs コレクションに追加してください。


フィールドが定義されていないので、リレーションシップを追加できません。(Error 3366)

フィールドを 1 つも持っていない Relation オブジェクトを Relations コレクションに追加しようとしました。

Relation オブジェクトを追加するには、次の手順を実行してください。

  1. CreateRelation メソッドを使用して Relation オブジェクトを作成します。

    CreateRelation メソッドの引数として、Relation オブジェクトの Table、ForeignTable、Attributes の各プロパティを指定しなかった場合は、これらのプロパティを設定します。

    CreateField メソッドを使用し、リレーションシップの主キーと外部キーにある各フィールドに対応する Field オブジェクトを作成します。

  2. 各 Field オブジェクトの Name プロパティと ForeignName プロパティに、リレーションシップの主キー、および外部キーに対応する Field オブジェクトの Name プロパティの設定値をそれぞれ設定します。ただし、CreateField メソッドの引数として Name プロパティの値を指定した場合は、Name プロパティを設定する必要はありません。

  3. Append メソッドを使用し、Relation オブジェクトの Fields コレクションに Field オブジェクトを追加します。

  4. Append メソッドを使用し、データベースの Relations コレクションに Relation オブジェクトを追加します。


オブジェクトがコレクションに属しているので、このプロパティを設定できません。(Error 3268)

既にコレクションに追加されている TableDef や Field などのオブジェクトのプロパティの値を変更しようとしました。


このオブジェクトには使用できないメソッドです。(Error 3273)

メソッドを、そのメソッドをサポートしていないオブジェクトに対して使用しようとしました。そのオブジェクトの概要に示されている有効なメソッドの一覧を参照してください。


プロパティは、フィールドが Recordset オブジェクトの Fields コレクションに属していないと設定できません。(Error 3267)

指定したプロパティは、Field オブジェクトが Recordset オブジェクトの Fields コレクションの要素である場合にのみ有効です。Fields で使用できるプロパティの一覧については、オンライン ヘルプの「Field オブジェクト、Fields コレクションの概要」を参照してください。


オブジェクトはコレクションではありません。(Error 3272)

オブジェクトに対して、コレクションと同様の参照を行いました。たとえば、"qrySales.Refresh" や "qrySales(2)" などのステートメントを使用すると、このエラーが発生します。


指定された名前と同じ名前のオブジェクトが既にコレクションにあるので、追加できません。(Error 3367)

オブジェクトをコレクションに追加しようとしましたが、同名のオブジェクトが既に存在しています。コレクションに対して Refresh メソッドを実行し、追加するオブジェクトが既にそのコレクションに存在しないことを確認してください。または、オブジェクトの Name プロパティの設定を変更してください。


プロパティが見つかりませんでした。(Error 3270)

指定したプロパティが見つかりません。

原因：

  • 指定したプロパティは存在しません。プロパティ名が正しく入力されているかどうかを確認してください。

  • ユーザー定義プロパティの場合、コレクションから削除されている可能性があります。


ユーザー定義プロパティでは Null 値をサポートできません。(Error 3385)

ユーザー定義の Property オブジェクトには Null 値を設定できません。プロパティに対して Delete メソッドを使用し、コレクションからプロパティを削除してください。


データ型の変換エラーが発生しました。(Error 3421)

Microsoft Jet データベース エンジンは、メソッドまたはプロパティで必要なデータ型にデータを変換できませんでした。このエラーは、メソッドやプロパティで必要なデータ型とは異なるデータ型の引数を使用した場合に起こります。


Jet VBA ファイル (16 ビット VBAJET.DLL、32 ビット VBAJET32.DLL) が見つかりません。エラーが発生したアプリケーションを再度セットアップしてください。(Error 3446)

Microsoft® Jet データベース エンジンの VBA ファイル (16 ビット版は Vbajet.dll、32 ビット版は Vbajet32.dll) が見つかりませんでした。エラーを返したアプリケーションをもう一度セットアップしてください。


オブジェクトが正しくないか、現在設定されていません。(Error 3420)

無効になったオブジェクト、またはまだ設定されていないオブジェクトを参照しようとしています。

原因と対策：

  • オブジェクトが既に閉じています。

  • オブジェクトの親オブジェクトが既に閉じているか、または削除されています。

  • オブジェクトが適用範囲外の場所にあります。

  • オブジェクト ライブラリが Microsoft® Windows® レジストリに登録されていません。

  • コレクションのメソッドまたはプロパティを参照しようとしていますが、オブジェクトを変数に割り当てていません。たとえば、Name プロパティを参照するには、次のようにします。

    Dim dbsPublish As Database

    Set dbsPublish = OpenDatabase("BIBLIO.mdb")

    dbname = dbsPublish.Name


OLE システム関数の呼び出しでエラーが発生しました。エラーが発生したアプリケーションを再度セットアップしてください。(Error 3448)

OLE オートメーション関数の呼び出しに失敗しました。エラーを返したアプリケーションをもう一度セットアップしてください。


Jet VBA ファイル (16 ビット VBAJET.DLL、32 ビット VBAJET32.DLL) の初期化に失敗しました。エラーが発生したアプリケーションを再度セットアップしてください。(Error 3447)

Microsoft® Jet データベース エンジンの VBA ファイル (16 ビット版の場合は Vbajet.dll、32 ビット版の場合は Vbajet32.dll) が呼び出し時に初期化されませんでした。エラーを返したアプリケーションをもう一度セットアップしてください。


正しくないバージョンの DLL ファイル '<ファイル名>' が見つかりました。(Error 3445)

Microsoft Jet データベースでは、セットアップされている Microsoft® Jet の DLL (16 ビット版は Msajt200.dll、32 ビット版は Msjt2032.dll) は、2.5 以降のバージョンである必要があります。

ODBCDirect データベースでは、セットアップされている リモート データ オブジェクト (RDO) DLL (Msrdo32.dll) は 1.0 以降のバージョンである必要があります。

エラーを返したアプリケーションをもう一度セットアップしてください。


固定長 '<名前>' の指定で、<列名> 列の列幅が指定されていません。(Error 3444)

テキスト ISAM のテキスト ファイルの指定の中で、列幅パラメータを指定していません。テキスト ファイルの指定は、次の方法で設定できます。

  • Microsoft® Access では、テキスト リンク ウィザードを使用してこれらの値を設定できます。これには、[ファイル] メニューの [外部データの取り込み] をポイントして [テーブルのリンク] をクリックします。

  • Microsoft Jet データベース エンジン対応のその他のホスト アプリケーションを使用し、Schema.ini ファイルに値を保存します。


マシン '<マシン名>' のユーザー '<ユーザー名>' によってロックされているので、更新できませんでした。(Error 3260)

更新しようとしたデータは、現在ロックされているページ上にあります。

原因：

  • 保存しようとしたクエリは、現在ほかのユーザーが使用しています。ほかのユーザーが処理を完了するまで待つか、または別のクエリ名を入力してから、もう一度実行してください。

  • 既に開いているか、またはロックされているレコードのあるデータ ページに対して、Edit メソッドを適用しようとしました。


シンクロナイザのクライアントは現在存在していないので、認識されません。(Error 3537)

予期しないエラーが発生しました。詳細については、マイクロソフト社のテクニカル サポートにお問い合わせください。


関数で使用されている引数の数が正しくありません。(Error 2439)

入力した式には、引数の数が正しくない関数が含まれています。必要な引数の数を確認し、入力した式が正しいかどうかを確認してください。


照合順序が正しくありません。(Error 3220)

現在使用しているものとは異なる国別並べ替え順序で作成された Paradox テーブルとリンクしようとしました。


メモ ファイルのフォーマットが、指定されている外部データベースのファイル フォーマットに対応していません。(Error 3286)

インポートまたはリンクしようとしているデータベースに関連付けられたメモ ファイルが読み取れないため、ファイルをインポートまたはリンクできません。メモ ファイルの形式が違う可能性があります。たとえば、データ ソースとして dBASE IV を選択し、メモ ファイルが Microsoft® FoxPro® 形式である場合などです。


かっこの使い方が正しくありません。(Error 2442)

入力した式で、かっこの使い方が正しくありません。たとえば、クエリで識別子をかっこ "()" で囲んでいる場合などです。クエリでは識別子の標準の構文のみが使用できます。