(Untitled)

[Microsoft ODBC for Oracle セットアップ] ダイアログ ボックス

[Microsoft ODBC for Oracle セットアップ] ダイアログ ボックスには、次のコントロールがあります。

[データ ソース名] | このデータ ソースを呼び出すか使用するために、アプリケーションで使用する名前または識別子です。データ ソースの名前の付け方に制限はありません。このフィールドは既定では空白になっていますが、必ず指定する必要があります。
[説明] | 記述的な修飾子です。既定では空白になっています。
[ユーザー名] | データ ソースのユーザーの名前です。
[サーバー] | SQL*Net Easy Configuration で作成された、または接続文字列内のデータベースの別名です。接続文字列の詳細については、「接続文字列の属性」を参照してください。個人用データベースおよびリモート データベースの接続文字列については、Oracle のヘルプを参照してください。
[トランスレータ] | [選択] をクリックして、ロード済みのデータ トランスレータを選択します。既定では、[トランスレータなし] になっています。
[パフォーマンス] [バッファ サイズ] には、フェッチされたデータを受け取るためにバッファに割り当てるサイズをバイト単位で指定します。Oracle Server からの一度のフェッチでこのバッファ サイズを十分に満たす行数が返されるように、ドライバによりフェッチ機能が最適化されます。大量のデータをフェッチする場合、この値を大きくするとパフォーマンスが向上します。

[Catalog Functions の REMARKS を含む] チェック ボックスでは、ドライバにより SQLColumns 結果セットの Remarks 列が返されるかどうかを指定します。このチェック ボックスをオフにすると、パフォーマンスが向上します。

[SQLColumns の SYNONYMS を含む] を True (1) に設定すると、SQLColumns() API の呼び出しでテーブル、Views、および Synonyms 列の情報が返されます。この値を設定しなかった場合、または False (0) に設定した場合は、列の情報の取得速度が向上します。
[カスタマイズ] [ODBC DayOfWeek スタンダードを強制する] では、結果セットを特定の曜日形式に設定します。選択した場合、結果セットは ODBC の曜日形式に従います (日曜日 = 1、土曜日 = 7)。選択しなかった場合、結果セットは Oracle の曜日形式に従います (月曜日 = 1、日曜日 = 7)。

[SQLDescribeCol は常に有効桁数の値を返す] チェック ボックスをオンにすると、SQLDescribeCol の呼び出しで、Oracle から有効桁数の情報が提供されなかったときに有効桁数として 130 が返されます。Oracle の数値データ型の中には、計算される数値列や小数部桁数も有効桁数もない NUMBER として定義された列など、固定有効桁数を持たないものがあります。このチェック ボックスをオフにした場合は、有効桁数の列に 0 が返されます。

注意 このドライバの詳細およびプログラム情報については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「Microsoft Open Database Connectivity (ODBC)」の「ODBC Drivers」を参照してください。Microsoft ODBC for Oracle は、SQL*Net 2.3 またはそれ以降のバージョンのみをサポートしています。ORACLE 社製品の詳細については、ORACLE 社のマニュアルを参照してください。その他の情報については、このヘルプの「ソフトウェア サポート レベル」および「製品サポート」を参照してください。


.topic 4209
このデータ ソースを呼び出すか使用するために、アプリケーションで使用する名前または識別子です。既定では空白になっていますが、必ず指定する必要があります。

.topic 4210
記述的な修飾子です。既定では空白になっています。

.topic 4201
アプリケーションが一度にフェッチするデータの量 (バイト単位) です。

.topic 4202
データベースのユーザー名を入力します。これは、データベースのユーザー ID です。

.topic 4203
結果セットを ODBC または Oracle の曜日形式のいずれかに設定します。

.topic 4204
選択した場合、SQLColumns 結果セットの Remarks 列が返されます。このチェック ボックスをオフにすると、パフォーマンスが向上します。

.topic 4205
SYNONYMS の列情報が返されます。

.topic 4206
アクセスする Oracle Server エンジンの接続文字列を入力します。

.topic 4207
ロード済みのデータ トランスレータを選択します。

.topic 4208
オンにすると、SQLDescribeCol の呼び出しで、Oracle から有効桁数の情報が提供されないときに有効桁数として 130 が返されます。オフにすると、有効桁数の列に 0 が返されます。


接続文字列の属性

アプリケーションによっては、データ ソースへの接続方法を取得するために、ダイアログ ボックスの代わりに接続文字列の特定の属性を使用する場合があります。属性には、ドライバが接続を確立するために必要な情報が示されています。接続文字列は、次の形式になっています。

"DSN=<data-source-name> ;[SERVER=<value>] [;PWD=<value>] [;UID=<value>] [;<Attribute>=<value>]"

注意 Microsoft ODBC Driver for Oracle では、ドライバの最初のバージョン (1.x) から CONNECTSTRING 引数をサポートしています。

UID、PWD、SERVER (または CONNECTSTRING) およびドライバの属性を指定しない場合、データ ソース名を必ず指定する必要がありますが、その他の属性は省略可能です。属性を指定しない場合、[ODBC データ ソース アドミニストレータ] ダイアログ ボックスの [DSN] タブで指定された属性が既定値として使用されます。

次の表は、接続文字列の属性の説明です。

属性 | 説明 | 既定値
DSN [ODBC データ ソース アドミニストレータ] ダイアログ ボックスの [ユーザー DSN] または [システム DSN] タブに表示されるデータ ソース名です。 ""
PWD アクセスする Oracle Server のパスワードです。このドライバでは、Oracle で設定されているパスワードの制限と同じ 30 文字までのパスワードをサポートしています。 ""
SERVER アクセスする Oracle Server の文字列です。

この文字列は、TNSNAMES.ORA ファイルに登録されている Oracle データベースの別名、または Oracle Names Server によって正しいサーバーにマップされる別名にすることができます。

データベースの別名は、Oracle の SQL*Net Fast Configuration (Oracle8 データベースの場合は Net8 Easy Configuration) を使用して設定することができます。Oracle データベースへの接続の詳細については、ORACLE 社のマニュアルを参照してください。

 ""
UID Oracle Server のユーザー名です。この属性は、省略不可能な場合があります。データベースおよびテーブルによっては、セキュリティ上の理由からこの属性が不可欠なことがあります。

Oracle のオペレーティング システム認証を使用するには、"UID=/;" とします。

""
BUFFERSIZE 列をフェッチするために最適なバッファ サイズです。

Oracle Server からの一度のフェッチでこのバッファ サイズを十分に満たす行数が返されるように、ドライバによりフェッチ機能が最適化されます。大量のデータをフェッチする場合、この値を大きくするとパフォーマンスが向上します。

 65535
SYNONYMCOLUMNS | この値が True (1) の場合、SQLColumns API 呼び出しは、テーブル、Views、および Synonyms の列の情報を返します。False (0) の場合、SQLColumns はテーブルおよび Views の列のみを返します。処理速度を速くするには、True (1) に設定しないでください。 | 1
REMARKS | この値が True (1) の場合、SQLColumns 結果セットの Remarks 列が返されます。処理速度を速くするには、True (1) に設定しないでください。 | 0
StdDayOfWeek | DAYOFWEEK スカラの ODBC 標準を適用します。既定では標準が適用されることになっていますが、ローカライズ バージョンを使用するユーザーは、Oracle で返されるすべての値を使用するために、動作を変更することが可能です。 | 1

注意 属性値では大文字と小文字が区別される場合があります。

例

Oracle ユーザーである cindy が mickey.world という名前の Oracle Server を使用して Employees データ ソースに接続するための接続文字列は、次のようになります。

"DSN=Employees;UID=cindy;PWD=secret;SERVER=mickey.world"

Oracle のオペレーティング システム認証と moola という名前の Oracle Server を使用して Payroll データ ソースに接続するための接続文字列は、次のようになります。

"DSN=Payroll;UID=/;PWD=;SERVER=moola"


[Microsoft ODBC for Oracle 接続] ダイアログ ボックス

[ODBC for Oracle 接続] ダイアログ ボックスには、次のコントロールがあります。

[ユーザー名] | Oracle データベースに接続するために使用する名前です。
[パスワード] | Oracle データベースに接続するためのパスワードで、Oracle で設定されているものと同じパスワードの制限が適用されます。
[サーバー] | TNSNAMES.ORA ファイルに登録されている Oracle データベースの別名、またはOracle Names Server によって正しいサーバーにマップされる別名を入力します。 Oracle データベースへの接続の詳細については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「Microsoft Open Database Connectivity (ODBC)」の「ODBC Drivers」を参照してください。 TNSNAMES.ORA ファイルについては、ORACLE 社のマニュアルを参照してください。


製品サポート

このドライバの詳細およびプログラム情報については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「Microsoft Open Database Connectivity (ODBC)」の「ODBC Drivers」を参照してください。

Oracle クライアント ソフトウェアのセットアップおよび使い方については、ORACLE 社が提供しているヘルプ マニュアルを参照してください。


ソフトウェア サポート レベル

Microsoft ODBC Driver for Oracle では、次のソフトウェアをサポートしています。

  • Windows 95/98 以降、または Windows NT 4.0 以降または Windows 2000。

  • Oracle Call Interface 7 (OCI7)。

  • SQL*Net 2.3 以降。

  • ODBC 2.x および 2.x 以前のバージョン。ODBC の最新バージョンをインストールすることもできますが、機能によっては使用できないものがあります。


SQLColumns 関数

指定されたテーブル (複数可) の列の一覧で構成されるテーブルの結果セットを作成します。PUBLIC シノニムの列を要求する場合は、SYNONYMCOLUMNS 接続属性を設定し、空白の文字列を szTableOwner 引数として指定する必要があります。PUBLIC シノニムの列が返されると、空白の文字列に TABLE NAME 列が設定されます。結果セットの各行の終わりに ORDINAL POSITION 列が追加されます。この値は、テーブル内の列の位置を数値で示すものです。