(Untitled)

[ユーザー DSN] タブ

ユーザー データ ソース名 (DSN) についてデータ ソースの追加、削除、構成を行います。これらのデータ ソースはコンピュータに対してローカルになり、現在のユーザーのみがアクセスできます。

コントロール | 説明
[ユーザー データ ソース] | 各 DSN の名前および関連するドライバを含む、すべてのユーザー DSN を表示します。ユーザー DSN をダブルクリックすると、ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。
[追加] | 新しいユーザー データ ソースを追加します。表示された [データ ソースの新規作成] ダイアログ ボックスで、追加するユーザー データ ソースのドライバを選択し、[完了] をクリックします。ドライバ固有のセットアップ ダイアログ ボックスが表示されます。
[削除] | [ユーザー データ ソース] ボックスから選択されたユーザー データ ソース名を削除します。
[構成] | 選択されたユーザー データ ソースの構成を変更します。ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。
[OK] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。[ユーザー データ ソース] ボックスに対する変更を適用するために [OK] をクリックする必要はありません。リスト ボックスに対する変更は、データ ソースのセットアップ ダイアログ ボックスで [OK] をクリックした時点で適用されます。
[キャンセル] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。ダイアログ ボックスのほかのコントロールで行った変更は取り消されません。
[ヘルプ] | ヘルプを表示します。


.topic 902
各 DSN の名前および関連するドライバを含む、すべてのユーザー DSN を表示します。ユーザー DSN をダブルクリックすると、ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。

.topic 903
選択されたユーザー データ ソースの構成を変更します。

.topic 904
新しいユーザー データ ソースを追加します。

.topic 905
選択されたユーザー データ ソースを削除します。

.topic 910
各 DSN の名前および関連するドライバを含む、すべてのシステム DSN を表示します。システム DSN をダブルクリックすると、ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。

.topic 911
選択されたシステム データ ソースの構成を変更します。

.topic 912
新しいシステム データ ソースを追加します。

.topic 913
選択されたシステム データ ソースを削除します。

.topic 915
[データ ソースの場所] ボックスに表示されたフォルダのファイル DSN とサブフォルダをすべて表示します。ファイル DSN をダブルクリックすると、ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。

.topic 916
選択されたファイル データ ソースの構成を変更します。

.topic 917
新しいファイル データ ソースを追加します。

.topic 918
選択されたファイル データ ソースを削除します。

.topic 919
[データ ソースの場所] ボックスに表示されたフォルダを、ODBC アドミニストレータの実行時の既定フォルダに設定します。

.topic 920
フォルダを表示します。下のウィンドウには、そのフォルダのサブフォルダとファイル DSN が表示されます。

.topic 921
[データ ソースの場所] に表示されたフォルダを 1 つ上のレベルのフォルダで置き換えます。

.topic 969
インストールされている ODBC ドライバとその接続プール タイムアウト オプションを表示します。タイムアウト オプションを設定するには、任意の ODBC ドライバ名をダブルクリックします。

.topic 965
インストールされている各 ODBC ドライバの、名前、バージョン、会社名、ファイル、更新日時です。

.topic 924
アプリケーションに対してトレース オプションを設定します。

.topic 926
[ODBC データ ソース アドミニストレータ] ダイアログ ボックスが表示されている限り、または [トレースの停止] をクリックするまで、接続が確立されているかどうかに関係なく継続的な動的トレースを実行します。このボタンは、クリックするたびに [トレースの開始] と [トレースの停止] が切り替わります。

.topic 923
Visual Studio Analyzer をアクティブにします。Visual Studio Analyzer は、[Visual Studio Analyzer の停止] をクリックするまで有効です。このボタンは、クリックするたびに [Visual Studio Analyzer の開始] と [Visual Studio Analyzer の停止] が切り替わります。

.topic 927
トレース情報の格納先のパスとファイル名を表示します。既定のファイルはログ ファイルの sql.log です。

.topic 968
ログ ファイルのフル パスとファイル名を選択します。

.topic 928
適切なパスとファイル名を入力してカスタム トレース DLL ファイルを選択します。

.topic 929
カスタム トレース DLL のディレクトリ構造を参照します。

.topic 952
[データ ソースの場所] ボックスに表示されたフォルダに含まれているファイル DSN とサブフォルダをすべて表示します。DSN をダブルクリックするとデータ ソースに接続します。

.topic 953
フォルダを表示します。下のウィンドウには、そのフォルダのサブフォルダとファイル DSN が表示されます。

.topic 954
[データ ソースの場所] に表示されたフォルダを 1 つ上のレベルのフォルダで置き換えます。

.topic 955
[ファイル データ ソース] ボックスで選択したか、別に入力したファイル DSN の名前を表示します。

.topic 957
新しいファイル データ ソースを追加します。

.topic 961
ユーザー DSN とシステム DSN (データ ソース名と種類を含む) をすべて表示します。DSN をダブルクリックするとデータ ソースに接続します。

.topic 970
選択されたドライバのタイムアウト時間を秒単位で表示します。

.topic 974
接続のパフォーマンス モニタをデバッグ用に設定します。ただし、アプリケーションのパフォーマンスに影響します。

.topic 971
接続のパフォーマンス モニタを有効にします。

.topic 972
接続のパフォーマンス モニタを無効にします。

.topic 973
再試行までの待ち時間を秒単位で指定します。

.topic 962
新しいコンピュータ データ ソースを追加します。


[バージョン情報] タブ

ODBC コンポーネントについての情報を表示します。情報が表示されるコンポーネントには、ドライバ マネージャ、カーソル ライブラリ、インストーラ DLL、およびコア コンポーネントを構成するそのほかのファイルが含まれます。

コントロール | 説明
[ODBC コア コンポーネント バージョン情報] ボックス | 各 ODBC コア コンポーネントの説明、バージョン、ファイル名、および場所を表示します。
[OK] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。
[キャンセル] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。ダイアログ ボックスのほかのコントロールで行った変更は取り消されません。
[ヘルプ] | ヘルプを表示します。


[接続プール] タブ

接続プールを使用しているときに、選択したドライバの接続待ち時間および接続タイムアウトの時間を変更できます。また、接続回数の統計を記録するパフォーマンス モニタを有効または無効に切り替えることができます。接続プールを使用すると、アプリケーションは、使用時に再確立する必要がない接続プール内の接続を使用できます。接続が作成されプールに入れられると、アプリケーションは接続の手順を踏まないで接続を再使用できるため、パフォーマンスが向上します。

コントロール | 説明
[ODBC ドライバ] | インストールされている ODBC ドライバ名とその接続プール タイムアウト オプションを表示します。タイムアウト オプションを設定するには、任意の ODBC ドライバ名をダブルクリックします。
[接続プールのタイムアウト] | 選択したドライバの接続プール タイムアウトを秒単位で設定します。接続プールの属性を設定するには、ドライバ名をダブルクリックします。[接続プールの属性の設定] ダイアログ ボックスが表示されます。未使用の接続がプール内に保持される時間を設定し、選択したドライバに対して接続プールをアクティブにします。
[有効にする] | 接続プールのパフォーマンス モニタのカウンタを有効にします。パフォーマンス モニタの詳細については、『Microsoft ODBC プログラマーズ リファレンス』を参照してください。
[無効にする] | 接続プールのパフォーマンス モニタのカウンタを無効にします。パフォーマンス モニタの詳細については、『Microsoft ODBC プログラマーズ リファレンス』を参照してください。
[再試行までの待ち時間] | ODBC データベース マネージャがデータベース サーバーへの接続を再度試みるまでの待ち時間 (5 秒以下) を秒単位で指定します。
[OK] | 接続プールの設定の変更を適用し、[ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。
[キャンセル] | 設定の変更を適用せずに [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。
[適用] | 接続プールの設定の変更を適用し、[ODBC データ ソース アドミニストレータ] ダイアログ ボックスは開いたままです。
[ヘルプ] | ヘルプを表示します。


[ファイル データ ソース] タブ

ファイル データ ソース名 (DSN) を持つデータ ソースに接続します。ファイル データ ソースは、ユーザー専用にする必要も、コンピュータに対してローカルにする必要もなく、同じドライバをインストールしているすべてのユーザーが共有できます。

コントロール | 説明
[ファイル データ ソース] | [データ ソースの場所] ボックスに表示されたフォルダのファイル DSN とサブフォルダをすべて表示します。DSN をダブルクリックすると、データ ソースに接続します。
[データ ソースの場所] | フォルダを表示します。下のウィンドウには、そのフォルダのサブフォルダとファイル DSN が表示されます。テキスト ボックスの右横にある下向きの矢印をクリックすると、そのディレクトリ構造全体が表示されます。
[上へ] アイコン | [データ ソースの場所] に表示されたフォルダを 1 つ上のレベルのフォルダで置き換えます。
[DSN 名] | [ファイル データ ソース] ボックスで選択したか別に入力したファイル DSN の名前を表示します。
[新規作成] | 新しいファイル データ ソースを追加します。表示された [データ ソースの新規作成] ダイアログ ボックスで、追加するファイル データ ソースのドライバを選択し、[次へ] をクリックして新しいファイル データ ソースの名前または場所を指定します。もう一度 [次へ] をクリックし、新しいデータ ソースの情報を確認します。[完了] をクリックすると、そのドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。
[OK] | [データ ソースの選択] ダイアログ ボックスを閉じ、[DSN 名] ボックスに表示されているファイル データ ソースに接続します。[ファイル データ ソース] ボックスに対する変更を適用するために [OK] をクリックする必要はありません。リスト ボックスに対する変更は、データ ソースのセットアップ ダイアログ ボックスで [OK] をクリックした時点で適用されます。
[キャンセル] | ファイル データ ソースに接続せずに [データ ソースの選択] ダイアログ ボックスを閉じます。ダイアログ ボックスのほかのコントロールで行った変更は取り消されません。
[ヘルプ] | ヘルプを表示します。


[ファイル DSN] タブ

ファイル データ ソースの追加、削除、構成を行います。ファイル データ ソースは、同じドライバをインストールしているすべてのユーザーが共有できます。これらのデータ ソースを、ユーザー専用にする必要も、コンピュータに対してローカルにする必要もありません。

コントロール | 説明
[ファイル データ ソース] | [データ ソースの場所] ボックスに表示されたフォルダのファイル データ ソース名 (DSN) とサブフォルダをすべて表示します。ファイル DSN をダブルクリックすると、ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。
[追加] | 新しいファイル データ ソースを追加します。表示された [データ ソースの新規作成] ダイアログ ボックスで、追加するファイル データ ソースのドライバを選択し、[次へ] をクリックして新しいファイル データ ソースの名前または場所を指定します。もう一度 [次へ] をクリックし、新しいデータ ソースの情報を確認します。[完了] をクリックすると、そのドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。
[削除] | 選択されたファイル データ ソースを削除します。[削除] をクリックする前に、削除するファイル データ ソースをリスト ボックスで選択しておく必要があります。
[構成] | 選択されたファイル データ ソースの構成を変更します。[構成] をクリックする前に、対象となるファイル データ ソースをリスト ボックスで選択しておく必要があります。ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。
[ディレクトリの設定] | [データ ソースの場所] ボックスに表示されたディレクトリを、ODBC アドミニストレータ実行時の既定ディレクトリに設定します。
[データ ソースの場所] | フォルダを表示します。下のウィンドウには、そのフォルダのサブフォルダとファイル DSN が表示されます。テキスト ボックスの右横にある下向きの矢印をクリックすると、そのディレクトリ構造全体が表示されます。ODBC アドミニストレータの実行当初に最初に表示される既定フォルダは、システム情報に収められていますが、[ディレクトリの設定] ボタンで変更することができます。
[上へ] アイコン | [データ ソースの場所] に表示されたフォルダを 1 つ上のレベルのフォルダで置き換えます。
[OK] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。[ファイル データ ソース] ボックスに対する変更を適用するために [OK] をクリックする必要はありません。リスト ボックスに対する変更は、データ ソースのセットアップ ダイアログ ボックスで [OK] をクリックした時点で適用されます。
[キャンセル] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。ダイアログ ボックスのほかのコントロールで行った変更は取り消されません。
[ヘルプ] | ヘルプを表示します。


[コンピュータ データ ソース] タブ

ユーザー データ ソース名 (DSN) またはシステム DSN を持つデータ ソースに接続します。コンピュータ データ ソースはこのコンピュータに固有であり、共有されません。

コントロール | 説明
[コンピュータ データ ソース] | ユーザー DSN とシステム DSN (DSN の名前とタイプを含む) をすべて表示します。DSN をダブルクリックするとデータ ソースに接続します。
[新規作成] | 新しいコンピュータ データ ソースを追加します。表示された [データ ソースの新規作成] ダイアログ ボックスで、追加するユーザー DSN またはシステム DSN を選択し、[次へ] をクリックし、追加するデータソースのドライバを選択します。もう一度 [次へ] をクリックし、新しいデータ ソースの情報を確認します。[完了] をクリックすると、そのドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。
[OK] | [データ ソースの選択] ダイアログ ボックスを閉じ、選択したコンピュータ データ ソースに接続します。[OK] をクリックしても、[コンピュータ データ ソース] ボックスに対する変更は適用されません。リスト ボックスに対する変更は、データ ソースのセットアップ ダイアログ ボックスで [OK] をクリックした時点で適用されます。
[キャンセル] | コンピュータ データ ソースに接続せずに [データ ソースの選択] ダイアログ ボックスを閉じます。ダイアログ ボックスのほかのコントロールで行った変更は取り消されません。
[ヘルプ] | ヘルプを表示します。


[ドライバ] タブ

コンピュータにインストールされている ODBC ドライバに関する情報を表示します。このタブでは、ドライバに関する操作を実行できません。ODBC ドライバを追加または削除するには、適切なドライバ セットアップ プログラムを使用する必要があります。

コントロール | 説明
[ODBC ドライバ] | コンピュータにインストールされている各 ODBC ドライバについて、名前、バージョン、会社名、ファイル名、およびファイル更新日時を表示します。
[OK] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。
[キャンセル] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。
[ヘルプ] | ヘルプを表示します。


[システム DSN] タブ

システム データ ソース名 (DSN) についてデータ ソースの追加、削除、構成を行います。これらのデータ ソースはコンピュータに対してローカルになりますが、ユーザー専用ではありません。システム DSN には、特権を持っている任意のユーザーがアクセスできます。

コントロール | 説明
[システム データ ソース] | 各 DSN の名前および関連するドライバを含む、すべてのシステム DSN を表示します。システム DSN をダブルクリックすると、ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスが表示されます。
[追加] | 新しいシステム データ ソースを追加します。表示された [データ ソースの新規作成] ダイアログ ボックスで、追加するシステム データ ソースのドライバを選択し、[完了] をクリックします。ドライバ固有のセットアップ ダイアログ ボックスが表示されます。
[削除] | [システム データ ソース] ボックスから選択されたシステム データ ソース名を削除します。
[構成] | 選択されたシステム データ ソースの構成を変更します。ドライバ固有のデータ ソースのセットアップ ダイアログ ボックスを表示します。このダイアログ ボックスでは、既存のシステム データ ソースの構成を変更することができます。[構成] をクリックする前に、対象となるシステム データ ソースをリスト ボックスで選択しておく必要があります。
[OK] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。[システム データ ソース] ボックスに対する変更を適用するために [OK] をクリックする必要はありません。リスト ボックスに対する変更は、データ ソースのセットアップ ダイアログ ボックスで [OK] をクリックした時点で適用されます。
[キャンセル] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。ダイアログ ボックスのほかのコントロールで行った変更は取り消されません。
[ヘルプ] | ヘルプを表示します。


[トレース] タブ

ODBC ドライバ マネージャが ODBC 関数の呼び出しをトレース (追跡) する方法を指定します。カスタム トレース DLL を使用して、継続的なトレース、一度のみのトレース、動的トレース、またはカスタム トレースを指定できます。

コントロール | 説明
[トレースの開始]/[トレースの停止] | [ODBC データ ソース アドミニストレータ] ダイアログ ボックスが表示されている限り、または [トレースの停止] をクリックするまで、接続が確立されているかどうかに関係なく継続的な動的トレースを実行します。
[Visual Studio Analyzer の開始]/[Visual Studio Analyzer の停止] | Visual Studio Analyzer を有効にします。Visual Studio Analyzer は、[Visual Studio Analyzer の停止] をクリックするまで有効です。Visual Studio Analyzer は、分散アプリケーションのデバッグおよび分析に使用するツールです。Visual Studio Analyzer の詳細については、「MSDN Library Online」のマニュアルを参照してください。
[ログ ファイルのパス] | トレース情報の格納先のパスとファイル名を表示します。既定のパスとファイル名 (\SQL.LOG) を使用するか、別のファイルを指定できます。別のファイルを指定する場合は、パスとファイル名を入力するか、または [参照] をクリックしてフォルダとファイルを選択します。
[参照] | コンピュータのフォルダを参照して、ログ ファイルのパスとファイル名を選択するときに使用します。
[カスタム トレース DLL] | トレースを実行するために ODBCTRAC.DLL 以外の DLL ファイルを選択するときに使用します。カスタム DLL のパスおよびファイル名を入力するか、[DLL の選択] をクリックしてフォルダを選択します。Microsoft Data Access Component (MDAC) SDK に付属する ODBCTRAC.DLL ファイルを、任意のカスタム DLL に置き換えることができます。
[DLL の選択] | ディレクトリ構造を参照してカスタム トレース DLL を選択するときに使用します。選択した DLL のパスとファイル名が、[カスタム トレース DLL] ボックスに表示されます。
[OK] | [ログ ファイルのパス] および [カスタム トレース DLL] に対する設定の変更を適用し、[ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。
[キャンセル] | 設定の変更を適用せずに [ODBC データ ソース アドミニストレータ] ダイアログ ボックスを閉じます。
[適用] | トレースの設定の変更を適用し、[ODBC データ ソース アドミニストレータ] ダイアログ ボックスは閉じません。
[ヘルプ] | ヘルプを表示します。


[トランスレータの選択] ダイアログ ボックス

[トランスレータの選択] ダイアログ ボックスに表示されるインストール済みトランスレータ DLLの一覧からトランスレータ DLL を選択すると、ある文字セットから別の文字セットにデータが変換されます。アプリケーションとデータ ソースでは、データを異なる文字セットで保存することがあります。ODBC では、ある文字セットから別の文字セットにデータを変換するためのメカニズムが提供されています。

トランスレータ DLL を指定すると、ドライバは指定された トランスレータ DLL を読み込み、その DLL を呼び出して、アプリケーションとデータ ソース間でやりとりされるすべてのデータを変換します。これには、データ ソースへ送られるすべての SQL ステートメントと文字パラメータ、データ ソースから取得されるすべての文字結果、列名などの文字メタデータ、およびエラー メッセージが含まれます。接続データは変換されません。トランスレータ DLL は、アプリケーションがデータ ソースに接続した後に読み込まれるためです。

ドライバが呼び出す変換関数の SQLDriverToDataSource および SQLDataSourceToDriver を実装するトランスレータ DLL については、アプリケーションの開発者が作成したり、サード パーティが提供する製品を使用することができます。

トランスレータ DLL の詳細については、『Microsoft ODBC プログラマーズ リファレンス』を参照してください。