(Untitled)

[ODBC Microsoft Access セットアップ] ダイアログ ボックス

[ODBC Microsoft Access セットアップ] ダイアログ ボックスには、次のコントロールがあります。

[データ ソース名] [説明] | Access データベースを識別します。既定では、製造段階で割り当てられた名前になっています。[説明] フィールドに、データ ソースの説明を入力することができます。既定では、空白になっています。
[データベース] | [修復] をクリックすると、損傷したデータベースを修復できます。[最適化] をクリックすると、無駄な領域を減らすことができます。既存のデータベースを開くには [選択]、新しいデータベースを開くには [作成] をクリックします。
[システム データベース] | 共有データベースを選択する場合にクリックします。既定のユーザー名は Admin で、Admin ユーザーに対応する Access での既定のパスワードは空の文字列です。
[オプション] 次のドライバ オプションを変更する場合にクリックします。
  • [ページ タイムアウト]。未使用のページがバッファに保持される時間 (0.1 秒単位) です。0 より大きい数値であることが必要です。

  • [バッファ サイズ]。Access がディスクとの間でデータを転送するときに使用する内部バッファのサイズ (KB 単位) です。256 の整数倍の値にします。

  • [排他] [読み取り専用]。
[詳細設定] | ドライバのパフォーマンスに関するその他のオプションを設定する場合にクリックします。

注意 このドライバの詳細およびプログラム情報については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「Microsoft Open Database Connectivity (ODBC)」の「ODBC Drivers」を参照してください。その他の情報については、このヘルプの「データ ソースの変換」、「Access ファイル」、「IISAM レジストリ エントリ」、および「共通の ODBC コンポーネント ファイル」を参照してください。製品サポートもご利用いただけます。


.topic 2
変更を保存しないでこのダイアログ ボックスを終了します。

.topic 3
データ ソースの名前 (従業員名簿や人事など) を識別します。Excel 3.0 または 4.0 のドライバを使用する場合、データ ファイルの検索時に ODBC ドライバにより参照される既定のデータ フォルダを指定します。Excel 5.0、7.0、または 97 ドライバを使用する場合、データ ファイルの検索時に ODBC ドライバにより参照される既定のデータ ブックを指定します。

.topic 4
データ ソース中のデータの説明 (たとえば、採用日付、給与履歴、現在の従業員の再評価など)。この説明は省略可能です。

.topic 5
このダイアログ ボックスのヘルプを表示します。

.topic 6
セットアップ ダイアログ ボックスを終了して、変更を保存します。

.topic 7
そのデータベースを読み取り専用にし、更新されるのを防ぐ場合に選択します。

.topic 8
各列のデータ型を判別するためにスキャンする行数です。Excel ドライバの場合、この行数を 1 ～ 16 の任意の数値にすることができます。既定値は 8 です。0 に設定した場合は、すべての行がスキャンされます。

.topic 9
クリックすると、[フォルダの選択] ダイアログ ボックスが表示され、その中でアクセスするファイルが入っているフォルダを選択できます。データ ソース フォルダを定義する場合、使用頻度が最も高い Excel 3.0 または 4.0 のファイルが入っているフォルダを指定します。

.topic 10
クリックすると、[ブックの選択] ダイアログ ボックスが表示され、その中で、アクセスするファイルが入っているブックを選択できます。

.topic 11
アプリケーションの現在の作業フォルダをデータ ソース フォルダにします。このチェック ボックスをオフにした場合は、[フォルダの選択] をクリックしてデータ ソース フォルダを選択できます。このチェック ボックスは、Excel 5.0、7.0、および 97 の場合は使用できません。

.topic 12
使用するファイルの Excel バージョンを指定します。

.topic 13
Excel ファイルの場所とバージョンを変更するときに、これらのオプションを使用します。

.topic 14
ドライバ固有の属性を構成するときに、これらのオプションを使用します。

.topic 15
ドライバ固有の属性を構成する場合にクリックします。

.topic 16
選択した Excel フォルダの場所です。

.topic 17
選択した Excel ブックの場所です。

.topic 201
[拡張子] ボックスで入力した拡張子を追加する場合にクリックします。

.topic 202
変更を保存しないでこのダイアログ ボックスを終了します。

.topic 203
データ ソースの名前 (従業員名簿や人事など) を識別し、データ ファイルの検索時に ODBC ドライバにより参照される既定のデータ フォルダを指定します。

.topic 204
このチェック ボックスをオンにすると、フォルダ内のすべてのファイルを使用できます。オフにすると、既定では、拡張子の一覧に *.ASC、*.CSV、*.TAB、および *.TXT の拡張子が表示され、必要に応じて拡張子を追加または削除することができます。

.topic 205
クリックすると、[テキスト形式の定義] ダイアログ ボックスが表示され、そこで列の書式を定義し、データ ソース フォルダ内のテーブルについてスキーマを指定できます。

.topic 206
データ ソース中のデータの説明 (たとえば、採用日付、給与履歴、現在の従業員の再評価など)。この説明は省略可能です。

.topic 207
追加するファイル拡張子を *.xxx という形式で入力します。たとえば、.DAT ファイルを使用するには、拡張子として「*.dat」を入力します。

.topic 208
[既定 （*.*)] チェック ボックスの状態がオンかオフかに応じて、そのデータ ソースに含まれるテキスト ファイルのファイル名拡張子の一覧が表示されます。

.topic 214
特定のファイルの種類に対して書式を設定するときに、これらのオプションを使用します。

.topic 215
既定でないファイル拡張子を拡張子の一覧に追加または一覧から削除するときに、これらのオプションを使用します。ファイル拡張子を追加するには、[既定 （*.*)] チェック ボックスをオフにして、[拡張子] ボックスに新しい拡張子を入力し、[追加] をクリックします。

.topic 216
テキスト ファイルの場所を選択し、ファイル名を表示するときに、これらのオプションを使用します。

.topic 209
このダイアログ ボックスのヘルプを表示します。

.topic 210
セットアップ ダイアログ ボックスを終了して、変更を保存します。

.topic 211
選択されているファイル拡張子を拡張子の一覧から削除する場合にクリックします。

.topic 212
クリックすると、[フォルダの選択] ダイアログ ボックスが表示され、その中でアクセスするファイルが入っているフォルダを選択できます。

.topic 213
アプリケーションの現在の作業フォルダをデータ ソース フォルダにします。このチェック ボックスをオフにした場合は、[フォルダの選択] をクリックしてデータ ソース フォルダを選択できます。

.topic 217
テキスト ファイルの属性を構成し、テキスト ファイルの種類を追加または削除する場合にクリックします。

.topic 218
テキスト ファイルの場所を識別します。

.topic 301
[データ型]、[名前]、および [列幅] フィールドの値に基づいて列を追加する場合にクリックします。

.topic 302
変更を保存しないでこのダイアログ ボックスを終了します。

.topic 321
文字セットを ANSI または OEM のいずれかに設定します。

.topic 303
[テーブル] の一覧で選択した項目の書式に ANSI の文字セットを指定します。

.topic 304
選択したテーブルの 1 行目の列を列名に使用するかどうかを指定します。このチェック ボックスがオンの場合は True であり、オフの場合は False です。

.topic 305
[テーブル] の一覧で選択したテーブル内の列の列名が、テーブル内での列の順序に従って表示されます。

.topic 319
選択したテキスト ファイルの列属性を定義できます。

.topic 306
データ型が表示されます。BIT、BYTE、CHAR、CURRENCY、DATE、FLOAT、INTEGER、LONGCHAR、SHORT、または SINGLE を選択できます。

.topic 307
列の区切りとして使用するカスタム区切り記号の文字です。区切り記号は、必ず 1 文字とし、二重引用符 (") は使用できません。このコントロールは、[書式] ボックスで [カスタム区切り] を選択した場合に使用可能になります。

.topic 308
区切り記号付きか固定長のいずれかです。区切り記号付きの場合は、使用する区切り記号の種類が示されます。

.topic 309
[書式] ボックスでの選択に基づいてそのテーブルの内容がスキャンされ、テーブル内の列のデータ型、名前、および列幅が生成されます。これはテーブルの書式が区切り記号付きの場合に有効になります。

.topic 310
このダイアログ ボックスのヘルプを表示します。

.topic 311
[データ型]、[名前]、および [列幅] フィールドの値に基づいて選択された列を修正します。

.topic 312
選択した列の名前が表示されます。既存の列または新しい列に対して、新しい列名を指定するときに使用します。

.topic 313
このダイアログ ボックスを終了して、変更を保存します。

.topic 314
選択した列を削除します。

.topic 315
セットアップまたはドライバが、列および列データ型を設定するときにスキャンする行数です。[テーブル] の一覧で選択した項目の書式が定義されていない場合の既定値は、25 です。1 ～ 32767 までの任意の数値を指定できます。

.topic 316
[ODBC テキスト セットアップ] ダイアログ ボックスで選択した拡張子の一覧に適合するファイルがすべて表示されます。テーブル属性を表示または修正するファイルを選択します。

.topic 320
選択したテキスト ファイルのテーブル属性を定義するときに、これらのオプションを使用します。

.topic 317
CHAR または LONGCHAR 型の列については、列幅を変更できます。ほかのデータ型では、列幅は調整できません。値は、表示されません。[テーブル] の一覧で選択した項目の書式が定義されていない場合の既定値は、1 です。

.topic 318
[テーブル] の一覧で選択したファイルの書式に非 ANSI の文字セット (既定) を指定します。

.topic 401
変更を保存しないでこのダイアログ ボックスを終了します。

.topic 402
フィールドを並べ替える順序であり、ASCII (既定)、International、Norwegian-Danish、または Swedish-Finnish のいずれかです。

.topic 403
データ ソースの名前 (従業員名簿や人事など) を識別し、データ ファイルの検索時に ODBC ドライバにより参照される既定のデータ フォルダを指定します。

.topic 404
データ ソース中のデータの説明 (たとえば、採用日付、給与履歴、現在の従業員の再評価など)。この説明は省略可能です。

.topic 405
このチェック ボックスをオンにすると、データベースは排他モードで開きます。同時にデータベースにアクセスできるユーザーは 1 人に制限され、パフォーマンスが向上します。オフにすると、データベースは共有モードで開きます。同時に複数のユーザーがデータベースにアクセスできます。

.topic 406
このダイアログ ボックスのヘルプを表示します。

.topic 407
Paradox データにアクセスする際に使用するネットワーク アクセスのスタイルを指定します。"3.x" (Paradox 3.x 用) か "4.x" (Paradox 4.x/5.x 用) のいずれかを指定します。Paradox 4.x および 5.x の場合は "3.x" または "4.x" を設定することができます。Paradox 3.x の場合は必ず "3.x" にしてください。

.topic 408
セットアップ ダイアログ ボックスを終了して、変更を保存します。

.topic 409
未使用ページがバッファに保持される時間 (0.1 秒単位) です。既定値は 600/10 秒 (60 秒) であり、0 より大きい数値にする必要があります。

.topic 410
クリックすると、[フォルダの選択] ダイアログ ボックスが表示され、その中で、アクセスするファイルが入っているフォルダを選択できます。

.topic 415
Paradox ファイルの場所を識別します。

.topic 411
ネットワーク フォルダを選択するには、あらかじめ [ユーザー名] ボックスに Paradox のユーザー名を入力する必要があります。[ネットワーク フォルダの選択] をクリックして、ネットワーク フォルダを選択します。

.topic 416
Paradox ロック データベースおよび PDOXUSRS.NET ファイル (Paradox 4.x) または PARADOX.NET ファイル (Paradox 5.x) を格納するフォルダのパス。これらのファイルがフォルダに存在しない場合は、Paradox ドライバがそれを作成します。

.topic 412
アプリケーションの現在の作業フォルダをデータ ソース フォルダにします。このチェック ボックスをオフにした場合は、[フォルダの選択] をクリックしてデータ ソース フォルダを選択できます。

.topic 413
ロックが検出されたときに Paradox ファイルのほかのユーザーに表示される Paradox のユーザー名です。

.topic 414
使用するファイルの Paradox のバージョン (Paradox 4.x または Paradox 5.x など) を指定します。

.topic 417
Paradox データベースのバージョンおよび場所を選択および表示するときに、これらのオプションを使用します。

.topic 418
Paradox ドライバを構成するときに、これらのオプションを使用します。

.topic 419
ドライバ固有の属性を構成する場合にクリックします。

.topic 501
テーブル サイズ統計を近似値にするかどうかを指定します。このオプションは、その dBASE ドライバを使用するすべてのデータ ソースに適用されます。

.topic 502
変更を保存しないでこのダイアログ ボックスを終了します。

.topic 503
フィールドを並べ替える順序として ASCII (既定) またはインターナショナル設定を指定します。

.topic 504
データ ソースの名前 (従業員名簿や人事など) を識別し、データ ファイルの検索時に ODBC ドライバにより参照される既定のデータ フォルダを指定します。

.topic 505
データ ソース中のデータの説明 (たとえば、採用日付、給与履歴、現在の従業員の再評価など)。この説明は省略可能です。

.topic 506
このチェック ボックスをオンにすると、データベースは排他モードで開きます。同時にデータベースにアクセスできるユーザーは 1 人に制限され、パフォーマンスが向上します。オフにすると、データベースは共有モードで開きます。同時に複数のユーザーがデータベースにアクセスできます。

.topic 507
このダイアログ ボックスのヘルプを表示します。

.topic 508
セットアップ ダイアログ ボックスを終了して、変更を保存します。

.topic 509
未使用ページがバッファに保持される時間 (0.1 秒単位) です。既定値は 600/10 秒 (60 秒) であり、0 より大きい数値にする必要があります。

.topic 515
dBASE データベースの場所を識別します。

.topic 510
クリックすると、[フォルダの選択] ダイアログ ボックスが表示され、その中で、アクセスするファイルが入っているフォルダを選択できます。

.topic 511
クリックすると、[インデックスの選択] ダイアログ ボックスが表示され、その中で dBASE のファイルをインデックス ファイルに関連付けることができます。

.topic 512
削除マークで指定された行を検索できるかどうかを指定します。このチェック ボックスがオフ (既定) の場合は、削除された行は表示されません。オンにすると、削除された行は削除されていない行と同じように扱われます。

.topic 513
アプリケーションの現在の作業フォルダをデータ ソース フォルダにします。このチェック ボックスをオフにした場合は、[フォルダの選択] をクリックしてデータ ソース フォルダを選択できます。

.topic 514
使用する dBASE ファイルのバージョン (dBASE III、dBASE IV、dBASE 5.0 など) を指定します。

.topic 516
dBASE データベースのバージョンと場所を選択および表示するときに、これらのオプションを使用します。

.topic 517
dBASE ドライバを構成するときに、これらのオプションを使用します。

.topic 518
ドライバ固有の属性を構成する場合にクリックします。

.topic 701
パフォーマンスに影響を与えるドライバ オプションの詳細設定を行う場合にクリックします。

.topic 702
Access がディスクとの間でデータを転送するときに使用する内部バッファのサイズ (KB 単位) です。既定のバッファ サイズは 2048 KB です (2048 と表示)。256 の整数倍の値を入力します。

.topic 703
変更を保存しないでこのダイアログ ボックスを終了します。

.topic 704
Access データベースを作成する場合にクリックします。

.topic 705
既存の Access データベース内の無駄な領域を減らす場合にクリックします。

.topic 706
データ ソースの名前 (従業員名簿や人事など) を識別し、ODBC ドライバの検索対象となる既定のデータ フォルダを指定します。

.topic 707
現在選択されている Access データベースの場所です。データベースを選択するには、[選択] をクリックします。

.topic 708
データ ソース中のデータの説明 (たとえば、採用日付、給与履歴、現在の従業員の再評価など)。この説明は省略可能です。

.topic 709
このチェック ボックスをオンにすると、データベースは排他モードで開きます。同時にデータベースにアクセスできるユーザーは 1 人に制限され、パフォーマンスが向上します。オフにすると、データベースは共有モードで開きます。同時に複数のユーザーがデータベースにアクセスできます。

.topic 710
このダイアログ ボックスのヘルプを表示します。

.topic 711
システム データベースを使用しない場合は、このオプションを選択し、Access データベースに Admin (defaultUser) ユーザーとしてログインします。

.topic 712
セットアップ ダイアログ ボックスを終了して、変更を保存します。

.topic 713
未使用ページがバッファに保持される時間 (0.1 秒単位) です。既定値は 0.5 秒であり、0 より大きい数値にする必要があります。

.topic 714
そのデータベースを読み取り専用にし、更新されるのを防ぐ場合に選択します。

.topic 715
損傷した Access データベースを修復する場合にクリックします。

.topic 716
Access データベースを選択する場合にクリックします。

.topic 723
システム データベースを使用するときに選択します。次に、[システム データベース] をクリックします。

.topic 717
クリックすると、[システム データベースの選択] ダイアログ ボックスが表示され、使用するシステム (ワークグループ) データベースを選択できます。

.topic 718
Access データベースの場所を表示し、データベース保守機能を実行するときに、これらのオプションを使用します。

.topic 719
システム (ワークグループ) データベースを選択し、その場所を表示するときに、これらのオプションを使用します。

.topic 720
現在選択している Access のシステム データベースの場所です。

.topic 721
Access ドライバを構成するときに、これらのオプションを使用します。

.topic 722
ドライバ固有の属性を構成する場合にクリックします。


Access ファイル

ODBC デスクトップ データベース ドライバ 4.0 には、Microsoft Access ドライバ用の次の ISAM ファイルが含まれています。

32 ビット ISAM | Access のバージョン
なし。MSJET40.DLL に含まれています。 | 7.0 および 97。
MSRD2X40.DLL | 2.0
MSRD3X40.DLL | 3.0

注意 Windows 95/98 (Windows NT/Windows 2000 を除く) を使用する場合に、Access がコンピュータにセットアップされていない場合は、CONFIG.SYS ファイルに "FILES= 50" という行を追加してください。


Access のシステム データベース ログイン

あらかじめシステム データベースとして定義された Access データベースに接続する場合、[ログイン] ダイアログ ボックスで、許可された Access ログイン名とパスワードを入力できます。ログイン名とパスワードは、データベース管理者から割り当てられます。割り当てられたとおりに正確に入力する必要があります。

[データ ソース] には、接続するデータ ソースが表示されます。

注意 データ ソースが選択されていない場合、[データベース] をクリックするとデータ ソースを割り当てることができます。

ダイアログ ボックスを閉じてログイン処理を開始するには、[OK] をクリックします。

ダイアログ ボックスを閉じてログイン処理をキャンセルするには、[キャンセル] をクリックします。


共通の ODBC コンポーネント ファイル

次の表は、ODBC デスクトップ データベース ドライバ 4.0 の各コンポーネントが必要とするファイルを示しています。これらのファイルは、Windows 95 以降の場合には \Windows\System ディレクトリ、Windows NT または Windows 2000 の場合には \Windows\System32 ディレクトリにインストールされます。前に ODBC ファイルを別のディレクトリにインストールした場合は、必ず \Windows\System (または System32) ディレクトリにある新しいファイルを使用してください。

ファイルの中には、複数のコンポーネントで必要となるものがあります。デスクトップ データベース ドライバ 3.5 と共にアプリケーションを販売する場合は、これらのファイルを再配布する必要があります。

次に、各デスクトップ データベース ドライバに共通するファイルを示します。

DS16GT.DLL
DS32GT.DLL
EXPSRV.DLL
MSJINT40.DLL
MSJET40.DLL
MSJTER40.DLL
MSJTES40.DLL
MSVCRT40.DLL
ODBC16GT.DLL 		ODBC16GT.DLL
ODBC32.DLL
ODBC32GT.DLL
ODBCCP32.CPL
ODBCCP32.DLL
ODBCCR32.DLL
ODBCINST.CHM
ODBCINT.DLL 		ODBCJET.CNT
ODBCJI32.DLL
ODBCJT32.DLL
ODBCJTNW.HLP
ODBCJTNW.CNT
ODBCTL32.DLL
VBAJET32.DLL
ODBCTRAC.DLL


[最適化元データベース] ダイアログ ボックス

データベースを最適化すると、データベースの未使用領域が取り除かれて既存データが保存されます。[最適化元データベース] ダイアログ ボックスで、目的のデータベースを最適化することができ、最適化処理が行われている間のデータベースへのアクセスについて、読み取り/書き込み両用 (既定の設定)、読み取り専用 (更新の禁止)、または排他アクセスのいずれかを指定できます。

最適化を実行するには、[ODBC Microsoft Access セットアップ] ダイアログ ボックスを使用します。[最適化] をクリックし、[最適化元データベース] ダイアログ ボックスでファイルとパスを選択し、[OK] をクリックします。次に、[最適化先データベース] ダイアログ ボックスで、ファイルとパス、最適化先のファイルのバージョン、およびロケールを選択し、[OK] をクリックします。最適化先のファイルの名前は、最適化元のファイルと同じにすることもできます。最適化先のファイルの名前が別の既存ファイルの名前と同じ場合は、エラーが返されます。パスワードで保護された最適化元ファイルの結果は予測できない場合があります。


[データベースの新規作成] ダイアログ ボックス

作成する新しい Access データベースのフル パスを入力します。

Access ドライバを使用する場合、[作成] をクリックすると新しいデータベースを作成できます。

注意 この方法で作成したデータベースは、Access 7.0 以降でのみ使用することができます。

セットアップ時にデータベースを指定しないと、データ ソースに接続するときに、データベース ファイルを選択するように求めるメッセージが表示されます。

[データベースの新規作成] ダイアログ ボックスには、次のコントロールがあります。

[データベース名] [フォルダ] [ドライブ] | 新しいデータベースの名前と場所を指定します。
[ロケール] | そのデータベースに対してロケール (LCID)、すなわち、言語を設定します。
[書式] | Microsoft Jet データベース エンジンの書式。オプション。4.x バージョン (最新。Unicode 書式)、3.x バージョン (ANSI 書式)、2.x バージョン (ANSI 書式) があります。
[オプション] | [システム データベース] をクリックすると、共有可能なデータベースが作成され、ODBC データ ソース アドミニストレータの [システム DSN] タブに記録されます。 [暗号化] をクリックすると、この Access オプションが設定されます。Microsoft Jet データベース エンジンの Version 4.0 のリリースより、データベースを作成する際にデータベースを暗号化できるようになりました。詳細については、『Microsoft Jet データベース エンジン プログラマーズ ガイド』を参照してください。暗号化は、4.x バージョンの書式を選択したときにのみ行うことができます。


データ ソースの変換

ODBC デスクトップ データベース ドライバ Version 2.0 で使用される 32 ビット データ ソースは、Version 4.0 のドライバ用の 32 ビット データ ソースに自動的に変換されます。16 ビット データ ソースは変換されません。16 ビット データ ソースを 32 ビットに変更するには、32 ビット データ ソースを新規作成し、必要に応じて 16 ビット データ ソースを削除します。32 ビット データ ソースと 16 ビット データ ソースに同じ名前を使用することはできません。


dBASE ファイル

ODBC デスクトップ データベース ドライバ 4.0 には、Microsoft dBASE ドライバ用の次の ISAM ファイルが含まれています。

32 ビット ISAM | dBASE のバージョン
MSXBSE40.DLL ODDBSE32.DLL | dBASE III dBASE IV dBASE 5.0


[ODBC dBASE セットアップ] ダイアログ ボックス

[ODBC dBASE セットアップ] ダイアログ ボックスには、次のコントロールがあります。

[データ ソース名] [説明] | dBASE データベースを識別します。既定では、製造段階で割り当てられた名前になっています。[説明] フィールドに、データ ソースの説明を入力することができます。既定では、空白になっています。
[データベース] | インストールされている dBASE データベースのバージョンと場所を選択します。[現在のフォルダを使用する] チェック ボックスをオンにした場合は、[フォルダの選択] および [インデックスの選択] が使用不可になります。
[オプション] 次のドライバ オプションを変更する場合にクリックします。
  • [照合順序]。並べ替えに使用されます。

  • [ページ タイムアウト]。未使用のページがバッファに保持される時間 (0.1 秒単位) です。0 より大きい数値であることが必要です。

  • [排他]。データベースにアクセスするユーザーを 1 人だけに制限します。

  • [削除された行の表示]。削除マークで指定された行を検索できるかどうかを指定します。

  • [おおよその行数]。テーブル サイズ統計を近似値にするかどうかを指定します。

注意 このドライバの詳細およびプログラム情報については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「Microsoft Open Database Connectivity (ODBC)」の「ODBC Drivers」を参照してください。その他の情報については、このヘルプの「データ ソースの変換」、「dBASE ファイル」、「IISAM レジストリ エントリ」、および「共通の ODBC コンポーネント ファイル」を参照してください。dBASE は、INPRISE 社の製品であり、専用のヘルプ ファイルが付属しています。


[テキスト形式の定義] ダイアログ ボックス

[テキスト形式の定義] ダイアログ ボックスで、選択したファイルの列の書式を定義し、個々のデータ テーブルについてスキーマを指定できます。[テキスト形式の定義] ダイアログ ボックスには、次のコントロールがあります。

[テーブル] | [ODBC テキスト セットアップ] ダイアログ ボックスで選択したフォルダに入っているファイルのうち、指定した拡張子の一覧に適合するファイルの一覧が表示されます。 <default> を選択すると、列の一覧が無効になります。
[列名の見出し] | 選択したテーブルの 1 行目の列を列名に使用するかどうかを指定します。[テーブル] の一覧で選択した項目の書式が定義されていない場合の既定値は、False (オフ) です。
[書式] | 区切り記号付きと固定長のどちらかです。区切り記号付きの場合、使用する区切り記号の種類として、カンマ (CSV)、タブ、または特殊文字 (カスタム) が示されます。[テーブル] の一覧で選択した項目の書式が定義されていない場合の既定値は、[カンマ区切り (CSV)] です。 [書式] が固定長で、[列名の見出し] チェック ボックスがオンになっている場合、最初の行はカンマ区切りである必要があります。
[区切り記号] | 列の区切りとして使用するカスタム区切り記号の文字です。区切り記号は、必ず 1 文字とし、二重引用符 (") は使用できません。このコントロールは、[書式] ボックスで [カスタム区切り] を選択した場合に使用可能になります。
[スキャンする行数] | セットアップまたはドライバが、列および列データ型を設定するときにスキャンする行数です。[テーブル] の一覧で選択した項目の書式が定義されていない場合の既定値は、25 です。1 ～ 32567 までの任意の数値を指定できます。
[文字] | [ANSI] か [OEM] のどちらかです。OEM は、非 ANSI の文字セットであることを示し、[テーブル] の一覧で選択した項目の書式が定義されていない場合の既定値です。
[列] | [テーブル] の一覧で選択したテーブル内の列の列名が、テーブル内での列の順序に従って表示されます。
[データ型] | BIT、BYTE、CHAR、CURRENCY、DATE、FLOAT、INTEGER、LONGCHAR、SHORT、または SINGLE を選択できます。日付データ型には "dd-mmm-yy"、"mm-dd-yy"、"mmm-dd-yy"、"yyyy-mm-dd"、または "yyyy-mmm-dd" を使用します。ただし、"mm" は数字表現の月を表し、"mmm" は英字表現の月を表します。
[名前] | 選択された列の名前です。既存の列または新しい列に対して、新しい列名を指定するときに使用します。 [列名の見出し] チェック ボックスがオンになっている場合、表示された列名は無視されます。
[列幅] | CHAR または LONGCHAR の列については、値を変更できます。ほかのデータ型では、列幅は調整できません。値は、表示されません。[テーブル] の一覧で選択した項目の書式が定義されていない場合、既定値は 1 です。
[推量] | クリックすると、[書式] ボックスでの選択に基づいてそのテーブルの内容がスキャンされ、テーブル内の列のデータ型、名前、および幅が生成されます。これはテーブルの書式が区切り記号付きの場合に有効になります。[列] の一覧内の以前定義されていた列はクリアされ、新しいエントリに置き換えられます。[列名の見出し] チェック ボックスをオンにしていない場合は、"F1"、"F2"、... という列名が生成されます。 この機能は、64,513 バイト未満の列にのみ有効です。
[追加] | [データ型]、[名前]、および [列幅] フィールドの値に基づいて列を追加します。
[変更] | [データ型]、[名前]、および [列幅] フィールドの値に基づいて選択された列を修正する場合にクリックします。
[削除] | 選択した列を削除します。


Excel ファイル

ODBC デスクトップ データベース ドライバ 4.0 には、Excel 用の次の ISAM ファイルが含まれています。

32 ビット ISAM | Excel のバージョン
MSEXCL40.DLL ODEXL32.DLL | 3.0、4.0、5.0、7.0、97。

Excel ドライバは、Excel Version 3.0 より前の形式のファイルを読み込むことができません。ただし、このようなファイルは、Excel Version 3.0 以降で開き、Version 3.0、4.0、5.0、7.0、または 97 の形式で保存すると、このドライバで読み込めるようになります。


IISAM レジストリ エントリ

IISAM のレジストリ設定は、各 IISAM DLL について DLLRegisterServer 関数が呼び出されると記述され、DLLUnregisterServer 関数が呼び出されると削除されます。DLLRegisterServer 関数は、各 IISAM DLL ファイルを取得するために Jet ODBC 関数によって動的に呼び出されます。たとえば、任意の IISAM を使用して接続を確立しようとするとき、最初に失敗すると、ドライバは DLLRegisterServer 関数を呼び出してこの IISAM DLL ファイルを初期化し、再度接続しようとします。


[ODBC Microsoft Excel セットアップ] ダイアログ ボックス

[ODBC Microsoft Excel セットアップ] ダイアログ ボックスには、次のコントロールがあります。

[データ ソース名] [説明] | Excel ファイルを識別します。[説明] フィールドに、データ ソースの説明を入力することができます。既定では、空白になっています。
[データベース] | 既定のファイルの場所を変更するときに、これらのオプションを使用します。別の場所を指定する場合は、[バージョン] ボックスで選択したExcel 製品のバージョンに応じて、[フォルダの選択] または [ブックの選択] をクリックします。
[ドライバ] | [スキャンする行数] で、セットアップまたはドライバにより列および列のデータ型が設定されるときにスキャンされる行数を指定します。1 ～ 16 までの任意の数値を指定できます。 Excel ファイルが更新されるのを防ぐには、[読み取り専用] チェック ボックスをオンにします。

注意 このドライバの詳細およびプログラム情報については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「Microsoft Open Database Connectivity (ODBC)」の「ODBC Drivers」を参照してください。その他の情報については、このヘルプの「データ ソースの変換」、「Excel ファイル」、「IISAM レジストリ エントリ」、および「共通の ODBC コンポーネント ファイル」を参照してください。製品サポートもご利用いただけます。


[ODBC テキスト セットアップ] ダイアログ ボックス

[ODBC テキスト セットアップ] ダイアログ ボックスには、次のコントロールがあります。

[データ ソース名] [説明] | ファイルを識別します。[説明] フィールドに、データ ソースの説明を入力することができます。既定では、空白になっています。
[データベース] | 既定のファイルの場所です。別の場所を指定する場合は、[フォルダの選択] をクリックします。
[ファイル] | そのデータ ソースに関するテキスト ファイルのファイル名拡張子の一覧が表示されます。フォルダ内のすべてのファイルを使用するには、[既定 (*.*)] チェック ボックスをオンにします。指定した拡張子を持つファイルのみを使用する場合は、[既定 (*.*)] チェック ボックスをオフにして、必要な拡張子を個別に追加します。[既定 (*.*)] チェック ボックスがオフになっている場合、既定では、*.ASC、*.CSV、*.TAB、および *.TXT の拡張子が表示されます。 拡張子を追加するには、[拡張子] ボックスにその拡張子を入力してから [追加] をクリックします。拡張子は *.xxx という形式で入力してください。たとえば、.DAT ファイルを使用するには、「*.dat」と入力します。拡張子を削除するには、拡張子の一覧の中のその拡張子を選択してから [削除] をクリックします。
[書式の定義] | 選択したファイルの列の書式を定義し、個々のデータ テーブルについてスキーマを指定するには、[テキスト形式の定義] ダイアログ ボックスを使用します。 注意 Text ドライバを使用する場合、CREATE TABLE ステートメントを拡張子を省略して実行すると、拡張子を持たないファイルが作成されます。[テキスト形式の定義] ダイアログ ボックスで拡張子を持たないファイルを表示するには、[ODBC テキスト セットアップ] ダイアログ ボックスで拡張子の一覧に "*." を追加する必要があります。

注意 このドライバの詳細およびプログラム情報については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「Microsoft Open Database Connectivity (ODBC)」の「ODBC Drivers」を参照してください。その他の情報については、このヘルプの「データ ソースの変換」、「IISAM レジストリ エントリ」、「テキスト ファイルの ISAM ファイル」、および「共通の ODBC コンポーネント ファイル」を参照してください。


Paradox ファイル

ODBC デスクトップ データベース ドライバ 4.0 には、Paradox 用の次の ISAM ファイルが含まれています。

32 ビット ISAM | Paradox のバージョン
MSPDOX40.DLL ODPDX32.DLL | Paradox 3.x Paradox 4.x Paradox 5.x


製品サポート

Microsoft 製品の多くが ODBC をコア コンポーネントとして利用し、ODBC ドライバを再配布しているので、Microsoft 製品サポートは、ODBC がコンポーネントとして組み込まれた製品については、ODBC をその一部とみなします。ODBC の製品サポートは、その製品のサポート協定に従って提供されます。詳細については、個々の製品のマニュアルを参照してください。


[データベースの修復] ダイアログ ボックス

[データベースの修復] ダイアログ ボックスで、目的のデータベースを修復することができます。このダイアログ ボックスで、修復処理が行われている間のデータベースへのアクセスについて、読み取り/書き込み両用 (既定の設定)、読み取り専用 (更新の禁止)、または排他アクセスのいずれかを指定できます。

コミット処理の段階でクライアントでエラーが発生した場合は、関係するデータベースが損傷し、修復が必要になる場合があります。修復を実行するには、[ODBC Microsoft Access セットアップ] ダイアログ ボックスを使用します。[修復] をクリックし、[データベースの修復] ダイアログ ボックスでファイルとパスを選択し、[OK] をクリックします。


[データベースの選択] ダイアログ ボックス

セットアップ時にデータベースを指定しないと、データ ソースに接続するときに、データベース ファイルを選択するように求めるメッセージが表示されます。

Access ドライバを使用する場合、[ODBC Microsoft Access セットアップ] ダイアログ ボックスの [選択] をクリックすると、[データベースの選択] ダイアログ ボックスで既存のデータベースを開くことができます。[データベースの選択] ダイアログ ボックスには、次のコントロールがあります。

[データベース名] | .MDB 拡張子を持つ既存のデータベース ファイルの名前。
[読み取り専用] | そのデータベースを読み取り専用として指定し、更新されるのを防ぎます。
[排他] | 選択すると、データベースは排他モードで開かれます。同時にデータベースにアクセスできるユーザーは 1 人に制限され、パフォーマンスが向上します。オフにすると、データベースは共有モードで開かれます。同時に複数のユーザーがデータベースにアクセスできます。


[インデックスの選択] ダイアログ ボックス

[インデックスの選択] ダイアログ ボックスには、次のコントロールがあります。

[テーブル] | 現在選択されているデータ ソースに含まれているファイルがすべて表示されます。
[インデックス] | [テーブル] の一覧で現在選択されているファイルに割り当てられているインデックスの一覧が表示されます。
[ファイルの種類の一覧] | [インデックス] の一覧に表示されるファイルの種類を指定します。

ODBC dBASE ドライバは dBASE IV のインデックス ファイルを自動的に開いて更新します。[インデックスの選択] ダイアログ ボックスで、dBASE III .NDX ファイルを dBASE ファイルに関連付ける必要があります。

dBASE インデックスの作成時に、次の制限が適用されます。

  • すべてのフィールド名が有効であること。

  • すべてのフィールドの並べ替え順序が同じ (昇順または降順) であること。

  • どのテキスト フィールドの長さも 100 バイト未満であること。

  • 複数のフィールドが存在する場合、すべてのフィールドがテキスト フィールドで、フィールド サイズの合計が 100 バイト未満であること。

  • メモ フィールドをインデックス化できない。

  • 現在のフィールド セットに指定されていないインデックスであること。つまり、インデックスが重複して存在することはできません。

  • インデックス名が dBASE のインデックス名前付け規則に適合すること。dBASE III では、各インデックスが別々のファイルになっていて、.NDX 拡張子を持っていることが要求されます。dBASE IV では、インデックスがタグ名として作成され、それらのタグ名が、データベース ファイルと同じベース名を持つ単一の .MDX ファイルに格納されます。たとえば、EMP.MDX は EMP.DBF データベースのインデックス ファイルです。

インデックスをテーブルに関連付けるには

  1. [テーブル] の一覧からファイルを選択します。

  2. [インデックス] の一覧からインデックスを選択します。

  3. [OK] をクリックして、テーブルとインデックスの関連付けを保存します。

注意 dBASE III のインデックスをドライバが認識できるようにするためには、このダイアログ ボックスを使用してそれらを割り当てる必要があります。


[システム データベースの選択] ダイアログ ボックス

Access ドライバを使用する場合、[データベース] をクリックし、次に、[ODBC Microsoft Access セットアップ] ダイアログ ボックスの [システム データベース] をクリックすると、[システム データベースの選択] ダイアログ ボックスでシステム データベースを選択できます。システムのセキュリティ要件によっては、システム データベースの名前とパスワードの入力を求められる場合があります。既定の名前は Admin で、Admin ユーザーに対応する Access での既定のパスワードは空の文字列です。

[システム データベースの選択] ダイアログ ボックスには、次のコントロールがあります。

[データベース名] | .MDB 拡張子を持つ既存のデータベース ファイルの名前。
[読み取り専用] | そのデータベースを読み取り専用として指定し、更新されるのを防ぎます。
[排他] | 選択すると、データベースは排他モードで開かれます。同時にデータベースにアクセスできるユーザーは 1 人に制限され、パフォーマンスが向上します。オフにすると、データベースは共有モードで開かれます。同時に複数のユーザーがデータベースにアクセスできます。


[ブックの選択] ダイアログ ボックス

[ブックの選択] ダイアログ ボックスでは、Excel ブック ファイルの場所を指定および選択することができます。[データベース名] には、選択されているファイルが表示されます。ファイルの更新を防ぐには、[読み取り専用] チェック ボックスをオンにします。[フォルダ]、[ファイルの種類]、および [ドライブ] を使って目的のブックを検索するか、または [ネットワーク] をクリックしてネットワーク上のブックを検索します。


[詳細オプションの設定] ダイアログ ボックス

[詳細オプションの設定] ダイアログ ボックスを使用するには、まずこのサーバー用の [ログイン名] と [パスワード] を入力する必要があります。

システムのセキュリティ要件によっては、データ ソースでシステム (ワークグループ) データベースを使用するときに、ユーザー名とパスワードの入力を求められる場合があります。既定の名前は Admin で、Admin ユーザーに対応する Access での既定のパスワードは空の文字列です。

Access データベースにアクセスする場合、ドライバで使用される次のオプションを [詳細オプションの設定] ダイアログ ボックスで選択できます。

[DefaultDir] | ドライバがアクセスする既定フォルダです。
[Driver] | Access ドライバのカスタム名を入力するときに使います。
[ExtendedAnsiSQL] | 接続文字列の属性です。1 に設定すると、ビューおよびプロシージャの作成および削除、データ切断の検出、新しいデータ型、SQL-92 の予約語の使用などの Jet 4.0 の機能が有効になります。既定値は 0 です。0 の場合、Jet 4.0 の機能は無効です。
[FIL] | ファイル タイプです。Microsoft Access の場合は、"MS Access" です。
[ImplicitCommitSync] | トランザクションの外部で行われた変更をデータベースに書き込む方法を指定します。この値は "Yes" に初期設定されます。これは、Access ドライバが内部/暗黙トランザクションでコミットの終了を待機することを意味します。
[MaxBufferSize] | Access がディスクとの間でデータを転送するときに使用する内部バッファのサイズ (KB 単位) です。既定のバッファ サイズは 2048 KB です (2048 と表示)。256 で割り切れる任意の整数値を入力できます。これは、セットアップ ダイアログ ボックスの [バッファ サイズ] と同じオプションを設定します。
[MaxScanRows] | 既存のデータに基づいて列のデータ型が設定されるときにスキャンされる行数です。 1 ～ 16 の数値を入力します。既定値は 8 です。0 に設定した場合は、すべての行がスキャンされます。この範囲を超えるとエラーが返されます。
[PageTimeout] | 未使用ページがバッファに保持される時間 (0.1 秒単位) です。Access ドライバの場合、既定値は 0.5 秒であり、0 より大きい数値であることが必要です。このオプションは、Access ドライバにより使用されるすべてのデータ ソースに適用されます。
[ReadOnly] | そのデータベースを読み取り専用として指定し、更新されるのを防ぎます。
[SafeTransactions] | 0 (既定) の場合、すべてのトランザクションは即座にコミットされます。1 の場合、すべてのトランザクションはコミット操作が行われたときにのみディスクに保存されます。1 の場合は、パフォーマンスが多少低下します。
[Threads] | エンジンが使用するバックグラウンド スレッドの数です。既定では 3 になっています。データベースの活動が多い場合は、スレッドの数を増やすことができます。
[UserCommitSync] | Access ドライバによる明示的なユーザー定義トランザクションの非同期実行を指定します。既定値は "Yes" です。これは、Access ドライバがユーザー定義トランザクションでコミットの終了を待機することを意味します。 マルチユーザー環境でこの値を "No" に設定すると、予期しない結果が起こる可能性があります。


テキスト ファイルの ISAM ファイル

ODBC デスクトップ データベース ドライバ 4.0 には、Text ファイル用の 32 ビット ISAM ファイルが 2 つ (MSTEXT40.DLL および ODTEXT32.DLL） 含まれています。


[ODBC Paradox セットアップ] ダイアログ ボックス

[ODBC Paradox セットアップ] ダイアログ ボックスには、次のコントロールがあります。

[データ ソース名] [説明] | Paradox データベースを識別します。既定では、製造段階で割り当てられた名前になっています。[説明] フィールドに、データ ソースの説明を入力することができます。既定では、空白になっています。
[データベース] | Paradox データベースの場所を指定するか、現在のフォルダを使用する場合に、これらのオプションを使用します。インストールされているデータベースの特定のバージョンを選択することもできます。
[オプション] アクセス、サービス、およびパフォーマンスに影響を与える、次のドライバ オプションを変更する場合にクリックします。
  • [照合順序]。フィールドを並べ替える順序を指定します。

  • [排他]。アクセスするユーザーを 1 人だけに制限します。パフォーマンスが向上します。

  • [ページ タイムアウト]。未使用ページがバッファに保持される時間 (0.1 秒単位) を指定します。

  • [ユーザー名]。ロックが検出されたときに Paradox ファイルのほかのユーザーに表示される Paradox のユーザー名です。

  • [ネット スタイル]。Paradox データにアクセスする際に使用するネットワーク アクセスのスタイルです。

注意 このドライバの詳細およびプログラム情報については、msdn.microsoft.com から入手できます。「MSDN Online Library」、次に「Platform SDK」を開いて「Microsoft Data Access 2.5 SDK」を探してください。ここにある「Microsoft Open Database Connectivity (ODBC)」の「ODBC Drivers」を参照してください。その他の情報については、このヘルプの「データ ソースの変換」、「Paradox ファイル」、「IISAM レジストリ エントリ」、および「共通の ODBC コンポーネント ファイル」を参照してください。Paradox は、INPRISE 社の製品で、専用のヘルプ ファイルが付属しています。